Jump to content

Archived

This topic is now archived and is closed to further replies.

Kedmyster

Viewport animations from (top, right, bottom, left) doesn't work

Recommended Posts

Kedmyster

Hey,

 

I'm using the Pro version of DMS version 1.0.4.

I was trying to change the viewport animation property on a TextBox but it never stopped saving (the "Saving..." animation kept going forever).

I tried to apply it as a class to some element within MediaBox and again, it wasn't able to preform the action.

 

(By the way, the Fade animation for example does work - as far as I've seen, the problem is only with the From  [...] animations).

 

Has anyone encountered this issue?

Can someone check if it happens to him/her as well?

 

Thanks!

Share this post


Link to post
Share on other sites
Rob

Hi Kedmyster,

 

It sounds like you may have a plugin conflict.  Can you try deactivating the non-PageLines plugins to see if resolves the issue?


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Kedmyster

Hey,

 

Thanks for your response.

I tried disabling all plugins but the problem remains.

Did you check it yourself?

 

Thanks!

Share this post


Link to post
Share on other sites
Danny
HI, I am unable to recreate both your off your issues, therefore it is either related to plugins, custom scripts or your servers configuration. Can you disable all active plugins (keep them disabled), remove all custom scripts (if you have any) and then enable PL Debug mode (DMS Toolbar > Global Options > Advanced).

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Kedmyster

Alright so I enabled PL Debug without disabling anything just yet and looked at the console, this is what came out.

The first batch of alerts came when I changed Viewport Animation on a TextBox to "From Bottom".

The second batch of alerts came when I changed Viewport Animation on the same TextBox to "Fade".

Should I still disable all the plugins and try again?

Share this post


Link to post
Share on other sites
Rob

Yes, and return to Global Options > Advanced and under the Debug, click the link to run the report, copy and paste it here.

 

The report will contain important info we need to review.

 

Also, if you have a cache plugin, before deactivating it, make sure you clear the caches via the plugin's settings, then disable the plugin.

 

Thanks.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Kedmyster

Alright,

 

I disabled all of my plugins (non left active) and here Is the report.

WordPress Version : 3.6.1

Multisite Enabled : Yes

Current Role : Administrator

Framework Path : /var/www/vhosts/masta.co.il/httpdocs/wp-content/themes/dms

Framework URI : http://masta.co.il/wp-content/themes/dms

Framework Version : 1.0.4

Framework Build : 1.0.4

PHP Version : 5.3

Child theme : Yes
/var/www/vhosts/masta.co.il/httpdocs/wp-content/themes/Masta
http://masta.co.il/wp-content/themes/Masta

PHP Open basedir restriction : Yes!

PHP memory : 256

Mysql version : 5.1.69

PHP type : Cgi-fcgi

PHP User : Posix functions are disabled on this host!

OS : Linux

Licence OK : [email protected]

Again, I noticed i'm getting 403 error (forbidden)  from admin-ajax.php.

As you've probably gathered already, the above is evidently just a symptom, it appears I can't add some new sections like Simple Nav as it also uses admin-ajax.php.

 

Thanks in advance!

Share this post


Link to post
Share on other sites
Kedmyster

I don't know if it's relevant but the file permission on admin-ajax.php is 646, here is my .htaccess file which located on the root directory:

RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

# add a trailing slash to /wp-admin
RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
RewriteRule . index.php [L]

# ---Enable file compression using mod_deflate
AddOutputFilterByType DEFLATE text/html text/plain text/xml text/css text/javascript application/javascript

# ---Caching
Header unset Pragma
FileETag None
Header unset ETag
 
# cache images/pdf docs for 10 days
<FilesMatch "\.(ico|pdf|jpg|jpeg|png|gif|js|css)$">
  Header set Cache-Control "max-age=864000, public, must-revalidate"
  Header unset Last-Modified
</FilesMatch>
 
# cache html/htm/xml/txt diles for 2 days
<FilesMatch "\.(html|htm|xml|txt|xsl)$">
  Header set Cache-Control "max-age=7200, must-revalidate"
</FilesMatch>

Share this post


Link to post
Share on other sites
Danny

Can you backup your htaccess file and then delete the one from your server. Once done, go to Wordpress Admin Dashboard > Settings > Permalinks and click save, this should create a new .htaccess file.

See if this resolves your issue.

 

Also, you have the following on your server, I recommend you contact your webhost provider and ask them to address:

 

PHP Open basedir restriction : Yes!

PHP User : Posix functions are disabled on this host!


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Kedmyster

I deleted the file from the root directory and acted as you said, but it didn't re-create the htaccess file and when I tried to access the site, it was all broken (css-wise) so I couldn't test it if fixed the problem.

 

I contacted my hosting, see if there's anything they can do.

 

Regarding

 

PHP Open basedir restriction : Yes!

PHP User : Posix functions are disabled on this host!

 

Should Open basedir restriction be set to No?

Should Posix functions be enabled?

 

Thanks.

Share this post


Link to post
Share on other sites
Danny

Wordpress should regenerate a .htaccess file, if it doesn't then, go to Wordpress Admin Dashboard > Settings > Permalinks and choose a different setting from the one you currently have it set to, then click save. This should recreate your .htaccess file.

 

Regarding the server functions:

 

Open basedir restriction should be set to No.

Posix functions should be enabled


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • John Olsson
      By John Olsson+
      Hi, sometimes this happens, a footer image suddenly gets this animation on it, look at the video link here so you get what I talking 'bout.
      Can't recall that I've done something to make this happen..
       
    • bartok
      By bartok+
      Why is the auto animation on my quickslider not disabled? Why is it automatically animating? I have the option unchecked in settings but it continues to animate automatically. Answer? Webpage is: grantturck[dot]com/digital
    • swiftitnz
      By swiftitnz
      Hi Guys,
      I have been working on http://versiontwo.trustbasedrealestate.com/ for some time and use DMS2 (skeleton as child theme) for it. The primary domain (http://trustbasedrealestate.com/) is forwarded to the 'versiontwo' site with permanent forwarding + url masking. 

      The trouble I'm having is, when I load the site with http://versiontwo.trustbasedrealestate.com/ url, the site and all the contents( including the viewport animations) load fine. However, when I try to load the site with http://trustbasedrealestate.com/ url, the site doesn't load correctly.
      Please note:
      I'm not using any caching plugin I checked the URL forwarding and it's all ok Tried with 3 different browsers, even with cache/cookies emptied. Can anyone please suggest anything?
      Thanks in advance.
       
       
       
    • tjolin
      By tjolin+
      Hi all, 
       
      Anyone knows how to disable the transparency on the "translate on scroll" animation? 
      Been going crazy trying to edit this for the last couple of weeks. 
       
      TIA!
    • mccooluk
      By mccooluk
      Some of the built in animation effects on Pagelines can cause problems when using mobiles/iPads as they only kick in once the user stops scrolling, meaning it is possible to scroll past a section without seeing the content, for example, mediabox images that fadein.
       
      I would like to turn off/disable animations on mobiles/ipads. From another post I found the following:
       
      <script>
      jQuery( document ).ready(function() {
        var width = jQuery(window).width()       
          if( width < 480 )
          jQuery('div').removeClass('pl-animation')
      });
      </script>
       
      Unfortunately this disables the mediabox image from loading at all. Is there a way to set it so that the pl-animation is disabled, but after the animations have taken place?
       
      Thanks
       
      Chris
×