Jump to content

Archived

This topic is now archived and is closed to further replies.

pureandsimpleblog

Script Issue

Recommended Posts

pureandsimpleblog

I am on pureandsimpleblog.com

 

I added a script to my less.function.php file yesterday. I realized that the script is showing up in my header. I went in to the php file and deleted the script and it is still showing up on my homepage even though it is no longer in the php file.

 

The script also keeps showing up in my dms script section. I keep deleting it, but it just reappears.

I have tried clearing my cache multiple times as well.

 

This does not seem to be showing up in Chrome, but is doing this in IE and Firefox.

 

 

Share this post


Link to post
Share on other sites
Jake

Hi pureandsimpleblog - If you're going to add hooks, and functions, you'll need to start with a child theme as we can't provide support to sites with changes made to the core files. You should probably start by replacing the original functions file via FTP and then follow the instructions here for setting up a child theme. http://docs.pagelines.com/customize/base-child-theme.


Have you searched the forums yet or checked out the DMS user docs?

PageLines geek, blogging at MyUntangledLife.com

Share this post


Link to post
Share on other sites
pureandsimpleblog

Jake - Thanks. I am entirely self-taught/making up how to do my site design as I go. I had no idea I was doing something outside of support. What will happen if I replace the original functions file and how do I even do this??

 

Also, even though I edited the php file, the issue seems to be in the scripts section on dms. I have deleted the data from the php file and my hosting provider can't find the code anywhere. The issue seems to be that the script keeps reappearing in the DMS editor in firefox even after I have deleted it.

Share this post


Link to post
Share on other sites
Jake

Hi pureandsimpleblog - No worries, it's a common newbie mistake but makes for an incredible amount of trouble down the road and impossible for us to support so I wanted to make you aware right away.

 

It's tough to picture what's going on in there and would be easier to take a look under the hood. Would you be comfortable sending an email to [email protected] with a username/password to log into your site?


Have you searched the forums yet or checked out the DMS user docs?

PageLines geek, blogging at MyUntangledLife.com

Share this post


Link to post
Share on other sites
James B

What was the script for? I can see you have some code in the script file inside your header scripts box still - http://screencast.com/t/alqRwR0gC but it doesn't seem to reflect the code showing at the top of the site. Do you have wp-debug turned on in the wp.config?

 

If you can paste the script you entered, was it definetly entered into the functions.php? You can re-install the core DMS files via ftp to override the existing theme, this will overwrite any previous changes you made to the core file.

 

I would also advise deactivating your cache plugin completely when making changes on the site so you can see them reflected afterwards etc.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

×