Jump to content

Archived

This topic is now archived and is closed to further replies.

digamama

Dropdown menu issue...gap in margin

Recommended Posts

digamama

Hello everyone! 

 

I'm having an issue with my website (here's the link...screenshot also attached). If you take a look you'll see that the top navigation (the item titled 'Advisory') has one item listed below it ('Case Studies'). That dropdown has additional pages under it, so it's Advisory --> Case Studies --> list of items. The problem is there's a huge vertical gap between the first dropdown option and submenu options. I hope I'm making sense...

 

Can you please help me find the CSS selector to align the sub-drop down menu? 

 

[attachment=1607:Screen shot 2013-10-02 at 10.41.25 AM.png]

Share this post


Link to post
Share on other sites
Danny

Hi,

 

Your issue is related to your custom CSS, this snippet is the cause of the issue.

 

ul.sf-menu ul.sub-menu, ul.sf-menu ul.children {
width: 12.5em !important;
}

Removing that will resolve your issue.

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Danny
No problem.

Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Liv Kundalini
      By Liv Kundalini+
      Hi -
      Pulling my hair out over here, and would love an assist!
      Site I am building, http://www.livkundalini.com/home, has a problem with the submenu items in the nav not appearing. 
      If anyone wants to see what the Nav should look like, feel free to look in the footer on the left hand side.
      Have tried disabling Pagelines and using the twentyseventeen theme, but problem persists.
      Saw this error (pasted at the bottom of this post) displaying in the inspector, and saw discussion of Jetpack potentially being a culprit. Disabled Jetpack, but the problem persists.
      Had the hosting company even flush the server-side cache, but no avail.
      Any thoughts? Please? It's the only thing keeping me from launching this site!
      Many Thanks,
      Todd
       
      WebSocket connection to 'wss://public-api.wordpress.com/pinghub/wpcom/me/newest-note-data' failed: Error during WebSocket handshake: Unexpected response code: 403   O @ (index):7
    • russe-intensif
      By russe-intensif+
      Hi team,
      checking my site today, i'm surprised to see my MegaNav all in bottom of the pages, while it's in header.
      After getting to change it in couple of pages onto Template part (too time consuming !), i'm desperate and ask you for help :-)
      apprendre-le-russe-avec-ania.fr
      Thank you in advance !

    • dwpoyner
      By dwpoyner+
      Not sure exactly what is causing the issue. For some reason, why you view my site on mobile, the menu does not show up. It will pop up, but it is black. You can check it out here: http://dev.caryfbc.org. I'm also attaching a screenshot where I shrunk my browser down. Any suggestions?

    • mrmyth
      By mrmyth
      Hello:
      I have several sites on Host Gator that have been using Platform Pro. This template was great for me until recently, when after a Word Press update, all the sites just have the page heading and all the rest of the content doesn't display.
      Thanks for your help.
       
×