Jump to content

Archived

This topic is now archived and is closed to further replies.

leftcoastmichael

Specify horizontal location of RevSlider slide text

Recommended Posts

leftcoastmichael+    4
leftcoastmichael

Hi. Just wondering what the short code is for specifying the horizontal location of the RevSlider slide text.  Looks fine on browser but it's cut off in mobile view....

 

eMmSp3H.png

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there,

 

There isn't a shortcode for the text alignment in the mobile view specifically. We we take a live url to the page so we can see first hand what's happening in the code for you.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
leftcoastmichael+    4
leftcoastmichael

James B, It's ok if there's no short code for the mobile view; I don't mind adjusting the text in the main view so that it accommodates the mobile view.

 

http://leftcoastlogic.com/products/ampm

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi,

 

To change a specific aspect for mobile devices such as tablets or phones, you will need to use @media queries, you can not do it via a shortcode. For more information on @media queries see here - http://css-tricks.com/snippets/css/media-queries-for-standard-devices/

 

However, when I view your site and resize my browser window, my console displays a large number of errors that is constantly increasing when I change the width of my browser. These errors are coming from both jquery and resize scripts. Therefore, you most likely have a custom script or plugin that is causing this error, which is preventing your text from resizing correctly.

 

I recommend you disable all active plugins (except for DMS Pro Tools) and any custom scripts and see if this resolves your issue.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
leftcoastmichael+    4
leftcoastmichael

 

 

 

 

I recommend you disable all active plugins (except for DMS Pro Tools) and any custom scripts and see if this resolves your issue.

 

Danny, that didn't seem to work. In the case of the right-aligned text, it's simply too long.  I think the solution would be to simply reposition the text - in the browser view (forget about mobile view). Is there a way to do this?  For example, can I just over-ride the code to place the text at any x/y coordinates? I know you can do that for "slide extra elements" such as embedded videos. 

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Yeah, if you want to add your own text in its own position, you can use the options via x/y. See my reply here explaining how to add a video, you can use this as a base for your custom text.

 

http://forum.pagelines.com/topic/28168-revslider-how-to-add-video-and-have-it-resize-properly/page-2#entry171007

Remember to view the inline documentation link which takes you to the revsliders documentation.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • JawDesigns
      By JawDesigns
      Hi everyone,
      Flywheel have reported errors on my clients site 'www.racewaredirect.co.uk' and it's not loading. Can someone please provide some information on how to fix this? The site has never experienced these issues before.
      Thanks,
      James Wilson
    • MissT
      By MissT+
      Hi there,
      I've got an issue with 3 websites built with DMS since I migrated them from http to https that I need help with please.
      When any changes are made - e.g. new posts added or existing posts amended - certain sections of the live site seem to break e.g. image headers hang and don't load (b/g on canvas section), sliders hang and don't load (Revslider), flipper section doesn't load.
      Logging in and then clicking 'Edit the site using DMS' seems to fix the problem. Often if I try to open up another browser window to edit the site / re publish I'm unable to as the page wont load / hangs while trying to load.
      Any ideas how to fix this? On a couple of the sites I've installed a caching plugin as I thought it might be a loading speed issue but it's still happening.
      Website URL's can be provided privately.
      Many thanks in advance.
    • jeomiland
      By jeomiland+
      Hi
      I found this topic
      which talks about a similar issue I am having, but a little different. Hope someone can help me out.
      Best way to see the problem is to view http://cassclayton.com/ on Safari (Mac) compared to Firefox or Chrome. You will see the banner just under the fixed menubar has a gap between the menubar and top of the banner. Looking at Inspector, I found:
      <div class="fixed-top-pusher" style="height: 62px;"></div>
      <script> jQuery('.fixed-top-pusher').height( jQuery('.pl-fixed-top').height() ) </script>
      and indeed it seems the jquery is not always working consistently. For instance, if you simply refresh the page in Safari, it will loose the gap and all looks fine, so is it a browser cache issue that is interacting with the jquery? I do have W3 Total Cache installed. There must be a way to tell the code to make sure jquery is up and running and available to do it's majic?
      And perhaps there is just a better way to do this banner? Originally I tried several DMS sections and used the banner image as background, etc... Kept running into problems with resizing and the left/right parts of the image were getting chopped off. It is important the whole image show, so currently I just use a NextBox section with this code:
      <img src="[pl_site_url]/wp-content/uploads/2015/12/CassClayton-blues-tribute-banner.jpg" width="100%" />
      and it looks the way it should. Is there a better way to place a banner graphic under a fixed navbar and make sure the whole banner graphic displays regardless of screensize?
       
    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      every since Chrome introduce scroll anchoring (see chrome://flags) blog posts on my page start scroll automatically as soon as the user scrolls down a bit. It is super annoying and I don't know exactly what triggers the incompatibility with Chrome's latest feature that is supposed to improve usability.
      Since I don't know what causes it (Pagelines, or a Plugin), I would like to disable the feature using a CSS override that Google describes as follow:
      "Scroll anchoring aims to be the default mode of behavior when launched, so that users benefit from it even on legacy content. A CSS property overflow-anchor can disable scroll anchoring in part or all of a webpage (opt out), or exclude portions of the DOM from the anchor node selection algorithm. This property supports the following values when applied to an element E:
      overflow-anchor: auto (the default value) declares that the DOM subtree rooted at E is eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E. overflow-anchor: none declares that the DOM subtree rooted at E is not eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E." Do you guys happen to know how to use that property with the ROOT element so it applies to the whole page?
      Thanks
      Michael 
    • oseehys
      By oseehys+
      Hello There,
      So i want to use platform 5 and DMS sections on a single page, i am using a child theme with pinspro as my main theme and i activated platform 5, the only problem am having so far is the fixed option, my navbars are not aligning to their default size, and it will be great if platform 5 header and footer section will function, has anyone used this option, how can i make the best use of platform 5 and DMS on a site
      Cheers
×