Jump to content

Archived

This topic is now archived and is closed to further replies.

sethoof

embedded video on homepage blog post

Recommended Posts

sethoof

I wanted to post a video in the exceprts of blog posts that load into the blog page.  Through this forum post, I figured out that by putting the video in he top of the post and allowing <iframe> tags, I cold get the effect I wanted.  But the problem I am having is that the embedded video on the excerpt in the blog page is bleeding into the column on the left.  I thought this might be a problem of padding due to other forum comments and my look with firebug.  But my edits to try and adjust that have not fixed the problem.  I suspect I am just not hitting the right styling as I am not great with firebug, but would appreciate a little expert support to help me sort this out.  Page is http://www.opfistula.org/blog/

 

Thanks in advance for your help!

 

best,

seth

Share this post


Link to post
Share on other sites
Danny

Hi,

 

The issue isn't padding or anything like that, it's simply caused by the fact that your content width is 495px and your videos iframe has a width set to 560px, you will need to change the width in your iframe videos html. Doing so should resolve your issue.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
sethoof

This is the embed code copied directly from youtube and pasted into the post. I am trying to avoid any additional edits for the writer who will post on this blog.

 

If it is a probably of width, why then does it stay within the content frame on the post, but bleed over on the blog?   Is there something I can change in the settings to have the blog page follow the same format as the posts?

Share this post


Link to post
Share on other sites
Danny

This is most likely caused by the way you have added it to the excerpt, how have you added it? Either way, the iFrame is too large for the content area. I would recommend one of following:

 

Reduce the width of the iFrame so that it isn't wider than your content width

Increase the width of your website thus increasing the width of your content area

Embed your videos using the Responsive Video shortcode (neat bottom of page) - http://docs.pagelines.com/tutorials/shortcodes


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
sethoof

I tried the responsive video shortcode earlier and it is great, but it doesn't show up at all on the blog page.  My first thought was to make the video smaller, but given that it was not a problem on the post page, I thought there would be a way to make the blog page follow suit.  I suppose I have no choice other than to just make the video smaller.  But I find it a bit disappointing that no one can help explain why the video fits itself into the post page just fine, but does not manage to do the same thing on the blog page. No offense, Danny, but this is a pretty lazy support response.  Definitely less nuanced than the help I got prior to the DMS launch. I suppose the team is reoriented to the next revenue opportunity...

Share this post


Link to post
Share on other sites
Danny

I apologise, if you feel my response was lazy.

 

However, I asked the question in my response "This is most likely caused by the way you have added it to the excerpt, how have you added it?"

If you can provide this information, I may be able to assist you.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
sethoof

Sorry, Danny.  I missed that question - a bit lazy of me ;)  I tried to paste a screen shot, but coulnt get it to work. I pasted the embed code into the Text tab of where you write the post before I wrote any other post text.

 

<iframe width="560" height="315" src="//www.youtube.com/embed/PnkynNkgHPI" frameborder="0" allowfullscreen></iframe>
 

Share this post


Link to post
Share on other sites
Danny

Ok, so I can try and recreate your issue can reply with the following information please. (when adding screenshots, use a service like https://droplr.com/hello or take a screenshot and upload to

http://imgur.com/
and then provide the link to the image.

 

1. Take a screenshot of your Layout Setting in the DMS Toolbar so I can see the width of your site.

2. Take a screenshot of your Wordpress Admin Dasboard > Post > the post in question, so that the screenshot shows both your Post content

3. Take a screenshot of your Posts excerpt, again in the Wordpress Admin Dashboard > Posts > your post in question

 

Once I have this info, I will try and recreate your issue.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
sethoof

Thanks, Danny.  Here are the screenshots. http://imgur.com/a/5oklP#0  The post excerpts are created when the blog page is formed.  I don't know where to get a screen shot of the post excerpt in the admin dashboard.

Share this post


Link to post
Share on other sites
sethoof

Not sure why it keeps posting that the link is dead, but try this

Share this post


Link to post
Share on other sites
Danny

Ok, the screenshots aren't working. 

Can you email me your admin username and password please so I can take a closer look.

 

danny at pagelines dot com


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Danny

The email you sent just tells me you have setup an account. However, it doesn't contain any details ?

 

Can you provide me with an admin username and password please, also include the link to your site as well.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
sethoof

Just sent it seperately from what wordpress should have sent you. cheers,

s

Share this post


Link to post
Share on other sites
Danny

Add the following code to your custom CSS, this should resolve your issue:

 

#site .post-excerpt iframe {
max-width: 100%;
}

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
sethoof

Thanks, Danny!!  This worked perfectly! Appreciate your patience and committment to helping me get this sorted!

Share this post


Link to post
Share on other sites
Danny

No problem.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

×