Jump to content

Archived

This topic is now archived and is closed to further replies.

Toby

Tag Cloud & Search Results Not Displaying Excerpt

Recommended Posts

Toby    2
Toby

Hi I am having trouble getting the excerpt to display when a search or tag result is displayed on my site.

 

Here is a link to an example:

http://www.innovativethinkingit.com.au/tag/analytics/

 

As you can see the top result has only the title displayed while the bottom result has the title and excerpt, is there a reason the top result is not displaying the excerpt?

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi,

 

Not sure to be honest, but it could be that the title contains the tag word and the excerpt doesn't, where as the second search result has the tag word in its excerpt. I would recommend you try Relevanssi, its a pretty cool search plugin.

 

http://wordpress.org/plugins/relevanssi/


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

What do you mean, would the plugin effect tag results ?

The plugin I linked above, has tons of options on improving your sites search.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Toby    2
Toby

Sorry, yes i mean will it affect the tag results or just search results.

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

I haven't used the plugin in months, but from what I can remember it does work with tags. Best thing to do is try it.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Toby    2
Toby
Ok, I'm am working with it at the moment, I'll see how I go.
Thanks for the help as always :)

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

No problem.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • John Olsson
      By John Olsson+
      Hello, i'm working on a webshop, and got this code to really boost the search within WP. But when adding this code to functions.php the front end media library search flipped totally, and not working at all, any ideas what's the problem?
      function atom_search_where($where){ global $wpdb; if (is_search()) $where .= "OR (t.name LIKE '%".get_search_query()."%' AND {$wpdb->posts}.post_status = 'publish')"; return $where; } function atom_search_join($join){ global $wpdb; if (is_search()) $join .= "LEFT JOIN {$wpdb->term_relationships} tr ON {$wpdb->posts}.ID = tr.object_id INNER JOIN {$wpdb->term_taxonomy} tt ON tt.term_taxonomy_id=tr.term_taxonomy_id INNER JOIN {$wpdb->terms} t ON t.term_id = tt.term_id"; return $join; } function atom_search_groupby($groupby){ global $wpdb; // we need to group on post ID $groupby_id = "{$wpdb->posts}.ID"; if(!is_search() || strpos($groupby, $groupby_id) !== false) return $groupby; // groupby was empty, use ours if(!strlen(trim($groupby))) return $groupby_id; // wasn't empty, append ours return $groupby.", ".$groupby_id; } add_filter('posts_where','atom_search_where'); add_filter('posts_join', 'atom_search_join'); add_filter('posts_groupby', 'atom_search_groupby');  
    • Queue-it
      By Queue-it+
      HI,
      Search function doesn't seem to work. 
      When ever searching for something it redirect to the home page and add the search string to the url.
      For example searching for "cases" it would display https://queue-it.com/?s=cases
      Do you know how to solve that? 
    • MissT
      By MissT+
      Would be great to have the ability to include a search option within menus and within Splashup - is this possible?
    • balfred1345
      By balfred1345
      null When I tested Search using the search field in Navi, it throws the error as shown in pastebin: http://pastebin.com/DJ079bmy
      Is there a fix for this? If there is no fix, can you please tell me how to disable search in Navi?
      Thanks,
      Bruce
    • mno
      By mno+
      Is there a way to mass apply a template to all tag archives?
      We are using Powerloop
×