Jump to content

Archived

This topic is now archived and is closed to further replies.

hajobakker

Fontawesome and pagelines

Recommended Posts

hajobakker

Guys,

 

Something keeps happening to fontawesome display in pagelines. This boils down to cross-domain access, caught by Firefox.

 

What I see on one out of three sites is that for some reason fontawesome icons are transferred in https vs http.

I'm running in network mode and have an ssl certificate for one domain only so transfer of the font fails.

 

There are workardounds pointing to .htaccess modifications though your ISP needs header_c complied in Apache for that to work.

 

Thing is: even docs.pagelines.com presents these errors: check out a screenshot at http://www.hajobakker.com/?attachment_id=864

 

 

Setup: wp 3.6.1, network / domain mapping / multilanguage / wp super cache / widget logic

Share this post


Link to post
Share on other sites
hajobakker

Hi,

 

This has been brought to our attention before. See here for more info - http://wpvkp.com/font-awesome-doesnt-display-in-firefox-maxcdn/

 

Thanks Danny,

 

For some this is woule be a nice workaround - provided your ISP compiles Apache with mod_headers.c - but not a solution.

Instead of using the original URL, somehow somewhere a variable is overwritten and httpd used for transfer instead of http.

Firefox is not in any way responsible for this behaviour and is basically the only browser adhering to cross-domain standards.

 

If this is the way it is I'll just drop fontawesome and themes making use of it, a shame to think about this but the way it is.

 

Thanks anyway, guess it's time for me to reconsider.

Share this post


Link to post
Share on other sites
Danny
I understand that the issue does not lie with FireFox or IE and they're following the Cors standard. However, I am not entirely sure why you keep mentioning your ISP, what does your ISP have to do with CORs? I assume you mean your web host provider and not your Internet Service provider ? I will report this to our developers and see if there is anything we can do. However, you will most likely need to use the .htaccess trick provided on the link above.

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
hajobakker

Sorry Danny, you're right and I'm tired I guess. I indeed did intend my hosting provider, sorry.

Share this post


Link to post
Share on other sites
Danny

:D No problem, was just confused thats all. I've created an issue in our tracker, hopefully our devs will be able to provide an alternative. If thats not the case, then you will need to use the .htaccess snippet.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Michael Kummer
      By Michael Kummer+
      Hi guys!
      I have noticed that my primary sidebar becomes intermittently invisible when browsing through various blog articles on michaelkummer.com/blog.
      See:
      https://www.dropbox.com/s/z646sgoa3mfjl1j/Screenshot 2018-07-12 15.57.46.jpg?dl=0 and https://www.dropbox.com/s/vdledzzgginvwgv/Screenshot 2018-07-12 15.57.57.jpg?dl=0
      Upon refresh, the sidebar appears. I have been using the following CSS code to hide the sidebar on mobile without any issues. 
      @media only screen and (max-width: 993px) {
      /* hide sidebars */
           .plsb {
              display: none !important;
          }
      }
      I tried to add the following CSS to force the sidebar to show on screens that are wider than 994 pixels but to no avail. Any clue what could be causing this issue?
    • Michael Kummer
      By Michael Kummer+
      Hi guys!
      I am using the LESS/CSS Pagelines extension and tried to add the following code to make use of FontAwesome:
      a.c2a:before {
          content: "\f07a\00a0";
          font-family: "Font Awesome 5 Pro";
          Font-weight: 900;
          font-style: normal;
          font-weight: normal;
          text-decoration: inherit;
          padding-left: 4px;
      }
       
      The issue is that as soon as I have the CSS via the Custom Styling text box, Pagelines (or the extension) strips out the backslashes (\). As a result, I had to abandon the CSS/LESS extension and instead add all my CSS code to a separate .css file.
      Is there a fix or workaround for this?
      Thanks
      Michael
    • MiraAdmin
      By MiraAdmin+
      Looking for some help on a recently developed issue. Editor will not load. 
      Theme:  DMS2
      Error from:  Chrome - Inspector - console view
      Error message: Refused to execute script from 'http://xxxx.xxx/wp-content/themes/dms/dms/editor/js/gettext.js/?ver=4.9.7' because its MIME type ('text/html') is not executable, and strict MIME type checking is enabled.
      Occurs on all sites on same server. 
      WP versions to 4.9.5, 4.9.6, 4.9.7 = same behavior. Worked properly on these same versions until 07/04/2018.
      No new plugins. Isolating plugins offers same behavior. 
      Server vendor reports no changes, patches, etc. 
      Server re-starts no impact.  

      Thank you. 
    • glyph.marketing
      By glyph.marketing+
      Hello, I am having a problem similar to that experienced by Michael Kummer here. We have pages that show this automatic scrolling issue (examples here and here) and it is sufficiently annoying that we have seen customers bounce while trying to convert. Strangely, it only happens at specific resolutions, so it can be difficult to reproduce. In general we can only consistently reproduce it on a 4k resolution with a browser width between 1517 and 1536px. 
      Thanks to Michael Kummer's help we were able to set the overflow-anchor property to none in the entire body, which fixed the issue as far as we can tell, but also obviously disabled scroll anchoring for the whole site. I tried applying it to the specific element that looked like it was being reloaded, which was the PL Meganav extension, but that was unsuccessful. 
      Can anyone help us figure out which element or ID we can apply this property to, so that we can fix the scrolling issue but not disable scroll anchoring for the entire site?
      Thank you - 
      Glyph Language Services
    • marshallsolutions
      By marshallsolutions
      For the site https://marshallsirishpub.com I am running
      Wordpress 4.9.4
      Pagelines base theme 1.0.2
      Pagelines Framework 2.5.0
      The share bar specifically Stumble Upon is causing an error when checking SSL for HTTPS at whynopadlock.com.  Here is the errors shown:
      A file with an insecure url of "http://cdn.stumble-upon.com/js/badge_su.js?v=20120613" was loaded on line: 1 of https://www.stumbleupon.com/badge/embed/2/?url=https%3A%2F%2Fmarshallsirishpub.com%2F.
      A file with an insecure url of "http://cdn.stumble-upon.com/css/badges_su.css?v=20120613" was loaded on line: 1 of https://www.stumbleupon.com/badge/embed/2/?url=https%3A%2F%2Fmarshallsirishpub.com%2F.

      Errors that are reported on line 1 are generally not part of the source code. This error may be caused by an external javascript file which is writing to the page, however we are unable to reliably detect these scripts in our automated test.
      Please contact us using the "Need Help?" link below if you need assistance with resolving this error.
      I contacted support at Really Simple SSL which is the plugin we use to convert the site to HTTPS via SSL.  They said I should contact you guys.  Here is what their support had to say via email:
      the sharing bar seems to load the Stumbleupon script over http:// despite being trying to redirect it to https://. The cdn.stumbleupon doesn't seem to have an SSL certificate and therefore refuses to load over https://. I'd suggest to contact the developer of the sharing plugin, the Stumbleupon button can de designed in another way, without it trying to load a script over http://.
      So it seems I need to modify some file in pagelines to make the stumble upon portion of the share bar to read https and not http.  If that's not possible then I need to remove stumble upon from the share bar.
      Thanks.
×