Jump to content

Archived

This topic is now archived and is closed to further replies.

rafaeldesilva

Blog paging not working

Recommended Posts

rafaeldesilva    0
rafaeldesilva

Hello, my blog page only shows las blog page, when I clic "previous entries" it goes back to first page instead of http://example.com/blog/page/2/

 

I guess it might be related with a problem I've detected, evrytime I hit any action in admin panel, htaccess file gets modified (reset to default), might this be related to Pagelines Framework? It's happening since last update (big update, I also updated some other plugins, also from Pagelines family).

 

What should be a correct htaccess for correct paging? This is my htaccess now:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

Plus, another cuestion: not all my entries or categories are shown in blog page/category, where do I config which categories show up in this page?

 

Thank you

Share this post


Link to post
Share on other sites
Rob    547
Rob

The code you have in .htaccess is absolutely correct.  Here's mine for comparison:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

Framework has no reason to re-write your .htaccess file.  Very likely that is a server related problem, such as permission or ownership, which requires the attention of your hosting company.

 

It could be a plugin having a conflict with the last Wordpress update.  Try deactivating the plugins via Dashboard > Plugins > Installed Plugins and see if this helps.

 

Did you re-save the permalinks? This is often a good easy step.  To do this, go to Dashboard > Settings > Permalinks and do not change anything.  Just save the permalinks as they are.  Often, this will resolve broken link issues in WordPress.

 

Let us know if these steps work.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
rafaeldesilva    0
rafaeldesilva

The one reseting .htaccess was a plugin, I found out seaching for flush_rewrite_rules through files, so it has been disabled. I still can't access previous posts, http://example.com/blog/page/2/ redirects to http://example.com/blog/ (save permalinks setting didn't help)

 

Any other ideas?

 

And another question: what makes a post to appear or not appear in blog page?

 

Thank you

Share this post


Link to post
Share on other sites
Rob    547
Rob

The addition of the Content/PostLoop section makes the posts appear.

 

Can you please send us specific links to your site instead of demo links?  I can't diagnose example.com.

 

Also, if you have a cache plugin activated, please clear the cache via the plugin, then deactivate it.

 

Thanks.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Can you disable all plugins and enable PageLines Debug mode. You can do this by going to PageLines > Site Options > Advanced.

 

Once enabled, reply here and we can take a closer look.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
rafaeldesilva    0
rafaeldesilva

I can't disable plugins, and about debug mode... i's a production site, what implications does that have?

Share this post


Link to post
Share on other sites
Jake    74
Jake

Hi rafaeldesilva - Debug mode will just allow us to take a look at possible issues with your server settings, it won't cause problems with your live site.


Have you searched the forums yet or checked out the DMS user docs?

PageLines geek, blogging at MyUntangledLife.com

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi,

 

Your issue is most likely related to one of the following:

 

1. A plugin conflict, you will need to disable all active plugins and see if this resolves your issue.

2. An error in the way you have set your blog up or related to your permalinks.

3. An issue with your server configuration, you're using PHP version 5.2, I recommend you contact your host and ask them to upgrade you to a later version.

 

Please be aware, that if you're unwilling to disable your plugins, we are powerless to assist you further. As we need to know that your issue isn't caused by a plugin.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
rafaeldesilva    0
rafaeldesilva

Thank you, I'll try it in a local environment, I don't think 2 and 3 are real candidates, as I have a newer PHP in localhost and it's happening here also, but I'll give it a try anyway.

 

Thank you

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

OK, if this is happening locally, then its most likely related to your plugins if you have all the plugins installed on your live site on your local site. Let us know how you go when you start disabling those plugins.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
rafaeldesilva    0
rafaeldesilva

I cleaned plugins and set up a development site, in development paging is working ok and not in productions, PHP and MySql versions are the same and they have the same plugins active...

 

See:

http://n.nzurita.es/?pldebug=1 (dev)

http://nirakara.org/?pldebug=1 (prod)

 

And:

http://n.nzurita.es/blog/page/2/ (working)

http://nirakara.org/blog/page/2/ (not working)

 

Any other ideas? As a strange thing, some times http://nirakara.org/blog/page/2/ has shown the rss page, I think I saw this before but I don't remember when or where, I also detected the plugin which was resetting htaccess all the time and disabled it, but it wasn't causing the problem.

 

Thank you

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Both links are doing the same thing and displaying RSS and not your blogs second page. Please disable all active plugins, meaning you have zero active, then reply here and let us test it.

If the issue is still persisting when you have no plugins active then its most likely an issue with your Wordpress config or server configuration.

Also, if you disable your PageLines themes and replace it with Twenty Eleven, Twelve or Thirteen, is the issue still exist, if it doe then you will need to contact Wordpress support as this related to Wordpress and not PageLines.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
rafaeldesilva    0
rafaeldesilva

Sorry for that, it's quite strange behaviour, I was emptying cache in each test and the error seems to have appeared after my tests or the server has it's own cache...

 

Anyway, now all plugins are disabled and (right now) I get an error: http://n.nzurita.es/blog/page/2/ (error message says not a valid feed template)

 

Thank you

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

If you have disabled all active plugins, which your debug info suggests, then this is most likely a Wordpress or server related issue.

 

Try the following:

 

1. Revert to your Permalinks to default and see if this resolves your issue. 

2. If #1 doesn't resolve your issue, try deleting your .htaccess file, via FTP. Once deleted, go to Wordpress Admin Dashboard > Settings > Permalinks and do nothing but click Save. Then try again.

3. If that doesn't work, try switching to another theme, such as Twenty Twelve or Thirteen and see if the issue persists.

If the issue persists, then its an issue with either your Wordpress installation or a server issue and you will need to contact both Wordpress and your web host provider.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • BentleyD
      By BentleyD+
      Hi Everyone,
       
      I am having issues with being able to post to my blog with platform 5. Currently when i click publish, it just shows the homepage of MoonBodySoul.com. That is until i open the page editor and change the scope from "All of type: Posts" to "Current Page Only". Then I have to re-insert the menu header as well. This seems like a really dumb process. In past versions of pagelines, I could just post a blog and the menu would be there and there would be no formatting issues. What can I do to fix this?
      MoonBodySoul.com
       
    • Houston Haynes
      By Houston Haynes+
      Hey folks - I'm trying to get right of some 'dead space' at the bottom of the page in the Material Theme. (see attached) Those two gray lines have an "Edit" button in between them when the browser has a login cookie for the site. Here I created a screenshot from a browser session that doesn't have context for my main login, so you can see that the "Edit" indicator is gone, but the bars and the space it occupies still remains. Can someone help me isolate this so I can make it *completely* disappear? Thanks.

    • tforasiepi
      By tforasiepi+
      How do you move the thumbnail on a blog post?  I need the thumbnails for the blogroll page, but they show up at the top of the actual post page.  Normally, this would be fine, but I've been requested to put it under the blog title.  Any suggestions?
      Thanks.
    • tforasiepi
      By tforasiepi+
      My client is asking for a new blog layout similar to the one found here:  http://blog.perkinswill.com/pokemon-augmented-reality-and-the-future-of-urban-design/ 
      They have a splashy full-width background image overlaid with part of the blog and one sidebar.  The navigation arrows send you to the next post.
      Does anyone know if this is even possible using Framework 5?  If so, can you send me some advice on how to get here?
      Totally stuck!
      Thanks.
    • j powers
      By j powers+
      Looking to fond the best way to add in some javascript, the script is from Salesforce to add a chat button, ie Chat available / chat offline.  I need to add this to a specific page though.
       
      Much apprciated 
       
×