Jump to content

Archived

This topic is now archived and is closed to further replies.

janpeeters

Can't edit 404

Recommended Posts

barkingsheltie

I hope this isn't a stupid question :) I also hope for world peace.

 

I assumed there was a 404.php template. I don't see one, either in DMS nor the basic child theme. We need to create one, correct?

 

And since Im using the postname permalinks. Are there exceptions, things to know?

 

Finally, do I need to edit the .htaccess to redirect?


"The first principle is that you must not fool yourself and you are the easiest person to fool"
Richard P. Feynman

Share this post


Link to post
Share on other sites
barkingsheltie

Was stupid question. I setup test site in MAMP. I can edit the 404 template in DMS. Using php 5.3 and base theme. Hmmmmmmmm....

 

Does it matter than my wordpress site isn't in root, but in subdirectory?


"The first principle is that you must not fool yourself and you are the easiest person to fool"
Richard P. Feynman

Share this post


Link to post
Share on other sites
barkingsheltie

Ok, its the fact wp is not in root directory.   Now, I wonder if I edit page, will this be saved when change the wp settings?


"The first principle is that you must not fool yourself and you are the easiest person to fool"
Richard P. Feynman

Share this post


Link to post
Share on other sites
barkingsheltie

Yep, once the page is edited, and if I change the link back, I lose the edit. 

 

What I mean by that, is I have wp address  http://www.mysite.com/wp, and site address, http://www.mysite.com

 

I guess I could reinstall, and use root directory. I had a couple subdomains, thought this was a cleaner way to handle the directory. 

 

What do you all think!   <tell her to go home  http://www.military.com/daily-news/2013/09/17/welsh-f22-flew-to-drones-rescue-off-iran-coast.html?comp=7000023435630&rank=4  >


"The first principle is that you must not fool yourself and you are the easiest person to fool"
Richard P. Feynman

Share this post


Link to post
Share on other sites
James B

Hi there,

 

I've checked with our developer, the css link on the 404 page is showing as a draft when logged in, <link rel='stylesheet' id='pagelines-draft-css' href='http://www.lovo.nu/cms/?pagedraft=1'>; and throwing a 500 error, they've suggested turning on wp debug to see what errors/warnings show up.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
janpeeters

Hi James B,

 

I've set WP_DEBUG to true in wp-config.php

To my eye not much has changed but maybe you know what to do next.

 

Thanks, Jan

Share this post


Link to post
Share on other sites
barkingsheltie

James B"], @[member="Danny,

 

Could either of you comment on my finding? That is, since my wp install in not in root, but nested one folder, e.g, /root/mywpsite, this seems to have affected 404 page editiing. 

 

In wp dashboard, if I set the site URL to the same as install director, I can successfully edit 404 page with front end DMS editor. Once I set site url to root, I have same problem that janpeeters is experiencing. 

 

I could leave well enough alone. I've only begun to make site, so I could stop and install wp in root, if you think that might also avoid other problems down the road?


"The first principle is that you must not fool yourself and you are the easiest person to fool"
Richard P. Feynman

Share this post


Link to post
Share on other sites
janpeeters

Hi all,

 

just to inform. My install is also in a subdirectory and the site is run from root.

So install dit www.lovo.nu/cms and site url is www.lovo.nu. I have no idea if this is a pattern but who knows.

 

Jan

Share this post


Link to post
Share on other sites
Danny

OK, can both of you provide a screenshot of your Wordpress Admin Dashboard > Settings > General page please.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
janpeeters

Danny,

 

Yes I did. I follow this procedure for all my Wordpress installs. I have latest version of DMS running on www.janpeeters.nl too and there I have no problems with a non-editable 404. So it really mind boggling for me.

 

Jan 

Share this post


Link to post
Share on other sites
barkingsheltie

Danny,

 

Like Jan, I have always followed  the WP procedure as well. 

 

Uploading picture of directory in general settings. 

 

The only way I found to resolve is if I set site url equal to wp directory, e.g., http://www.picotools.com/mywpdirectory - and use this in both fields. Then 404 page is editable. Of course that creates other problems...

 

I am about to delete site and start with root install. But if there is a fix, I would hold off. Why don't you create a fast site with wp in sub-directory and see if you can recreate the problem?

 

http://www.screencast.com/t/reDA2NdN


"The first principle is that you must not fool yourself and you are the easiest person to fool"
Richard P. Feynman

Share this post


Link to post
Share on other sites
janpeeters

Just to chime in, doing a root install isn't an option for me because I have installs of other packages running on the same webserver and I organise them all in folders. I like to keep things neat ;-) I don't think it's an uncommon setup so I guess we should be able to get this working? Maybe by adding the install folder name somewhere?

 

Jan

Share this post


Link to post
Share on other sites
Rob

Hi all,

 

Just to throw my two cents into this conversation, I noticed some mention of cache plugins.  It is a common misconception that one can just turn on or turn off a cache plugin and see the changes made before.

 

To explain this, a cache plugin creates a snapshot of the site in a particular moment in time. It places that snapshot outside the plugin, and enables the browser to find that when a customer visits the site.  Because the snapshot is faster to load than all the scripting, images, etc, it increases the speed of your site.

 

When someone deactivates a cache plugin (any of them), that snapshot remains actively visible, so changes made to the site as admin, do not become visible to you or visitors -- in other words, what you fixed doesn't seem fixed.  This is incredibly frustrating to designers and developers of websites because it looks like they've wasted time, especially when refreshing the screen doesn't work.

 

The solution is very simple.  Activate your cache plugin and use the settings it has to clear the cache, then immediately deactivate the cache plugin again.  This disables its ability to make a new cached snapshot, and erases the previous snapshot, making your site actually 'live'.  Once this is done, changes you make should be visible with a simple refresh of your browser.

 

I'm not sure if this will help in this matter, but, from what I read above, it looks like this wasn't a step taken and that a snapshot may be in place.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
janpeeters

Hi Rob,

 

Thanks for the suggestion. I've emptied caches vigorously when W3TC was still active. Just to be sure I did it again in the way you suggested but with no results. 

 

Jan

Share this post


Link to post
Share on other sites
barkingsheltie

Danny,

 

http://www.picotools.com/phpinfo.php

PHP 5.3.27

 

Rob,

 

Thanks Rob. Keep the tips coming, appreciated!

 

Btw, I cam across a plugin for Cinema 4D (the 3d app I make), that produces an egg  ;)   http://eggtion.net/category/playground/cinema4d?lang=en

 

Since I can make a small change in the directory URL, in the wp dashboard, and then edit the 404 page, would you say its probably not a cache issue? Actually as I write that, hey, maybe by changing the URL, ....!

 

In any event, I delete the cache using the button from the admin panel each time. 


"The first principle is that you must not fool yourself and you are the easiest person to fool"
Richard P. Feynman

Share this post


Link to post
Share on other sites
barkingsheltie

Any update here?

 

Its a little work to move everything into root directory, and I hope that's not necessary. However, if someone would recognize this is a bug, and no fix imminent, that would make the decision easier!

 

I've been mainly testing/playing with DMS, but like to get started for real sometime this week. 


"The first principle is that you must not fool yourself and you are the easiest person to fool"
Richard P. Feynman

Share this post


Link to post
Share on other sites
barkingsheltie

Danny"], @[member="Rob,

 

Hey guys - I know you have lots on your plate. Any ideas here? I can move forward by changing directories - but held onto possibility that perhaps this 404 issue is a bug - haven't seen any indication it is - for sure it has something to do with nesting wp into a sub-directory - if I change the site url to www.yoursite.com/wpinstall from www.yoursite.com I can edit 404 page with DMS. 

 

Anyway, if there are more pressing issues I understand - just let me know and I will reinstall and move forward. 

 

Thanks!!!

 

PS - its so windy here in southern calif, I might blow away, so if you can answer today, otherwise I might be in Kansas during the weekend   :)


"The first principle is that you must not fool yourself and you are the easiest person to fool"
Richard P. Feynman

Share this post


Link to post
Share on other sites
Rob

I have to say I love answering your topics.  You keep your sense of humor.

 

I must also apologize for the slow reply.  I've been on my first vacation in more than two years.

 

If you can see the changes after clearing the cache, then you're right, it's not the cache. In that case, it could be a permalink issue.

 

If you go to Dashboard > Settings > Permalinks and save without changing, are you seeing any changes?


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
barkingsheltie

Thanks Rob, 

 

Life is easier with a smile. My father thought i was too flippant, not serious enough. My blood pressure says otherwise!

 

Just occured to me, I have 5 authorizations I can use, and a couple sub-domains, I will try to see if I can duplicate the behavior. The other sites are just plain wp 3.6.1 with no cache, etc. But nested directories. I will try that. 

 

I have changed permalinks, and have the same result. 


"The first principle is that you must not fool yourself and you are the easiest person to fool"
Richard P. Feynman

Share this post


Link to post
Share on other sites
janpeeters

I've tried with permalinks too but with no success. I'm curious if the researching the php info files that Danny requested has delivered any ideas? Hope you had a nice vacation Rob!

Share this post


Link to post
Share on other sites
barkingsheltie

Update:

 

I installed DMS in another site. I first installed wp in subdirectory. I followed the codex, which is to copy the .htaccess and index.php (after setting permalinks and wp dashboard settings, site and wp url), into root directory, and making necessary changes to the index.php to point to the wp subdirectory. 

 

Whew. If Im not careful, some of my friends might think I've become a nerd!

 

Just for grins, using default theme, everything works - meaning, http://mysite.com loads the blog, even though wp is http://mysite.com/wp

 

Next, installed DMS and child theme. Use one activation. No plugins, no cache, CDN, no voodoo (yet, but 31st in quickly approaching). 

 

Again, things dandy. Can edit, etc. 

 

Now, for editing 404 page. Using post name as permalink, and the http://mysite.com/wtfbbq (or whatever!), scrambled stuff comes out. 

 

Note: when not logged in, the default 404 page does appear. 

 

Next, reinstall into root directory, install DMS, etc. 

 

Now everything works. So its some issue with DMS and using sub-directory, and/or site and wp url?

 

I noticed couple others were/are having trouble outside of this thread. 

 

If its a bug, can you name after me!!!!! :thumbsu:


"The first principle is that you must not fool yourself and you are the easiest person to fool"
Richard P. Feynman

Share this post


Link to post
Share on other sites

×