Jump to content

Archived

This topic is now archived and is closed to further replies.

janpeeters

Can't edit 404

Recommended Posts

janpeeters

Hi,

 

I can't edit my 404 page. So I searched forums and docs. I've read the following post:

http://forum.pagelines.com/topic/28586-404-section-wont-drag-drop/

so I think I understand the concept of how I should be able to edit my 404 page. 

But when I search for a non existing page e.g. www.lovo.nu/jhsgfjsf I get a page with a garbled look, see screenshot where the DMS editor doesn't work. http://cl.ly/image/0x0w0u1k361P

 

So what have I done to troubleshoot:

- Deactivated all my plugins.

- Emptied browser cache.

- Created a new template from a page with a post/page-loop on it and made that 'page global default'.

- Even tried silly things like: create a template named '404', created a new page with the name 'page-not-found.html' but of course that all didn't work.

 

I hope you have some ideas. I was almost certain that the problem was in the fact that I didn't have a page global default page with a post-loop but that didn't solve it.

 

Thanks, Jan

Share this post


Link to post
Share on other sites
janpeeters

Hi bhowton,

 

Thanks for posting that. I see it too when I'm logged out. Didn't notice it was working when logged out.

But when I'm logged in it is the view like I posted as a screenshot. A view that I cannot edit because the editor isn't working. I do see a lot of items that would normally be in a neat editor window but they're all spread out. And there are no items on the page that I could drag n drop like on working pages. 

 

Jan

Share this post


Link to post
Share on other sites
barkingsheltie

I have the same problem.

 

I know Pagelines is aware a few people have this issue, at least  Danny and Rob as they've replied in the thread I started. 

I will follow this thread as Im interested in their is a fix or something with our setup....


"The first principle is that you must not fool yourself and you are the easiest person to fool"
Richard P. Feynman

Share this post


Link to post
Share on other sites
janpeeters

Hi Shelley,

 

I problably didn't come accross your thread, even looked in your posts on your profile. Could you reference it so I can read it and get up to speed what is already known about this issue?

 

Thanks, Jan

Share this post


Link to post
Share on other sites
barkingsheltie

Hi Shelley,

 

I problably didn't come accross your thread, even looked in your posts on your profile. Could you reference it so I can read it and get up to speed what is already known about this issue?

 

Thanks, Jan

 

Hi Jan,

 

http://forum.pagelines.com/topic/28586-404-section-wont-drag-drop/

 

Hopefully this link works. 


"The first principle is that you must not fool yourself and you are the easiest person to fool"
Richard P. Feynman

Share this post


Link to post
Share on other sites
janpeeters

Hi Shelley,

 

Thanks. Hoping for a solution.

Danny"], @[member="Rob. Any news on this? I can give you an admin account in my install if you want to see this when logged in.

 

Jan

Share this post


Link to post
Share on other sites
Danny

Hi,

 

Are you still encountering the issue, as I am able to check for a non-existing page easily on your website - http://d.pr/i/dIpB


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
janpeeters

Danny, that's what bhowton also reported, but the problem is not viewing the page when you're logged out. It's being not able to edit it when logged in. As said: "I can give you an admin account in my install if you want to see this when logged in."

 

Jan.

Share this post


Link to post
Share on other sites
barkingsheltie

Danny,

 

I am still experiencing the issue of not being able to edit the 404 page.  Unless Im mistaken, we can do this with DMS, using your method described in the thread I linked?

 

Or do we edit the php file?


"The first principle is that you must not fool yourself and you are the easiest person to fool"
Richard P. Feynman

Share this post


Link to post
Share on other sites
Danny

janpeeters

barkingsheltie

 

Email our helpdesk with the following:

 

A link to this post

A link to your website

Your Admin username and password.

 

Then we can investigate your issue.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
janpeeters

Danny, done, thanks!

Share this post


Link to post
Share on other sites
Rob

:)


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Danny
OK, you're using PHP version 5.3 and also have Magic Quotes on. Therefore, I recommend you contact your host and ask them to upgrade you to 5.4, as this function (magic quotes) has been removed in 5.4. Once done, check to see if you can access your 404 page without any issue. If this doesn't resolve your issue, can you add the following snippet of code: define( 'PL_NO_DYNAMIC_URL', true ); To your wp-config.php file please, add it underneath WP_DEBUG: Let us know, if this resolves your issue.

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
janpeeters

Hi Danny,

 

Magic quotes are off now, had to change php.ini file. But version is still PHP 5.3. 

I've added the pagelines code to wp-config. But when I do that my whole site looks like the 404 page. This is even the case when I'm logged out. So I removed the code again.

 

So the problem is not solved. Have you got any other ideas?

 

Thanks, Jan

Share this post


Link to post
Share on other sites
James B

Hi there, once you added the code in did you refresh the permalink setup? It might need to be resaved to take affect.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
janpeeters

Hi James B, Just tried your suggestion but also with no luck. Jan

Share this post


Link to post
Share on other sites
Danny
OK, can you remove that code I added earlier and replace it with this:
define( 'LESS_FILE_MODE', true );

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
janpeeters

Hi Danny, 

 

Added the new code, deleted the old. Still no luck. :-(

Thanks so far!

 

Jan

 

Edit: I flushed the LESS cache also, just to be sure. Bit still no. 

Share this post


Link to post
Share on other sites
janpeeters

Little addition:

I noticed when doing a search on my site and getting to the results page that also this type of page looks mixed up when logged in.

Share this post


Link to post
Share on other sites
barkingsheltie

Still tagging along. I will watch closely what tactics/advice that Jan gets before I plunge. 

 

My site is currently running 5.2. I will see about upgrading. 

 

Would using a CDN like cloudflare, and super cache have any affect?

 

I will email helpdesk. What is the email addy for them?


"The first principle is that you must not fool yourself and you are the easiest person to fool"
Richard P. Feynman

Share this post


Link to post
Share on other sites
janpeeters

Hi Shelly,

 

My site was running on W3 Total Cache with Cloudfront CDN, ON or OFF didn't make any difference regarding the error. So I suppose the problem is not with the plugins. I have deactivated all plugins and removed all custom CSS when troubleshooting but that didn't change a thing.

But deactivating your Cache plugin and CDN when you start troubleshooting is very advisable. Otherwise changes might not be visible right away and you might think it's still broken when it does work. My Cache plugin is off for now untill we've got this figured out. 

 

Jan

Share this post


Link to post
Share on other sites
barkingsheltie

I went ahead and updated php to 5.3. 

Turned off all plugins. 

Added the code Danny"] supplied here - refreshed permalinks as @[member="james suggested. 

 

No success. 

 

I assume, that when we try to edit 404 page, we should have access to the DMS editor, yes?  


"The first principle is that you must not fool yourself and you are the easiest person to fool"
Richard P. Feynman

Share this post


Link to post
Share on other sites
janpeeters

 

I assume, that when we try to edit 404 page, we should have access to the DMS editor, yes?  

 

Yep you need to be able to drag sections onto the page if you want it different than default. 

If you can update to PHP 5.4 you should try that. I'm not sure my shared host will provide me with that service but it seems you have access to do this yourself. It might be the solution. 

Share this post


Link to post
Share on other sites
barkingsheltie

Thanks janpeeters"]. That is very sensible work flow. I believe @[member="Rob has mentioned this too. I haven't really started editing the site intensely yet, still learning from everyone else while DMS evolves.  :thumbsu:

Next week I will get to it. 

 

I wonder, why can't we just edit the 404 page directly for now?

 

Btw, @Jan, I was a user of ElectroGig 3d software. Eventually they closed down, and switched to Alias - which now is Maya. GiG was ahead of its time. A few of the programmers visited me here in the states, and I convinced them to compile - as far as I know - the only version of GiG to run on a macintosh! It was running Linux, but still. 

 

 

Edit:

 

Yes, janpeeters, I think maybe just install DMS on MAMP, and see what happens here. 


"The first principle is that you must not fool yourself and you are the easiest person to fool"
Richard P. Feynman

Share this post


Link to post
Share on other sites

×