Jump to content

Archived

This topic is now archived and is closed to further replies.

radroz

Text Box issue

Recommended Posts

radroz

I attempted to insert this basic text into a textbox:

 

<div class="address">©2013 JTMJ • Addressline • City state</div>

 

When I did, it completely jacked up the entire site — all of the sections reverted back to their default settings. All of them. It was only when I added the © and • symbols with their HTML code that the line was accepted.

 

Thankfully, I had the json settings file already backed up, but this would have been a disaster if I didn't. Can you guys check on that? 

Share this post


Link to post
Share on other sites
Rob

Before I ask our developers to research this, what CSS did you add for the class "address"?

 

I ask because I have the copyright and dot you're using in my site without problems, on both Framework and DMS.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
radroz
.address {
color:#002B16;
text-align:center;
}
 
For the record, I'm using wp 3.6.1, latest DMS, and Hero Nav, Hooker (which didn't work at all), Scrollex, and I have Business Branding, Projects, and Flip Slide installed.
 

Share this post


Link to post
Share on other sites
Danny
Hi,
 
Just so you're aware, it is physically impossible for that code you cause the issue you encountered. To prove this, I have just this moment added your code to my test site and had no such issue.
 
 
DMS has been tested vigorously and settings and section settings reverting back to default upon adding custom HTML or CSS, never happened once. The only possible way for your site to revert to default settings and section settings, is for you to click on the reset buttons. Another possible cause could be you either have a Cache plugin installed or your web host provider did some kind of major error and had to restore all sites using a previous backup.

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
radroz

You know, I love how you guys tell me that things that are "physically impossible to happen" happen regardless. :: sigh :: There are no errors in the webhost, and there is no cache plugin in stalled. 

Share this post


Link to post
Share on other sites
Danny

HTML can not revert your sites settings, think about it, if what you're saying is true, then how would your site ever function?

How can adding HTML to a textbox, remove all your sites settings as well section settings?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
radroz

How? That's what I want to know! LOL 

I ended up reinstalling DMS, and now that the section is set — I'm leaving it alone. But I assure you, once I refreshed the page, it reverted back to default settings. Frankly, if I knew HOW, I would have fixed it! 

Share this post


Link to post
Share on other sites
Rob

I hate to say it, but Danny's absolutely correct.   Even if you were using a bunch of symbols in DMS in any content area, the system would see them as content, not code.  Being an economist in my former life, I have several sites with complex formulae using much more complex math symbols than a copyright and nothing ever broke in PlatformPro, Framework, DMS or even WhiteHouse Pro.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Danny

I haven't encountered this issue, nor has anyone else reported this kind of issue. If it happens again, let us know and we will try to recreate it again.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
radroz

Oh, I assure you. If I see it again, I'll be all over it.

Share this post


Link to post
Share on other sites
Rob

Please believe me, neither of us are trying to insult you in any manner.  We know how easy it is to do something that has an adverse reaction, but isn't caused by that which seems obvious.   For example, we've had a few people say that they've laid out some design or another, then it vanishes.  Ultimately, in those cases (every, single one of them), the customer had clicked the 'Refresh" icon before clicking Publish.   As a result, changes implemented, and often slaved over for considerable time, were ultimately lost.  I did it myself the first few times I used DMS.

 

To be clear, that's not what I'm suggesting happened to you.  But, this illustrates how simply, easily and readily a slight misstep can impact anyone's work.

 

Your CSS code does not violate any CSS rules. Even if it did, the worst that would happen would be a CSS error or another type of error screen.  One absolutely safe way to add copyright symbol is to go into Text mode when editing your document and use the html code for it:

 &copy;

See http://www.w3schools.com/html/html_entities.asp

 

I've tested your code, and the html you've added, twice and I'm not getting any adverse reaction on publishing.  If you can capture this somehow, please share it with us.  I'm open to the idea you may have a conflict with something, but so far in multiple tests of what you've added, I'm not able to duplicate it, which is Danny's problem too.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
radroz

Oh, I know — I didn't take it as such! Which is why I was so frustrated with why it was happening. I couldn't help but wonder if it was a wonky cookie, or if my Mac was getting possessed. Made me wanna jump up and down in frustration!

Share this post


Link to post
Share on other sites
Rob

Good way to get some exercise! :D


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

×