Jump to content

Archived

This topic is now archived and is closed to further replies.

outtareach

Changing post shown in post loop

Recommended Posts

outtareach    3
outtareach

I am using a post loop section to display a contact page but I am having an issue when I use 2 post loops.  It seems that the post loop section doesnt let me change what post is showing in the loop and only shows the same post.  I go to edit post and it takes me to the same page.  Any way to change which post shows in the post loop section?

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

HI,

 

Not quite sure what you're trying to do. The Content/PostLoop section shows your Posts when you're on a Post or blog page, it also shows your Pages content when viewing a page.

So you can't use the PostLoop section to display a Post when added to a Page, as it will only show your Pages content. If you want to display your Posts, you will want to either use a PostLoop such as Nicks Any Loop or use a Plugin such as Mini Loop or Special Recent Posts.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
KimAnn03    2
KimAnn03

i posted a ? and figured it out. please ignore and thank you

Share this post


Link to post
Share on other sites
James B    436
James B

Thanks for updating.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

  • Similar Content

    • jojoking
      By jojoking+
      I have to admit to being baffled.
      I'm trying to embed a video (from my WP media library) within a WP post using the videobox section shortcode.
      The shortcode section popup only allows two items to be configured - the section type, in this case videobox - and a unique id. There's no URL or other parameters such as autoplay or loop which are available within the Pagelines editor.
      Whatever I put in the unique ID makes no difference to what is shown which seems to be a default video with stars or white noise on a black background.
      I assume I need to define this ID somewhere else, or maybe WP has done it for me?
      HELP!
       
      PS This is the page source generated when a shortcode is added within the WP post editor
      <!-- VideoBox | Section --> <section id="videobox_1675853156" class="pl-sn pl-col-sm-12 pl-col-sm-offset-0 pl-sn-videobox" data-object="PL_VideoBox" data-clone="1675853156" data-level="0"><div class="pl-sn-wrap"><div class="pl-sn-pad fix" data-bind="pledit: true" > <div class="video-highlight"><h3 class="video-title" data-bind="pltext: vb_title"></h3></div> <div class="pl-video-box" data-bind="plcallback: { vb_autoplay: vb_autoplay(), vb_loop: vb_loop(), vb_controls: vb_controls(), vb_video: vb_video()}" data-callback="videobox"> <video id="280414138" autoplay loop > <source src="https://www.handinhandmanchester.org.uk/wp-content/plugins/pl-section-videobox/default.mp4?r=280414138" type="video/mp4" /> No browser html5 video. </video> <script> jQuery('#280414138')[0].load(); </script> </div> </div></div></section> </div>  
      If I add a videobox section using the Pagelines page editor the page source generated includes my video:
      <!-- VideoBox | Section --> <section id="videobox_udvu4uz" class="pl-sn pl-col-sm-12 pl-col-sm-offset-0 pl-sn-videobox" data-object="PL_VideoBox" data-clone="udvu4uz" data-level="0"><div class="pl-sn-wrap"><div class="pl-sn-pad fix" data-bind="pledit: true" > <div class="video-highlight"><h3 class="video-title" data-bind="pltext: vb_title"></h3></div> <div class="pl-video-box" data-bind="plcallback: { vb_autoplay: vb_autoplay(), vb_loop: vb_loop(), vb_controls: vb_controls(), vb_video: vb_video()}" data-callback="videobox"> <video id="429558737" autoplay loop > <source src="https://www.handinhandmanchester.org.uk/wp-content/uploads/2017/04/HIHWelcome.mp4?r=429558737" type="video/mp4" /> No browser html5 video. </video> <script> jQuery('#429558737')[0].load(); </script> </div> </div></div></section>  
    • flourishdesignstudio
      By flourishdesignstudio
      Hi,
      I am having an issue with the Lax sections on Platform 5. I can embed a widget or text box into a Lax section which is really neat, but the image in the background (the parallax image) seems to get stretched and doesn't scale in an attractive way.  For example, the page http://ed6.61e.myftpupload.com/#clients has a parallax section with a woman's face  and I thought is would scale as the browser window gets smaller but the zoom-level never changes. Also, the amount of parallax shift seems more dramatic than what we want. I thought that if I uploaded a shorter image it would scan/scroll less since the height from the image's top to bottom would be less. However, that doesn't seem to have any effect and I am at a loss of how to properly control the way the image is displayed within that box. Any thoughts, tips, or suggestions to get me pointed in the right direction?
      Thanks so much for the help!
    • PierreFF
      By PierreFF+
      Hello Everyone, 
      I think this one is for the pagelines team. 
      I have some trouble with the Adventure section plugin https://www.pagelines.com/product/pl-section-adventure/ that doesn't seem to load in any of the three websites I run using pagelines. 
      I do the setup via the extend platform as usual. It tells me that the plugin is installed and activated but unfortunately it doesn't appear on the page editor.
      I have just tried it consecutively with three websites I own with the same result.
      My intention was to use it with this website: http://launchpadweekend.foundersofthefuture.co/ (free version)
      And I also tried with this website http://foundersofthefuture.co/ (pro license) and this one http://ffactor.me/ (free version). And I have the same problem with each. 
      I would love to see how I could solve this issue. 
      Thanks a lot. 
      Pierre
       
    • flourishdesignstudio
      By flourishdesignstudio
      I am working on a site that uses post categories to organize a large collection of cocktail recipes (such as 'Fall Cocktails', 'Winter Cocktails', 'Spring Cocktails', and 'Summer Cocktails'). I am trying to style the category pages so that a user will land on the Fall page and see the fall posts in a two-column setup. The Pagelines Content section has no real post display options to speak of so I am trying to work within the Loops section, which does produce the overall visual effect that we are hoping for. However, it means that I have to create a Loops section for every single category page and tell it to show the posts for that specific category (Fall posts on the Fall Category page, Spring posts on the Spring page, etc). We actually have about 25 cocktail categories so creating unique pages for each category isn't going to be very time effective for us - especially if we want to change a setting later and have to go to each page to do that.
      So, my question is whether or not there is a way to control general category pages or if there are any other good post loop options that you recommend. This used to be much easier in the past versions of Pagelines and DMS so I just want to make sure I am not missing something within this new system.
      Thanks so much for the help!
    • chamois_blanc
      By chamois_blanc+
      What is the right/best way to make a one-page website with PL5? The framework seems to hardcode section IDs without any possibility of changing them. Scrolling to a page section requires the link to use the section ID, ie <a href="#<section_ID>">...</a>. I don't see myself hardcoding weird section IDs in there as this will show up in the address bar.
      Please advise, thanks!
×