Jump to content

Archived

This topic is now archived and is closed to further replies.

sfmstudios

iBox Responsive overlap

Recommended Posts

sfmstudios

Ran into an issue with the iBox section not flowing well onto a mobile browser - the only custom CSS I have right now is

 

.ibox .ibox-media .ibox-icon-border {border-radius: 0 0 0 0;}

 

 

Attached are a couple screenshots, one with full width and one representing the overlap on a mobile browser.  What is causing this issue and how can it be fixed?

 

[attachment=1527:Full-width.png]

 

[attachment=1528:mobile.PNG]

Share this post


Link to post
Share on other sites
greenfly

Do you have a link to the site please? 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
Danny

What browser is having the issue with the boxes image ?

 

As I don't have that problem - http://d.pr/i/TziH


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
sfmstudios
On iOS - checked on both iOS 6 and iOS 7 and they both unfortunately have that same issue...

Share this post


Link to post
Share on other sites
Rob

Can you tell us what the settings for your iBoxes are? I looked on all four browsers I have on my android phone, and it's fine on those.

 

I'll try and replicate it, though I do not have an iPhone or iPad.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
sfmstudios

I have these settings in Custom Code:

 

 

.ibox-icon-border {background: #FFE66D;}
 
.ibox .ibox-text {color: #000000}
 
.ibox .ibox-media .ibox-icon-border {border-radius: 0 0 0 0;}
 
And attached is how I have them set up in Customize.
 
[attachment=1540:Box options.png]
 
Thanks!

Share this post


Link to post
Share on other sites
Rob

Everything looks fine.  The only thing left that could cause this is your scaling of the images.  Each of your images is 150px square, but it's being placed into an 80px container.  As a result, the browser is forced to scale the images dynamically.  Not all do that, and result in bleeding of the image beyond the container, which is exactly the condition you're seeing. 

 

Try this... use a graphics editor and resize the images to 100px square and save with a modified name. Upload the modified files in replacement of the ones you have now.  Check to see if this resolves or improves the issue.  I suspect it will.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
sfmstudios

Hmm...tried that, but the same result unfortunately.  Could it be something with the animation?

Share this post


Link to post
Share on other sites
Rob

Just to make sure... you don't have a cache plugin activated? If you do, clear the cache via its settings and deactivate the plugin.

 

Add this temporarily to custom code:

.ibox.left-aligned .ibox-icon-border.media-type-image {
    height: 100px;
    width: 100px;
}

Let's see if this works.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
sfmstudios

That did work, but I had to adjust the pixels - the 100px made the overlap worse, but after fiddling a bit it's all set now.  Many thanks!

Share this post


Link to post
Share on other sites
Rob

Great!


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
micstepl

the above solution does not work.

 

My Suggestion: 

  • limit the width of the text
  • so that the text breaks below the image
  • once the width is in a critically low range (to overlap)
  • maybe you play with th px size
.ibox-desc {
    min-width: 240px;
}

Share this post


Link to post
Share on other sites
Rob

Your solution is interesting, but doesn't explain what happens when someone sets up 6 in a row.  It also doesn't speak to the responsiveness of the iboxes after this is implemented.  Have you tested your solution to be fully responsive in multiple browsers or with different column setups?


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
micstepl

Your solution is interesting, but doesn't explain what happens when someone sets up 6 in a row. It also doesn't speak to the responsiveness of the iboxes after this is implemented. Have you tested your solution to be fully responsive in multiple browsers or with different column setups?


No - didn't test with different browsers. I admit that this is only a quick fix which is supposed to be a tip that would require to be adopted for each type of box count. In general I would expect this sort of feature from pagelines team - if we are talking about the responsive design.


Sent from my iPad using Tapatalk - now Free

Share this post


Link to post
Share on other sites
Danny

Well I have just added several boxes to a page with a similar to setup i.e. image is 100x100 etc... and when I viewd on a mobile device, there was no such issue. Therefore, the issue had to come from custom CSS.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • glyph.marketing
      By glyph.marketing+
      Hello, I am having a problem similar to that experienced by Michael Kummer here. We have pages that show this automatic scrolling issue (examples here and here) and it is sufficiently annoying that we have seen customers bounce while trying to convert. Strangely, it only happens at specific resolutions, so it can be difficult to reproduce. In general we can only consistently reproduce it on a 4k resolution with a browser width between 1517 and 1536px. 
      Thanks to Michael Kummer's help we were able to set the overflow-anchor property to none in the entire body, which fixed the issue as far as we can tell, but also obviously disabled scroll anchoring for the whole site. I tried applying it to the specific element that looked like it was being reloaded, which was the PL Meganav extension, but that was unsuccessful. 
      Can anyone help us figure out which element or ID we can apply this property to, so that we can fix the scrolling issue but not disable scroll anchoring for the entire site?
      Thank you - 
      Glyph Language Services
    • chamois_blanc
      By chamois_blanc+
      Hello,
      Shouldn't the image PL5 component be using the srcset/picture css directives to pick the correct size for an image? or it does already and I don't know how to use it? Thank you for any advice or enlightenment.
    • stijnxo
      By stijnxo+
      Is there a way to disable the responsive function of your iBoxes?
      I do not want all iBoxes underneath each other on mobile, is there a way to fix columns or group boxes?
      I use them for small links and want them to stay next to each other, see attachment
      Please let me know.



    • Dan Haddock
      By Dan Haddock
      Plugins Active and installed: 
      Akismet Anti-Spam
      Coming Soon Page & Maintenance Mode by SeedProd
      Contact Form 7
      Cookie Law Info
      DMS Professional Tools  
      Enhanced Media Library  
      Flamingo
      Google Analytics for WordPress by MonsterInsights
      Google XML Sitemap
      Jetpack by WordPress.com
      Legull 
      Loginizer   
      MailChimp for WordPress
      PageLines Updater    
      Schema App Structured Data 
      Sucuri Security - Auditing, Malware Scanner and Hardening
      Uber reCaptcha    
      Yoast SEO
      Wordpress Version: 4.8.1
      Pagelines Version: 2.2.4
       
      Good Evening/Afternoon or Morning, 
      I am running into a problem with CSS styling not applying inside of most browsers (Safari, Firefox) when I am logged in to wordpress, and all browsers that I have tested when I am logged off and the site has been made public (Chrome, Firefox and Safari).
      As a result, I have managed to identify the probable cause. It looks as though these browsers are refusing to render my sites compiled CSS file due to it being a HTTP URL rather than HTTPS.
      I have attempted to change this URL to HTTPS in my browser, however it brings back an ERROR: File not found page - https://www.shortfilmblog.com/wp-content/uploads/pagelines/compiled-css-core-1505847507.css
      What would you suggest in this regard? Would this be resolvable from your end?
      Happy to provide any further details required.
    • Borries
      By Borries+
      I know this is not an easy problem. Maybe there is a easy solution.
      I have tryed to uses the existing solution, that I have found in the forum
      I changed the colours of my nav (simple nav) and the hover effect (a. hover).
      I really tryed to highlight the active/used link in the nav but I cant figure it out.
      I want it to be black when active.
      Any help would be appreciated. Thanks.
      http://www.marcborries.de  nav link: "Sinn & Selbst" 
×