Jump to content

Archived

This topic is now archived and is closed to further replies.

davekeys

Saving And Publishing's Little Secret

Recommended Posts

davekeys
It should be the culmination of a session of arranging, tweaking, styling and otherwise designing- to click the publish button and see a saved result, but it isn't. Much like the Obama campaign, the DMS launch had us full of hope and anticipation of great change. Now the reality is that often, nothing has changed- literally when I try to save- and that's the little secret that the DMS seems to harbor until it is revealed by updating the browser.
 
This video explains it better than I can do by writing more than I feel like at the end of a long day of struggle with the system that might need a little more secret sauce to get it up to par.

It seems that DMS can be a bit too buggy even in a relative vacuum. I hope this gets better. I actually started considering whether to re-up my Headway subscription. I have to get things done and rolled out here and Pagelines seems broken in DMS and now somewhat broken in Pagelines Framework as well. 
 
But I digress. Here's the video that explains it: https://www.youtube.com/watch?v=RICCIS9BOHs
 
I hope this issue can be resolved. It seems like a lot of people are dealing with a lot of bugs, but especially in real world environments like Wordpress websites that actually have running plugins and now browser add-ons are a problem too. It's starting to feel like airport security in the support forum- take off your shoes, your belt, your jewelry, spread your arms and legs apart, step over here for closer examination... 
 
Stripping down the browser, the Wordpress environment and the computer can't be the answer for a robust product long term. Do we have any hope of change in the fragility of this product?

Share this post


Link to post
Share on other sites
Rob

Dave!

 

First, I'm sorry for your troubles with this. 

 

Next, I think you kinda hit it head on by saying it's cache.  Disabling the cache plugin is actually, and surprisingly the wrong step.  With a cache plugin, it creates a snapshot of your site and stores it.  Even if the plugin is deactivated, the snapshot is still resident and delivered to browsers who see that, rather than what you've done, in fact.   The Framework forum is full of instances where my colleagues and I have had customers clear the cache first and then deactivate the plugin.  That will remove the snapshot and allows you and others to see the actual changes made.

 

Reactivate the cache plugin, then clear the cache and deactivate again.

 

Lastly, I presume you have a template for that page.  One of the steps you didn't do just before or immediately after publishing is saving the template.  I'm still convinced this is a cache problem, but to be absolutely certain that the section isn't somehow simply locked into the template.  That shouldn't cause this, but it's worth a try.

 

Let us know how you get on!


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
davekeys
OK, that worked precisely! It's still counterintuitive but there's only so much you can do in a cached Wordpress environment and making that more graceful may be a ways down the road. I appreciate the insight. The platform has a lot to offer and I think you guys are committed to improving it, especially given your track record with prior products and the fact that you've already released an upgrade.

Thanks again.

Dave

Share this post


Link to post
Share on other sites
davekeys

I updated my video to show this solution in the description section with an annotation to alert the viewer that this issue has a solution.

Share this post


Link to post
Share on other sites
Rob

Thanks Dave.  I'm glad it worked!


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

  • Similar Content

    • burkeproperties
      By burkeproperties
      Hello,
       
      I recently downloaded DMS and have been working on my companies site. I did a lot of work on the header and footer yesterday and when I went to work on the site today all that work was gone. Everything else I had worked on before and after working on the header and footer were there. How can I fix this so my work saves? The site's url is proto.burkeproperties.com.
       
      Thank you.
    • RainMakerDesign
      By RainMakerDesign
      When I go to publish as a theme, it won't let me....   (Disabled! No child theme active) Publish Configuration to Child Theme (No Download File) Check this to publish your site configuration as a theme configuration file in your themes root directory. When a user activates your theme it will ask if it can overwrite their settings to attain a desired initial experience to the theme.
    • triggerfish
      By triggerfish+
      Hi, I am confused here... How do I lock a template..ie NOT ACTIVE
    • Josiah L
      By Josiah L
      I am in the process of updating WP to 3.8 and DMS to 1.1.5 development site to test before updating my "live" site.
       
      An issue that I have run into, that I have never seen before, is that one of my pages will not save when I click the "publish" button. The page template is the incorrect column sizes, rapidtabs keep displaying, as well as the comment section. I have tried removing rapidtabs, adjusted the column sizes, and removed the comment section multiple times, but it never "saves" when I click the publish button. I have even tried removing everything on this page template and clicking the "publish" button, but everything still shows up after a refresh.
       
      The odd thing about this issue is that it only happens on one page. Other page templates save changes just fine.
       
      The testing page that I having issues with is: http://www.godfilms.net/shopp/cart/
       
      The current live site looks like this: http://www.wpfilm.com/shopp/cart/
       
       
      Test Site Versions:
      WordPress 3.8
      Pagelines DMS 1.1.5
      Shopp 1.3.1 
    • bloom1creative
      By bloom1creative+
      Hi guys   I have used DMS lots now, and generally really love it.  I've had a couple of issues recently where the Js/CSS appears to just fail when trying to go into the front end, and I am presented with a very long webpage of all my site plus all the dms stuff on one page, including the store etc almost like something hasn't loaded correctly.  Anyway I just deleted those two installs and reinstalled, and it worked fine again.   I have been building a new site, and it was all going great until today... I drag Widgetizer areas and similar, and for instance a span3 column on the top header that WAS working fine, suddenly just stopped functioning correctly and the span3 now appears smaller than the rest for no apparent reason, and it's intermittent.  The issue with the Widgetizer seems ONLY on the footer area, where nothing will save or stay put anymore.All plugins were disabled, still the same issue.  The site has not been customised in any other way by myself.   Any help would be great as I have a headache trying to work this out :/
×