Jump to content

Archived

This topic is now archived and is closed to further replies.

q2tech

Filter Thumbnail vs Post Featured Image

Recommended Posts

q2tech    0
q2tech

The Section Filter is working great but I have a question regarding the image that shows for the filtering vs an individual post image.

 

I have a Custom Post Section (Galleries) that is housing individual artwork posts with categories The artwork pics for each post are all over the map in sizes. Thus when I use the pics as a featured item for the post and view the filter page the images are of course all different sizes.

 

if however i crop a section of each artwork pic to use as a thumbnail (ie 250 x 250) via the featured image the filtered section looks consistent and good but the featured image for the actual post is just a thumbnails size. I have seen isotope galleries that have a masonic layout with different sizes and layouts of images. Is this something that can be done with this section?

 

Can anyone point me in the right direction to solve this issue of mine or give me suggestions of a better approach?

 

Thank you in advance :)

 

Regards,

Jeffrey

Share this post


Link to post
Share on other sites
ellenmva    112
ellenmva

q2tech Filtering is more for for displaying content/images more uniformly. I know what you are looking for, just Filtering is built using columns, making everything even.

 

Let me see if there is anything out there that uses isotope like that.

 

Ellen 


Ellen Moore

Pagelines Developer

www.elsue.com www.betterdms.com

Share this post


Link to post
Share on other sites
q2tech    0
q2tech

Oh I can understand that. So when you say uniformly you are also saying the featured images all need to be the same fixed size as the others in order to get that uniform layout correct?

 

Jeffrey

Share this post


Link to post
Share on other sites
q2tech    0
q2tech

I sould clarify.... I am asking if, given that the filter images come from the post's featured image field, that i need to have all of the posts have the same featured image dimensions?

 

I think i know the answer and that is fine but I suppose i am looking at adding the following steps:

 

1) Make equal dimension thumbs of all of the images to use in the featured image of each for uniformity in the filtering

2) Find a way to disable the featured image and either use a custom field for a main image of teh post or just manually have the client add the photo in the content.

 

Not really a question specific to the filter Section but any yes/no or other comment to those options would be appreciated :)

 

PS. Ellen I commend you on the great work! :)

Share this post


Link to post
Share on other sites
ellenmva    112
ellenmva

q2tech Is there a link to the site so I can see what you are trying to do? I'm having a hard time visualizing it and we may be making the issue more complicated than it is. 

 

Or, if the site isn't online, screenshots of what Filtering looks like with the images when the post pages are setup to display the way you want.

 

Thanks.

 

Ellen


Ellen Moore

Pagelines Developer

www.elsue.com www.betterdms.com

Share this post


Link to post
Share on other sites
Jenny    33
Jenny

Please let us know if you still need help with this topic otherwise I will close it in 7 days. Thanks! :)


Jenny :: Web designer at Simple Mama (follow me at @simplemamacom)

Check out Share Me, a social sharing add-on for DMS that is super simple to set up.

Share this post


Link to post
Share on other sites
getlink    0
getlink

i have one question. how much degree exactly should i filter image.  sometimes i will do excessive filtering. so the image will turn out to be bad quality.

so any suggestion on this one.

Share this post


Link to post
Share on other sites

  • Similar Content

    • Josiah Jones
      By Josiah Jones
      Hi,
      I'm currently using the Filtering plugin on a website that is not yet live (http://www.RetroLeaders.com/ - currently hidden by a "Coming Soon" plugin) however after updating to the most recent version of Wordpress and DMS the Filtering plugin has stopped working and is causing DMS to display the never ending load icon.
      Inspecting the code for errors I see the following problems:
      . jquery.isotope.min.js?ver=1.7.4:11 Uncaught TypeError: Cannot read property 'opera' of undefined (anonymous function) @ jquery.isotope.min.js?ver=1.7.4:11 (anonymous function) @ jquery.isotope.min.js?ver=1.7.4:11 (index):66 Uncaught TypeError: mycontainer.isotope is not a function (anonymous function) @ (index):66 jQuery.Callbacks.fire @ jquery.js?ver=1.11.2:3143 jQuery.Callbacks.self.fireWith @ jquery.js?ver=1.11.2:3255 jQuery.extend.ready @ jquery.js?ver=1.11.2:3467 completed @ jquery.js?ver=1.11.2:3498
        Can you please check if everything is working properly and provide an update if necessary? The filtering function is a crucial part of my web design and we cannot go live without it!
      Please let me know what you find.
      Best,
      - Josiah 
    • evscicats
      By evscicats
      Ellen,
       
      What version number is the latest for the Filtering section?  I have version 1.6 and hope that I'm up-to-date.  If there's a new version, how do I get the latest update and do I have to pay again?
       
      Thanks,
       
      Jerrad
    • jujutanada@gmail.com
      By jujutanada@gmail.com
      Hi, I found out that if I go to the archive of a tag e.g. http://mysite/?tag=lotd , it doesn't work. It doesn't show the correct posts tagged with lotd, --but it works for categories. It only works when I use WP Content. How do I display this using Postpins?
      And is it possible to create a different archive page for only a particular category?
       
    • jujutanada@gmail.com
      By jujutanada@gmail.com
      Hi, I found out that if I go to the archive of a tag e.g. http://mysite/?tag=lotd , it doesn't work. It doesn't show the correct posts tagged with lotd, --but it works for categories. It only works when I use WP Content. How do I display this using Postpins?
      And is it possible to create a different archive page for only a particular category?
       
    • aldisney
      By aldisney+
      Hello, PageLines!
      I have a problem I'm running into with trying to get a featured image (in a WP loop) to display as a circle. I'm using the filtering plugin, too. Here's the image I'm trying to show displayed as a circle:
      [sharedmedia=core:attachments:2460]   I've tried adding:   .filtering-image center {   border-radius: 50%;  }  
      I think I just have the wrong tag, but I can't seem to figure it out. Anyone have any ideas?
×