Jump to content

Archived

This topic is now archived and is closed to further replies.

fliptheu

Templates not saving correctly?

Recommended Posts

fliptheu    4
fliptheu

Hi,

 

I have two templates saved. One is for the landing page which will have a masthead with a big graphic. Another template is for a specific category. I do not want the masthead in that template. I saved both templates, and loaded them on the respective pages. When I remove the masthead on the category page template, it removes it from the separate landing page template. Why? Doesn't that defeat the whole purpose of having templates?

 

I have flushed cache, I know I am not affecting global sections, this was working and now it has stopped. It is not a plugin because it was working before.

 

Thanks for any help.

 

 


fliptheu

"Finding beauty one picture and one pixel at a time."

http://www.fliptheu.com

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi,

 

You're most likely adding the MastHead section to the Header Template Area, which is a global template area. This means that any sections added to this area will be visible throughout your site.

There is already a issue posted on our tracker regarding allowing users to have multiple different header areas for different templates.

In the meantime, you can add the Masthead to your templates template area instead of the Header area.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
fliptheu    4
fliptheu

Hi,

 

You're most likely adding the MastHead section to the Header Template Area, which is a global template area. This means that any sections added to this area will be visible throughout your site.

There is already a issue posted on our tracker regarding allowing users to have multiple different header areas for different templates.

In the meantime, you can add the Masthead to your templates template area instead of the Header area.

 

Ah! That makes sense. Thanks!

 

What I have done as a workaround is give the masthead in the category section a local styling class, and then display:none; that class. 


fliptheu

"Finding beauty one picture and one pixel at a time."

http://www.fliptheu.com

Share this post


Link to post
Share on other sites
Rob    547
Rob

Glad to know you were able to find a solution.  :D


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

  • Similar Content

    • DonRicardoRVM
      By DonRicardoRVM+
        First of all, sorry for my bad English.  I am developing an ecommeece with wp, woocommerce, PL5 and quickshop, and I need to do some changes in the simple product grid. I want to change the classes of some divs, but I can't find the templates. 
      Also, I change the grid of the category products pages, but I didn't make it correctly.
      This is the cat archive's: http://globosdemar.com/wp/categoria-producto/camisetas-para-ninos-y-ninas/
      Can you help me?
    • poseyg
      By poseyg+
      Could someone explain exactly how the new template sync works or what it is suppose to do?
    • Anthony King
      By Anthony King+
      I have to say that I like the Layout and the Template based sections. Some of them are really impressive.
      One of the things that I would like to request though is the possibility of being able to dynamically rearrange the layout.
      An example of what I am talking about is take the Agency Section. It's current layout starts with the
      Splash Module then the Portfolio Module then the Service Module and so on and so forth.
      What would be great is if we were able to move these modules around. I.e have the Service Module first
      then maybe the Splash, and then the portfolio.
       
    • flourishdesignstudio
      By flourishdesignstudio
      I am using Jigoshop on a website that also uses PL5 and am running into an issue where the store pages do not allow me to use the PL5 editor. Is anyone else having this problem or know if a solution? 
      When I open the Chrome console I see the following error:
      site.js?ver=b199df:5 Uncaught ReferenceError: PLData is not defined
          at Object.setMasterModel (site.js?ver=b199df:5)
          at Object.init (site.js?ver=b199df:5)
          at HTMLDocument.<anonymous> (site.js?ver=b199df:5)
          at i (jquery.js?ver=1.12.4:2)
          at Object.fireWith [as resolveWith] (jquery.js?ver=1.12.4:2)
          at Function.ready (jquery.js?ver=1.12.4:2)
          at HTMLDocument.K (jquery.js?ver=1.12.4:2)
       
      The problem can be seen here: http://fingerlakesdistilling.com/shop/ where the sidebar, footer, and header do not show up. Any thoughts?
      Thanks so much!
    • Queue-it
      By Queue-it+
      I've created a new post category "Success stories" with Custom Post type UI. (in order to have a different layout for a different post category - blog post one layout, success stories another layout).
      New category "success stories" are "detached" from all the other posts, so they have a different layout, but the problem is that all of the success stories are also having the same exact content.
      So whenever I edit content (e.g. change body text) on one of success story posts, it also changes the content (body text) for all other Success story category posts. 
       
      Question: Is there a way to retain this separate category with it's own layout, and have a different content for each individual post? I'm using Pagelins templates. 
       Thanks in advance.
×