Jump to content

Archived

This topic is now archived and is closed to further replies.

Toby

Add padding to 'tabs' (shortcode) globally

Recommended Posts

Toby

Hi, I would like to add padding to the 'tabs' short code, globally so there is more space on the left and right throughout my site.

 

Here is an image of my section, and as you can seethe image lines up flush with the end of the tab.

http://postimg.org/image/lz0l3wtrx/

 

I would like to add 10px of padding to the left and right, I think I am on the right track with:

 

 

#site .tabs {
padding-right:10px;
padding-left:10px;
 
}
 
I am not sure what the identifier/property is.
Any help would be greatly appreciated, Thanks

Share this post


Link to post
Share on other sites
Erwan

Toby

Did you try with the tab-content class instead of the tabs class (not sure this one exists)?

Share this post


Link to post
Share on other sites
Danny

Toby,

 

I think Erwan is right and you should be targeting the tab-content class.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Toby

I applied it to the tab-content class and achieved this result:

http://postimg.org/image/uiokferi5/

 

As you can see it has pushed the white space over the 'content/loop' area, also it does not line up with the top line.

Is there a way to keep the padding within the 'content/loop' section?

 

If you want to compare this is what it looks like before i apply the padding:

http://postimg.org/image/lz0l3wtrx/

Share this post


Link to post
Share on other sites
Danny

Can you provide a link to the page in question please.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Toby
The site has an under construction banner on it at the moment.
I can take it down for 10 minutes if you like?

Share this post


Link to post
Share on other sites
Danny

Yeah sure, just reply here when you have taken it down, don't forget to link the page you're referring too.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Toby
Thanks Danny.
The site is active now.

The page is:
www.innovativethinkingit.com.au/news

I will put it back up in 10mins.

Share this post


Link to post
Share on other sites
Danny

That page doesn't contain any tabs ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Danny

Update, you gave me the wrong link :D

 

You should have give the Our Clients page link, nevermind. Add the following to your custom CSS:

 

#site .tab-content {
padding: 30px;
box-sizing: border-box;
}

http://d.pr/i/mG3D

 

Change the 30px value to whatever, you like. The more information on why I have added Box-sizing, see here - http://www.w3schools.com/cssref/css3_pr_box-sizing.asp


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Toby
I'm sorry I linked the wrong page.
The correct one is
www.innovativethinkingit.com.au/markets

Share this post


Link to post
Share on other sites
Toby
Amazing thanks Danny!!
The site is still up if you want to see what it looks like :)

Share this post


Link to post
Share on other sites
Toby
Site is back up now.
Thanks again for the help Danny"] and @[member="Erwan

Share this post


Link to post
Share on other sites
Danny

No problem.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Michael Kummer
      By Michael Kummer+
      Hi guys!
      I have noticed that my primary sidebar becomes intermittently invisible when browsing through various blog articles on michaelkummer.com/blog.
      See:
      https://www.dropbox.com/s/z646sgoa3mfjl1j/Screenshot 2018-07-12 15.57.46.jpg?dl=0 and https://www.dropbox.com/s/vdledzzgginvwgv/Screenshot 2018-07-12 15.57.57.jpg?dl=0
      Upon refresh, the sidebar appears. I have been using the following CSS code to hide the sidebar on mobile without any issues. 
      @media only screen and (max-width: 993px) {
      /* hide sidebars */
           .plsb {
              display: none !important;
          }
      }
      I tried to add the following CSS to force the sidebar to show on screens that are wider than 994 pixels but to no avail. Any clue what could be causing this issue?
    • Michael Kummer
      By Michael Kummer+
      Hi guys!
      I am using the LESS/CSS Pagelines extension and tried to add the following code to make use of FontAwesome:
      a.c2a:before {
          content: "\f07a\00a0";
          font-family: "Font Awesome 5 Pro";
          Font-weight: 900;
          font-style: normal;
          font-weight: normal;
          text-decoration: inherit;
          padding-left: 4px;
      }
       
      The issue is that as soon as I have the CSS via the Custom Styling text box, Pagelines (or the extension) strips out the backslashes (\). As a result, I had to abandon the CSS/LESS extension and instead add all my CSS code to a separate .css file.
      Is there a fix or workaround for this?
      Thanks
      Michael
    • glyph.marketing
      By glyph.marketing+
      Hello, I am having a problem similar to that experienced by Michael Kummer here. We have pages that show this automatic scrolling issue (examples here and here) and it is sufficiently annoying that we have seen customers bounce while trying to convert. Strangely, it only happens at specific resolutions, so it can be difficult to reproduce. In general we can only consistently reproduce it on a 4k resolution with a browser width between 1517 and 1536px. 
      Thanks to Michael Kummer's help we were able to set the overflow-anchor property to none in the entire body, which fixed the issue as far as we can tell, but also obviously disabled scroll anchoring for the whole site. I tried applying it to the specific element that looked like it was being reloaded, which was the PL Meganav extension, but that was unsuccessful. 
      Can anyone help us figure out which element or ID we can apply this property to, so that we can fix the scrolling issue but not disable scroll anchoring for the entire site?
      Thank you - 
      Glyph Language Services
    • chamois_blanc
      By chamois_blanc+
      Hello,
      Shouldn't the image PL5 component be using the srcset/picture css directives to pick the correct size for an image? or it does already and I don't know how to use it? Thank you for any advice or enlightenment.
    • Dan Haddock
      By Dan Haddock
      Plugins Active and installed: 
      Akismet Anti-Spam
      Coming Soon Page & Maintenance Mode by SeedProd
      Contact Form 7
      Cookie Law Info
      DMS Professional Tools  
      Enhanced Media Library  
      Flamingo
      Google Analytics for WordPress by MonsterInsights
      Google XML Sitemap
      Jetpack by WordPress.com
      Legull 
      Loginizer   
      MailChimp for WordPress
      PageLines Updater    
      Schema App Structured Data 
      Sucuri Security - Auditing, Malware Scanner and Hardening
      Uber reCaptcha    
      Yoast SEO
      Wordpress Version: 4.8.1
      Pagelines Version: 2.2.4
       
      Good Evening/Afternoon or Morning, 
      I am running into a problem with CSS styling not applying inside of most browsers (Safari, Firefox) when I am logged in to wordpress, and all browsers that I have tested when I am logged off and the site has been made public (Chrome, Firefox and Safari).
      As a result, I have managed to identify the probable cause. It looks as though these browsers are refusing to render my sites compiled CSS file due to it being a HTTP URL rather than HTTPS.
      I have attempted to change this URL to HTTPS in my browser, however it brings back an ERROR: File not found page - https://www.shortfilmblog.com/wp-content/uploads/pagelines/compiled-css-core-1505847507.css
      What would you suggest in this regard? Would this be resolvable from your end?
      Happy to provide any further details required.
×