Jump to content

Archived

This topic is now archived and is closed to further replies.

mrlipa

Page {LESS} compiler output not working

Recommended Posts

mrlipa

I'm working now with Pagelines DMS v1.0.2

 

I don't know why, the Page{less} plugin is not working, I am able to write my css or less code, but the compiler does not compile the code. In addition, when I hover over the compiled output zone, the mouse shows me a forbidden symbol. In conclusion. I can't edit specific pages. Any ideas? 

 

Thx for the help

Share this post


Link to post
Share on other sites
Jackey

Have the same problem... it does not compile.

Share this post


Link to post
Share on other sites
evan

jackey - Seems to be working for me.  Are you running the latest DMS?

 

Also, please check your console for JS errors.  Those could come from other plugins or something else.  Almost any JS error will throw a wrench in things.

Share this post


Link to post
Share on other sites
Jackey

Hi Evan,

 

Sorry forgot to look there:

 

L {type"Parse"message"missing opening `{`"filename"input"index25879line3}
  1. callExtractundefined
  2. callLineundefined
  3. column0
  4. extractArray[3]
  5. filename"input"
  6. index25879
  7. line3
  8. message"missing opening `{`"
  9. stackundefined
  10. type"Parse"
  11. __proto__Error
page-less.js?ver=1.2:67

Share this post


Link to post
Share on other sites
Jackey

Updated to 1.2.1 and DMS 1.0.3 at no avail.

Also disabled all plugins except Page{ LESS } at no avail.

Share this post


Link to post
Share on other sites
Jackey

Needed some time to sink in I guess... after a few page updates it started to work!

Share this post


Link to post
Share on other sites
Jackey

Hi Evan,

 

Still have an issue with the Page{ LESS } input panel. It seems to be a bit distorted, and sometimes there is displayed no content at all in it.

 

http://cl.ly/image/1M1c0r2h0Q1v

 

Can you reproduce that?

Share this post


Link to post
Share on other sites
Jackey

Maybe just a glitch... can't reproduce it myself.

 

Thanks!

Share this post


Link to post
Share on other sites
evan

jackey

 

Yeah, I've seen that now and again.  It has to do with the editor rendering.  If you click the Custom Code tab or PageLESS tab again, it should refresh and appear properly.  Otherwise, once you type anything, it straightens itself out right away.

 

About your compiling issue, it may've just been that it was a LESS parse error?  Hard to say.

 

Glad to hear it's all working now!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Michael Kummer
      By Michael Kummer+
      Hi guys!
      I am using the LESS/CSS Pagelines extension and tried to add the following code to make use of FontAwesome:
      a.c2a:before {
          content: "\f07a\00a0";
          font-family: "Font Awesome 5 Pro";
          Font-weight: 900;
          font-style: normal;
          font-weight: normal;
          text-decoration: inherit;
          padding-left: 4px;
      }
       
      The issue is that as soon as I have the CSS via the Custom Styling text box, Pagelines (or the extension) strips out the backslashes (\). As a result, I had to abandon the CSS/LESS extension and instead add all my CSS code to a separate .css file.
      Is there a fix or workaround for this?
      Thanks
      Michael
    • Steve Webb
      By Steve Webb+
      I am having an issue with DMS editor not loading.  Just keeps spinning and spinning.
      Have tried several things - Logged in and out, cleared cache, deactivated all plugins, but the issue persists.
      I even had our host restore from a backup a few weeks ago, when I know it WAS working, as I edited a text box on the homepage.  The restore from backup didn't help either.
      Also, the front end of the site shows that the site is framed, or boxed now (whatever you call it), instead of full width as it was previously (last week).
      Dev console shows that there are php errors in Google maps - file is attached.
      Can someone please help?  Not sure what else I can do here...
      Thanks in advance.
      -Matt

    • tuciudadenred
      By tuciudadenred+
      Hi everyone, what happens is that the web page metrosalarmas.com has a google tags which I have not attacked where I can look to remove those tags and be able to locate the correct ones.
    • Steve Webb
      By Steve Webb+
      I am having an issue with DMS editor not loading.  Just keeps spinning and spinning.
      Have tried several things - Logged in and out, cleared cache, deactivated all plugins, but the issue persists.
      I even had our host restore from a backup a week ago, when I know it WAS working, as I edited a text box on the homepage.  The restore from backup didn't help either.
      Also, the front end of the site shows that the site is framed, or boxed now (whatever you call it), instead of full width as it was previously (last week).
      Dev console shows that there are php errors in Google maps - file is attached.
      Can someone please help?  Not sure what else I can do here...
      Thanks in advance.
      -Matt

    • JawDesigns
      By JawDesigns
      Hi everyone,
      Flywheel have reported errors on my clients site 'www.racewaredirect.co.uk' and it's not loading. Can someone please provide some information on how to fix this? The site has never experienced these issues before.
      Thanks,
      James Wilson
×