Jump to content

Archived

This topic is now archived and is closed to further replies.

Leobons

How do I add menu items to the navbar?

Recommended Posts

Leobons

I saw someone from staff here saying it was under PageLines > Site Options which I don't even see as a menu in my backend. I try to add it in the customization screen by clicking on the edit button on the fixed navbar and selecting the menus from the drop-down (they are configured under the WP menus options) but they still don't show up in my navbar. This is my first day here :)

Share this post


Link to post
Share on other sites
Danny

Hi,

 

To assign a menu, first you need to create one - http://docs.pagelines.com/tutorials/adding-custom-menus

Once you have done this, goto the DMS Visual editor then drag & drop a navigation section onto your template. Once this is done, click the pencil icon (edit) for that section which will bring up that sections options, from here you should be able to configure/select your menu.

 

If you want to assign your custom menu to the Fixed Navbar, you will need to goto DMS Toolbar > Global Options > NavBar.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Leobons

Yes that's what I'm doing. I can't add my menu items from Global Options > NavBar. How do I do that?

Share this post


Link to post
Share on other sites
Rob

You're a bit confused, probably because you didn't read the link Danny provided.  Menu items are created at Dashboard > Appearance > Menus, not in DMS. 

 

You create the menu name, save it. Add items. Save the menu.  Then in Theme Locations you select the named, saved menu.  Then in DMS, you select it too.  Bingo, you'll have menu!


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Leobons

I've understood Danny pretty good. I'll put the word "already" in my post so it will be clearer:

 

"selecting the menus from the drop-down (they are (ALREADY) configured under the WP menus options)  ".

 

 

The menus are created and they are showing in the dropdown of Options>NavBar of the Customize screen but thy are still not showing up in the navbar :(

Share this post


Link to post
Share on other sites
Rob

Somehow, the default menu created by WordPress is showing up.   That means that the menu you say you created and already saved, is not selected in the Theme Locations. In DMS, under Global Options > NavBar, the saved, named menu isn't selected either.  So, DMS is selecting the default WP menu.  Can you tell me the name of your saved, named menu in Dashboard > Appearance > Menus


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Leobons

Thanks Rob. It just worked, I had some problems with the host so I had to do the installations all over again and it worked so I guess I don't know which exactly was the problem at the last time. I have another problem now: It won't activate the Pro account because it says I have already exceeded the maximum number of activations. It must be counting the previous activation, what do I do now? I guess I will be needing the Pro features like a different color and height for the fixed navbar.

 

Thanks for trying to help :)

Share this post


Link to post
Share on other sites

  • Similar Content

    • Liv Kundalini
      By Liv Kundalini+
      Hi -
      Pulling my hair out over here, and would love an assist!
      Site I am building, http://www.livkundalini.com/home, has a problem with the submenu items in the nav not appearing. 
      If anyone wants to see what the Nav should look like, feel free to look in the footer on the left hand side.
      Have tried disabling Pagelines and using the twentyseventeen theme, but problem persists.
      Saw this error (pasted at the bottom of this post) displaying in the inspector, and saw discussion of Jetpack potentially being a culprit. Disabled Jetpack, but the problem persists.
      Had the hosting company even flush the server-side cache, but no avail.
      Any thoughts? Please? It's the only thing keeping me from launching this site!
      Many Thanks,
      Todd
       
      WebSocket connection to 'wss://public-api.wordpress.com/pinghub/wpcom/me/newest-note-data' failed: Error during WebSocket handshake: Unexpected response code: 403   O @ (index):7
    • russe-intensif
      By russe-intensif+
      Hi team,
      checking my site today, i'm surprised to see my MegaNav all in bottom of the pages, while it's in header.
      After getting to change it in couple of pages onto Template part (too time consuming !), i'm desperate and ask you for help :-)
      apprendre-le-russe-avec-ania.fr
      Thank you in advance !

    • dwpoyner
      By dwpoyner+
      Not sure exactly what is causing the issue. For some reason, why you view my site on mobile, the menu does not show up. It will pop up, but it is black. You can check it out here: http://dev.caryfbc.org. I'm also attaching a screenshot where I shrunk my browser down. Any suggestions?

    • khat
      By khat+
      I think I may have installed pagelines pro incorrectly, and then used features incorrectly. I installed first platforms framework theme and then the child, thinking I could do setup for child later. I tried to set up a background image, and tried custom css feature in pagelines dashboard. I had mistakes in my css, and just thought that if I deleted the info in the css custom feature in pagelines dashboard that the new information would overwrite the old info. The background image didn't respond at all, probably because I didn't have the child directory renamed. I then tried to use the LSS plugin to create css and added more css, possibly, somewhere -sigh-. I never did change the background image and get it placed properly. I used a workaround and in nested containers I placed a background image which worked well enough, so I moved on to try to create my nav bar/ menu bar. When I go to the Menus panel, there is NO area where I can place a menu on a page. I have read and reread and re- re- reread the instructions for placing a menu. I've used the pagelines editor to place a menu, however only HOME shows up. I've been at this for many hours. I've since uninstalled all of my pagelines items and reinstalled, thinking that it would restore all my changes to default, but no, it is still all there, with all my unresolved issues. I am completely at a loss as to what to do next.
    • Jarek
      By Jarek+
      How to make the Impulse menu sticky?
      Here is a site that seems like it is doing just that: http://www.manhattanperiodontist.com/
      Here is the site I am working on: http://boeriu.digitalvector.com/ 
      I have no problem showing the menu at the bottom, but when scrolling up it does not stick.  I tried to add Nav Pro menu but when I do that, it just shows on top and no matter what I try is not working as I want it to.
      Any suggestions?
×