Jump to content

Archived

This topic is now archived and is closed to further replies.

gwnich

Loading Gravity Forms to DMS site failed

Recommended Posts

gwnich    1
gwnich

Hi, I tried uploading Gravity Forms plugin to my DMS site and received the below error.

 

Any ideas as to how to fix this?

 

Warning: Attempt to modify property of non-object in /home/content/71/10995271/html/virtualsalespresenter/wp-content/themes/dms/editor/editor.updates.php on line 93

Warning: Attempt to modify property of non-object in /home/content/71/10995271/html/virtualsalespresenter/wp-content/themes/dms/editor/editor.updates.php on line 93

Warning: Attempt to modify property of non-object in /home/content/71/10995271/html/virtualsalespresenter/wp-content/themes/dms/editor/editor.updates.php on line 93

Warning: Attempt to modify property of non-object in /home/content/71/10995271/html/virtualsalespresenter/wp-content/themes/dms/editor/editor.updates.php on line 93

Warning: Attempt to modify property of non-object in /home/content/71/10995271/html/virtualsalespresenter/wp-content/themes/dms/editor/editor.updates.php on line 93

Warning: Attempt to modify property of non-object in /home/content/71/10995271/html/virtualsalespresenter/wp-content/themes/dms/editor/editor.updates.php on line 93

Warning: Cannot modify header information - headers already sent by (output started at /home/content/71/10995271/html/virtualsalespresenter/wp-content/themes/dms/editor/editor.updates.php:93) in /home/content/71/10995271/html/virtualsalespresenter/wp-includes/pluggable.php on line875

Warning: Cannot modify header information - headers already sent by (output started at /home/content/71/10995271/html/virtualsalespresenter/wp-content/themes/dms/editor/editor.updates.php:93) in /home/content/71/10995271/html/virtualsalespresenter/wp-includes/pluggable.php on line875

Share this post


Link to post
Share on other sites
Blackice    5
Blackice

I experienced the same issue. I disabled all plugins. Then I enabled the security plugin first and then the gravity forms plugin. The issue never occurred again. You might want to try this if you haven't already.

 

 

Just my 2 cents.


Mark "Blackice" Robinson, CISSP

 


"If you can't explain it simply, you don't understand it well enough" - Albert Einstein

"We can't solve problems by using the same kind of thinking we used when we created them." Albert Einstein


 

CISO/Director   Creative Services

Email:                 mark@540online.net

Main SIte:           http://540online.com

Twitter Handle:  @online540

Share this post


Link to post
Share on other sites
gwnich    1
gwnich

Thanks for the help Blackice. Which security plugin did you load? Is this a Gravity forms plugin? Cheers G.

Share this post


Link to post
Share on other sites
Blackice    5
Blackice

No it's not a Gravity Form plugin. I have been using WordFence Security on the clients sites but testing Better WP Security with DMS. It is like having a Swiss Army Knife for security. However, it can screw things up if you're not careful in configuring the options. 


Mark "Blackice" Robinson, CISSP

 


"If you can't explain it simply, you don't understand it well enough" - Albert Einstein

"We can't solve problems by using the same kind of thinking we used when we created them." Albert Einstein


 

CISO/Director   Creative Services

Email:                 mark@540online.net

Main SIte:           http://540online.com

Twitter Handle:  @online540

Share this post


Link to post
Share on other sites
jeomiland+    2
jeomiland

Hi guys

 

I also had warning messages like that when installing GravityForms. Went back into Dashboard and all looked fine.

 

Then I added the Signatures add-on to GravityForms and when I make a form, I can see that Sig element working in the form preview, but it does not show up on the actual page.

 

Just sent a note to GravityForms about this and got reply including this:

 

John, there are a couple problems on this page. Take a look at the attached screenshot. See on lines 717-722 how each line ends in a <br /> - that is not supposed to be there. See lines 723, 724, 725 - that red highlighted closing < /p > should not be there. This is typically from a theme or plugin conflict, most commonly theme. You can read about the problem here with some common causes and solutions:

http://www.gravityhelp.com/forums/tags/raw-shortcode

 

Hope PL sees this thread and checks out if the Signature (and possibly other advanced add-on features in GravityForms) have conflicts within DMS and if so, to fix this bug...  The whole reason I plopped down the money for GravityForms was a client who needed Signatures.

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi,

 

I have gravity forms installed on my test site and do not receive any of these warnings, its most likely you have WP_DEBUG set to true instead of false or there is another plugin causing a conflict.

 

Regarding your issue with teh signature addon, if you can email me the plugin, as well as an export of your form and instructions on where and how you added the form to your site, I will try and recreate the issue.

 

danny at pagelines dot com

 

If you have any other GF addons send them myway and I can test those too. However, please be aware that I do my testing on a vanilla setup of Wordpress i.e no third party plugins installed.

So before sending me anything, disable all custom scripts, code you may have added as well as all active plugins and see if this resolves your issue.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

×