Jump to content

Archived

This topic is now archived and is closed to further replies.

save4eg

<--more!--> tag customize

Recommended Posts

save4eg

Hello! 

I want to delete "Read more" text in posts, and need to change properties of <--more!--> tag in theme DMS. Where it can be changed in DMS?

 

Sorry for my english...


Sorry for my english. Grammar for me is a big trouble :)

 

Share this post


Link to post
Share on other sites
Rob

Try adding this to your custom code, but please, check your site to see what other implications it may have. 

.continue_reading_link {
   display: none;
}

Let us know if that works.

 

There doesn't seem to be a setting I can find.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Erwan

Try adding this to your custom code, but please, check your site to see what other implications it may have. 

.continue_reading_link {
   display: none;
}

Let us know if that works.

 

There doesn't seem to be a setting I can find.


It works for me, with or without #site overriding ID.

But t's it of course radical and sitewide as far as I'm aware: all DMS excerpts won't show the link, including those used in the PostPins section for instance, or if you insert some <!--more--> quicktags mentioned by @save4eg in some posts to "customize" their excerpt.


Same result btw using a DMS action hook (in child theme functions.php):

add_action( 'continue_reading_link', 'remove_continue_reading_link' );
    function remove_continue_reading_link(){
    return '';
}

Share this post


Link to post
Share on other sites
save4eg

Try adding this to your custom code, but please, check your site to see what other implications it may have. 

.continue_reading_link {
   display: none;
}

Let us know if that works.

 

There doesn't seem to be a setting I can find.

 

Like Erwan wrote it works, but not for all sections on site.

 

Example: it works for Content\post loop, but doesn't work for widgetized areas with featured posts inside of it. Maybe it is mine "Featured Posts" plugin trouble...


Sorry for my english. Grammar for me is a big trouble :)

 

Share this post


Link to post
Share on other sites
Erwan

save4eg

Seems logical to me at first sight. Both methods mentioned above use "continue_reading_link" which is a DMS core CSS class and a DMS core hook (said differently: does not belong to WP core), hence targeting only DMS sections whatever they are. Your plugin use one way or another one of the WP functions to display excerpts, and has its specific functions and CSS.

For instance, I use the Special Recent Posts plugin: I get rid of the "[...]" at the end of the excerpts with:

 

.a.srp-widget-stringbreak-link {

     display: none;

}

Tell us if you manage to do it with the plugin you use (no idea which one it is), so that Rob can mark the topic as solved ;).

Share this post


Link to post
Share on other sites
Rob

save4eg

Your request to remove the Read More link only deals with the blog postings.  It doesn't affect plugins, widgets, or anything you'll add into the sidebar, footer, etc. If you have anything like that, you have to inspect the element in a tool like Firebug for Firefox, and find the CSS used for that link.  That will let you apply display: none; and remove the link.

 

Erwan

Not everyone knows how to use hooks, so it would probably be best to use CSS solutions only, without confusing the issue with added processes most will not understand.  If you do refer people to a hook, please also refer them to the docs page so that they will have a basic knowledge of them.   Thanks for understanding.  Well done!


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
save4eg

save4eg

Seems logical to me at first sight. Both methods mentioned above use "continue_reading_link" which is a DMS core CSS class and a DMS core hook (said differently: does not belong to WP core), hence targeting only DMS sections whatever they are. Your plugin use one way or another one of the WP functions to display excerpts, and has its specific functions and CSS.

For instance, I use the Special Recent Posts plugin: I get rid of the "[...]" at the end of the excerpts with:

 

.a.srp-widget-stringbreak-link {

     display: none;

}

Tell us if you manage to do it with the plugin you use (no idea which one it is), so that Rob can mark the topic as solved ;).

Problem solved :) That was a Stupid Plugin) Erwan"] @[member="Rob, Thank you!


Sorry for my english. Grammar for me is a big trouble :)

 

Share this post


Link to post
Share on other sites

  • Similar Content

    • Bleuy
      By Bleuy+
      How can I get support on pagelines DMS? The product isn't that old and my skeleton themes aren't working and I can't get support in the same way? 
    • Bleuy
      By Bleuy+
      I have a number of legacy websites that are running on the above version of Pagelines DMS, where the template has stopped working. I am using a skeleton theme to all of them. What do I need to do to rectify this.
       
       
    • Steve Webb
      By Steve Webb+
      I am having an issue with DMS editor not loading.  Just keeps spinning and spinning.
      Have tried several things - Logged in and out, cleared cache, deactivated all plugins, but the issue persists.
      I even had our host restore from a backup a few weeks ago, when I know it WAS working, as I edited a text box on the homepage.  The restore from backup didn't help either.
      Also, the front end of the site shows that the site is framed, or boxed now (whatever you call it), instead of full width as it was previously (last week).
      Dev console shows that there are php errors in Google maps - file is attached.
      Can someone please help?  Not sure what else I can do here...
      Thanks in advance.
      -Matt

    • tuciudadenred
      By tuciudadenred+
      Hi everyone, what happens is that the web page metrosalarmas.com has a google tags which I have not attacked where I can look to remove those tags and be able to locate the correct ones.
    • Steve Webb
      By Steve Webb+
      I am having an issue with DMS editor not loading.  Just keeps spinning and spinning.
      Have tried several things - Logged in and out, cleared cache, deactivated all plugins, but the issue persists.
      I even had our host restore from a backup a week ago, when I know it WAS working, as I edited a text box on the homepage.  The restore from backup didn't help either.
      Also, the front end of the site shows that the site is framed, or boxed now (whatever you call it), instead of full width as it was previously (last week).
      Dev console shows that there are php errors in Google maps - file is attached.
      Can someone please help?  Not sure what else I can do here...
      Thanks in advance.
      -Matt

×