Jump to content

Archived

This topic is now archived and is closed to further replies.

calvado32

server error log

Recommended Posts

calvado32+    0
calvado32

Hallo ,

 

For some unknown reason, my site has suddenly started putting an error line:

500 Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

bla...bla...

 

I checked the server error log :

  • mod_fcgid: stderr: PHP Warning: call_user_func_array() expects parameter 1 to be a valid callback, first array member is not a valid class name or object in /var/www/vhosts/polishdinner.de/httpdocs/wp-includes/plugin.php on line 406

or,

  • Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /var/www/vhosts/polishdinner.de/httpdocs/index.pl

:stuff: Help! What I have to do ? I'm just a cook. :D

 

Any help much appreciated
thanks,

Mariusz

Share this post


Link to post
Share on other sites
Simon    247
Simon

OK a 500 error is a fatal error soPHP cant continue, if you turn on WP_DEBUG in wp-config.php it will be revealed.

 

The error you pasted is just a warning, it is not the error you are looking for.

Share this post


Link to post
Share on other sites
calvado32+    0
calvado32

OK,

I have now turned WP_DEBUG in wp-config.php

Share this post


Link to post
Share on other sites
batman    389
batman

Hello @Simon_P

 
I have the same problem at random.
I am using a godaddy shared host.
My PageLines Debug says.
 

WordPress Version : 3.6

Multisite Enabled : No

Current Role : Administrator

Framework Path : /home/content/62/9163462/html/wp-content/themes/dms

Framework URI : http://mac-fotografia.com.ar/wp-content/themes/dms

Framework Version : 1.0.1

Framework Build : 1.0.1

PHP Version : 5.3

PHP Magic Quotes gpc : Yes (bad)

PHP memory : 256

Mysql version : 5.0.96-log

Sections DIR : Writable.
/home/content/62/9163462/html/wp-content/plugins/pagelines-sections

Sections Plugin : Not Active!

PHP type : Cgi-fcgi

PHP User : Posix functions are disabled on this host!

OS : Linux

Launchpad : Not logged in.Plugins : 6
add-local-avatar/avatars.php
classy/classy.php
grid-shortcodes/grid-shortcodes.php
nextgen-gallery/nggallery.php
splash-box/splash-box.php
tinymce-advanced/tinymce-advanced.php

 

This is because my host is very bad?
Thanks and sorry for the inconvenience.

 


Life is too short to remove USB safely ...

Share this post


Link to post
Share on other sites
calvado32+    0
calvado32

Hi,

 

Server Error shows is how it works with Option Page Setup

 

and page is loading very-very slow 

 

what to do now?

thanks,

Mariusz

Share this post


Link to post
Share on other sites
Rob    547
Rob

Mariusz,

 

Did you FTP into your site, go to wp-config.php and edit the debug option from false to true?  See the WP_DEBUG information here: http://docs.pagelines.com/support-troubleshooting/white-screen-of-death

 

This will provide all the errors that your site is throwing and point us to the issue. So far, nothing you're pointing to is related to PageLines, but to plugins.  Likely one is causing many PHP errors and drying to process continually. 

 

Once you get the errors, paste them here.

 

Then, deactivate all your plugins.  Change the debug back to false in wp-config.php.  

 

If there are no more 500 errors, then you can reactivate the plugins, one at a time, and checking the site for more errors.  If they come back, then you have to remove that most recently reactivated plugin.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

  • Similar Content

    • juice-qr
      By juice-qr
      Hi, we're on pagelines 1.5.2 (I believe the free version) with wordpress 3.8.1,
       
      We have 2 servers, a new server running apache 2.2.15 with centos 6., and an older server with centos 5.5. running apache 2.4.2.
       
      Trying to figure out a caching issue on the newer server, when we make changes to the custom css, it's not being updated on the apache 2.2.15 server.  On the apache 2.4.2 server, it works fine.
       
      Is this possibly an issue with pagelines needing to be updated? Or is there an apache config somewhere I can check? I read that it might be an issue with the apache sendfile directive, I've turned that off on the new server.
       
    • benz_admin
      By benz_admin
      Hi to all,
      on this category page I have a error 500 http://www.turismopesaro.com/hotel-a-pesaro/
       
      I controlled the error log on my server (attachment) but I didn't find the problem.
      I tryed to upload from Pagelines 2.4 to 2.4.1
       
      Please, can someone help me?
      Thansk a lot!
       

    • pracede
      By pracede
      I use Pagelines developper edition. Wordpress is installed on the root directory of my server. I configure my permalink like http://mpmea-congo.com/index.php/sample-post/ (see attached file) this but all my link are formed like the following http://mpmea-congo.com/index.php/demarches-administratives/ having index.php in the permalink. I'd like to knnow how to remove it ?
      Thanks

×