Jump to content

Archived

This topic is now archived and is closed to further replies.

sheilahoff

Adding Extra Google Fonts

Recommended Posts

sheilahoff

In Global Options there's a place to add Extra Google Fonts. So I've followed the example added these:

Cherry+Swash:400,700 | Muli:400,400italic

 

I gather this does not make them appear in the Primary & Text Header drop downs.


When I look at the generated source code I see under <!-- Styles -->
<link id='master_font_import' rel='stylesheet' type='text/css' href='//fonts.googleapis.com/css?family=Cherry+Swash:400,700 | Muli:400,400italic'>

 

So far it looks right.I may just have my CSS wrong but I'm not seeing these fonts appear. Here's the CSS I've used:

 

p {font-family:font-family: 'Muli', sans-serif}

h1,h2,h3,h4,h5,h6 (font-family: 'Cherry Swash', cursive;)
 

What am I missing?

 

ALSO: I saw in another thread where Rob offered "If you have a particular font you're trying to use, let us know and we can ask our developers to add it with the next update.  They're pretty good about that."

 

I'd love for these 2 to be added. In fact, it would be AWESOME to make all Google Fonts available through the interface.

 

BTW site under development at www.etc.hoffmangraphics.com

 

Thanks.


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
Rob

Sheila, Muli G and Cherry Swash G are already in Googlefonts on my list.  Did you check it in Global Options > Typography?  (the G means it's called as a Google font, not a resident font, but you know that.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
sheilahoff

Thanks Rob.

 

That's odd. I do not see Muli or Cherry Swash in my Global Options Typography. I looked there first! Meanwhile the client has changed from Chery Swash, which I did get working (bad syntax on my part) to Bentham which is also not listed in my listing. Why would that be?

 

I'm wondering if I'm adding these wrong. It appears that I'm suppose to add multiple fonts with "pipe" between them but I'm seeing the generated code include that pipe which seems wrong:

<link id='master_font_import' rel='stylesheet' type='text/css' href='//fonts.googleapis.com/css?family=Bentham | Muli:400,400italic'>

 

So I'm getting the first font to appear as the heading but the second one is not displaying as the body font. Could still be syntax as I'm not very proficient in CSS.Or it may have to do with how DMS adds them.

 

I am seeing a CSS/LESS parse error for the Muli font.

 

Here's my current CSS

#body {
   font-size: 1em;
   line-height: 1.75em;
   font-family:'Muli', sans-serif; font-weight: 400;}

h1,h2,h3,h4,h5,h6 { font-family: 'Bentham', serif; font-weight: 400; }

Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
Rob

Sheila,

 

I think you're not looking at the Typography list thoroughly.

 

It is broken into 'types', so the entire list isn't alphabetical.  If you scroll down a good bit, you'll see the alphabetical lists re-start, and Bentham is there.  We have the same license type, so I'm not getting any fonts you're not. Make sure you refresh the font list, but essentially, I think it's just that with 650 plus fonts you're just missing these.  Scroll down to Yanone Kaffesatz G and you'll see a whole new list there.  This is the bunch of fonts that load from Google (note the G *).  You'll find Bentham right there along with the rest.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
sheilahoff

Rob, I just created a list of all the fonts that appear in my list by doing multiple screen captures. Please show me where Bentham is here: http://www.hoffmangraphics.com/downloads/fonts.jpg. I do not have anything past Yanone Kaffesatz G. I suspect there's a plugin I'm missing or something! Maybe I need to install the legacy Framework plugin called Googlefonts? I just tried that and indeed I now have the full list. I'm not sure how anyone would know they're supposed to upload legacy plug-ins to the DMS when we've been warned not to do that! They were only made available for using in Framework!

 

BTW...I FTP'd my image as I couldn't figure out how this forum allows attaching an image. Pretty lame. It requires a url!

 

You can mark this as resolved. Hopefully it will help others.

 

Thanks.


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
Rob

Sheila,  I have the PageLines Googlefonts plugin activated. So probably you do need it.

 

[attachment=1418:8-25-2013 12-08-37 PM.jpg]

 

You can see where it is on my DMS development site.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
sheilahoff

Thanks Rob. Where is your DMS dev site? As I said above, I did install the legacy plugin and I do now have all the fonts. I just don't think it's intuitive that we should know to install it since it's not a DMS tool. But it works and I'm happy.


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
Rob

Sheila, its at dev.epicurus.com and I'm still working on it, so do forgive the messiness. I think the plugin was included when I imported stuff from the old site installations.

 

I'm glad you have the fonts working.  Ultimately, that's what counts.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
bfrye26

how do you get the google fonts plugin? It is not in the store yet?

Share this post


Link to post
Share on other sites
sheilahoff

@bfrye according to Rob's post it's supposed to now be included but I am not seeing it. I got it when they had the old legacy framework sections posted and linked to. I can't find that link now but I've uploaded the GoogleFont plug-in (install as a plug-in and activate). Hopefully providing this is not against the TOS. I'm sure someone will let me know if it is. Here's the link to my upload of it: http://www.hoffmangraphics.com/downloads/plugin-pagelines-googlefonts.zip


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
greenfly

Thanks for helping out with the link Sheila :) 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
Rob

You can also go to http://launchpad.pagelines.com/api/store_free/

 

Save but change the file name of plugin-pagelines-googlefonts.zip to pagelines-googlefonts.zip

 

Then, install it as a plugin.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
nfp1900

is this still a valid bit of advice installing the old pagelines google fonts plugin? Didn't want to screw things up in 1.1.1

Share this post


Link to post
Share on other sites
sheilahoff

AFAIK it is. I'm using it on half a dozen DMS sites in 1.1.1 with no issues.


Sheila Hoffman | Hoffman Graphics | Seattle

Share this post


Link to post
Share on other sites
Danny

As far as I am aware the Google Webfonts still works, just not sure it is updated with all the latest fonts.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

×