Jump to content

Archived

This topic is now archived and is closed to further replies.

dhrose

NextGen Gallery update... broke carousel?

Recommended Posts

dhrose+    3
dhrose

I updated my NextGen gallery plugin on my Framework site and all my carousel's are broken. The galleries are on the page and the i.d.'s is correct but the galleries don't show anymore? Hmmm... plugin is activated but the pages don't preview the images. 

 

dhrcreative.com

Share this post


Link to post
Share on other sites
Blackice    5
Blackice

Which version of Nextgen are you using?


Mark "Blackice" Robinson, CISSP

 


"If you can't explain it simply, you don't understand it well enough" - Albert Einstein

"We can't solve problems by using the same kind of thinking we used when we created them." Albert Einstein


 

CISO/Director   Creative Services

Email:                 mark@540online.net

Main SIte:           http://540online.com

Twitter Handle:  @online540

Share this post


Link to post
Share on other sites
dhrose+    3
dhrose

Apparently I've been so focused on dms I wasn't paying attention to the Framework issues... Ha!  I just started upgrading some plugins on my Framework site without reading the news... I was on 1.9.3 and the latest 2.0.11 broke it. I rolled back to the 1.9.3 and it's working again, but that's a little disturbing that something that's that heavily used in Framework could brake big big! Lot of galleries I'm using that on...

 

Thanks. 

Share this post


Link to post
Share on other sites
batman    389
batman

Hi dhorse

I use Nextgen too, and the problem is the plugin in most of the themes, not only Framework. You can see the Nextgen blog and you can see they have a lot of problems. 

;)


Life is too short to remove USB safely ...

Share this post


Link to post
Share on other sites
dhrose+    3
dhrose

So has anyone got it to work beyond 1.9.3? And how... Someone mentioned ftp to activate it? I had to do that to replace current version... does that work with the new version? 2.0.11.

Share this post


Link to post
Share on other sites
Blackice    5
Blackice

I have it working with 2.0.7 on this site http://www.tateworks.com (using pagelines 2.4.4). Its in the sidebar as a widget.


Mark "Blackice" Robinson, CISSP

 


"If you can't explain it simply, you don't understand it well enough" - Albert Einstein

"We can't solve problems by using the same kind of thinking we used when we created them." Albert Einstein


 

CISO/Director   Creative Services

Email:                 mark@540online.net

Main SIte:           http://540online.com

Twitter Handle:  @online540

Share this post


Link to post
Share on other sites
Blackice    5
Blackice

I just did an update to 2.0.11 and everything is working fine.


Mark "Blackice" Robinson, CISSP

 


"If you can't explain it simply, you don't understand it well enough" - Albert Einstein

"We can't solve problems by using the same kind of thinking we used when we created them." Albert Einstein


 

CISO/Director   Creative Services

Email:                 mark@540online.net

Main SIte:           http://540online.com

Twitter Handle:  @online540

Share this post


Link to post
Share on other sites
batman    389
batman

I just update too 2.0.11 and all works fine.


Life is too short to remove USB safely ...

Share this post


Link to post
Share on other sites
dhrose+    3
dhrose

Hmmm... I did the standard update plugin from the plugins view to 2.0.11. And the carousel stopped working. I put 1.9.3 back in and it started working again? Not sure what the problem is. I have my carousel on the page template set to display the gallery i.d. nothing changed other than the version. Framework 2.4.4

 

On this page and a couple others...

 

http://dhrcreative.com/about-me/

 

http://dhrcreative.com/design/

Share this post


Link to post
Share on other sites
Blackice    5
Blackice

When I first performed the update from 1.9.3 to 2.0.7:

 

  • Flush the cache of any CACHE plugin
  • Deactivate the Cache Plugin
  • Downloaded the version 2.0.7 from Photocratti
  • Unzip download
  • FTP it to Web server (wp-content/plugins)
  • Overwrite any files it needed (images and albums were not touched)
  • Reactivate NextGen Plugin first
  • Make any tweeks that were necessary
  • Then Re-activated cache plugin

 

That worked fine for me. I was then able today to perform a standard update using ManageWP on the site (to version 2.0.11)

 

Hope this helps.


Mark "Blackice" Robinson, CISSP

 


"If you can't explain it simply, you don't understand it well enough" - Albert Einstein

"We can't solve problems by using the same kind of thinking we used when we created them." Albert Einstein


 

CISO/Director   Creative Services

Email:                 mark@540online.net

Main SIte:           http://540online.com

Twitter Handle:  @online540

Share this post


Link to post
Share on other sites
dhrose+    3
dhrose

What tweeks did you have to do? I'm assuming you don't mean browser cahe, as I don't have any cache plugins anyway. Frankly I spent a LOT of time getting the correct image sizes for the thumbnails on these carousel's so I'm not to keen on redoing all those settings. I dread changing anything in Wordpress when I get it set the way I want it... Ha!

Share this post


Link to post
Share on other sites
Blackice    5
Blackice

:D No I was not referring to the browser cache. I did not have to touch any of the images or gallery. I had to correct a CSS issue that my client inserted to the website with out documenting what they had changed. (one of the reason i use managewp is so clients can send me what they changed from the admin dashboard.... another story for another day)

 

If you are worried about making changes, I would wait to you have a green zone. Do a full backup of site and database (I prefer duplicator instead of backup buddy). Do the upgrade. It is not functioning properly rollback. Then submit a trouble ticket to Photocratti.

  • Like 1

Mark "Blackice" Robinson, CISSP

 


"If you can't explain it simply, you don't understand it well enough" - Albert Einstein

"We can't solve problems by using the same kind of thinking we used when we created them." Albert Einstein


 

CISO/Director   Creative Services

Email:                 mark@540online.net

Main SIte:           http://540online.com

Twitter Handle:  @online540

Share this post


Link to post
Share on other sites
Rob    547
Rob

Good advice.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
dhrose+    3
dhrose

It would be nice if it just worked. The Pagelines base Carousel is too important to be breaking on update.

Share this post


Link to post
Share on other sites
Rob    547
Rob

First, let me say I've been fixing or trying to fix issues with the PL Carousel in Framework where NextGen is the source for over a year.  That gallery has had issues, not just with PL but with other themes, platforms and systems for a while.  I'm not saying they're at fault or have a bad product. It is simply that it doesn't work 100% with every website, or every system.  A thousand and one variables could impact it, through no fault of NextGen, nor of PageLines. 

 

The problem that is affecting Framework isn't the Carousel. It's the use of NextGen as the source of your thumbnails.  If you switch to Posts, you'll see the carousel works perfectly.

 

More than likely, you simply need to visit their website, download an older version and replace the new one. Another option is to deactivate the plugins other than Nextgen and see what happens to the carousel.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
dhrose+    3
dhrose

I do have it working with an older version. I'm just whining... that I have to fix this stuff when it breaks. I miss the old html days. Sigh. 

Share this post


Link to post
Share on other sites
Rob    547
Rob

I used to have HTML dreams, in code.  Eyes close, I'd see <html>... Glad those days are gone!


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
trisquelmedia    7
trisquelmedia

i send a bug report with this issue but has not yet been solved (v2.0.33) and if not fix it someday. Nothing to do from the side of Pagelines? :-(

Share this post


Link to post
Share on other sites
Rob    547
Rob

I'm sure the folks at NextGen are aware of their issues and are working to fix it. 


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
trisquelmedia    7
trisquelmedia

This is the answer I have given me Next Gen Gallery developers, Pagelines Framework have to make a minor modification to the code.

 

"The PageLines Carousel code may be asking for its information that is not compatible with the current version of NextGEN Gallery. There have been many changes to the underlying code when we moved to the current 2.0.x branch and several older pieces of code may need to be re-factored to use our current plugin framework."

Share this post


Link to post
Share on other sites
Rob    547
Rob

Their answer makes perfect sense, but our Carousel is an older technology, and isn't likely to be updated anytime soon.  We do offer a premium plugin that works with both Framework and DMS called Cool Carousel.  You can find it here: http://www.pagelines.com/shop/sections/cool-carousel/

 

I'm not sure there's any other way to resolve this other than to use a different carousel or an earlier version of NextGen.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
dhrose+    3
dhrose

My problem with this is that I spent a lot of time setting up the carousel, creating the galleries and getting the correct scaling for the next-gen. I mean weeks. I have to basically throw out that to redo the basic portfolio site I have. Not sure how easy it is to set up this $24.95 one, but that's a lot of work, and I have to pay for it... Or redo the site in DMS which I started, but then I have to move the whole site, which creates a whole new can of worms... Er, I suppose my love for website building... and wordpress is showing. Ha!

Share this post


Link to post
Share on other sites
Rob    547
Rob

You still have the viable option of using the 1.9.x version of NextGen, which still works well with our Carousel, thus removing any chance you'd have to reconstruct your previous work.

 

I understand your frustration, but the Carousel isn't new, by any measure, and when third party companies change their code, we can't upgrade what is essentially an out dated product.  As you know, the Carousel wasn't included in DMS, for this very reason. It's simply not adaptable enough to the newest technology.

 

Unfortunately, technology advances, and all too often (for my tastes, too), it means having to rebuild things far too often. You have my complete sympathies and agreement on that.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

×