Jump to content
Sign in to follow this  
Sourena

PlatformBase recognized as a Broken Themes

Recommended Posts

Sourena    2
Sourena

I uploaded both "PlatformPro" and "PlatformBase" to the Themes folder. I can activate "PlatformPro" but "PlatformBase" is shown as a Broken Themes. The theme's page says:

The following themes are installed but incomplete. Themes must have a stylesheet and a template. Name Description PlatformBase The parent theme is missing. Please install the "PlatformPro" parent theme.
As I said the theme "PlatformPro" is installed and can be activated.

alefba.us

Web Development & Design for Right-to-Left languages

Share this post


Link to post
Share on other sites
woodsysa    0
woodsysa

Read the other threads - you either need to WAIT till they admit the error and fix this or do the edit yourself so the pro "recognises" the correct platform pro lettering - it an upper case and lower case issue!! Then try the drag and drop - it's not working either. ;o)

Share this post


Link to post
Share on other sites
j1diek    0
j1diek

I have the same issue. Is it the line is sytle.css Template: PlatformPro that needs to be changed to Template: platformpro

Share this post


Link to post
Share on other sites
scottbruzek    0
scottbruzek

As mentioned in the linked discussion linked to, Here are the possible solutions: 1)The problem is that the theme folder is called "platformpro" and the Base theme looks for "PlatformPro". If it is hosted on unix boxes, capitals and small letters are not the same. Just look at style.css in the Base theme folder, and fix it by writing "platformpro" in these lines:

Template: PlatformPro
	
	/* ======================= */
	/* = Get PlatformPro CSS = */
	/* ======================= */
	
	/* Get Core CSS */
	@import url('../platformpro/core/css/core.css');
	
	/* Get Dynamic CSS */
	@import url('..platformpro/core/css/dynamic.css');
	
	/* Get Theme-Parent CSS */
	@import url('../platformpro/css/theme.css');

IF #1 DOES NOT WORK, try #2 below. 2)I simply changed the main Platform Pro theme folder name to "PlatformPro"(instead of "platformpro") to P's being in caps and this worked when #1 didn't work. ...These are both temporary fixes and Pagelines need to fix this and many other issues in the next update.

Share this post


Link to post
Share on other sites
cmunns    16
cmunns

Did everybody get the update that fixes these issues? v 1.0.9?

Share this post


Link to post
Share on other sites
scottbruzek    0
scottbruzek

My site has been updated with 1.0.9 and is fixed.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×