Jump to content

Archived

This topic is now archived and is closed to further replies.

opwolken

Only 64 MB memory from hosting, pagelines possible?

Recommended Posts

opwolken    3
opwolken

Hi,

 

I'm am starting a website with a hosting which only supports 64MB php memory. When installing wordpress and later on pageslines DMS i get this error.

 

Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 64 bytes) in /public/sites/www.iteratie.nl/wp-content/themes/dms/includes/less.plugin.php on line 282

 

I suppose this is due to the memory limit of 64MB by the hosting and before I contact my client, I would like to know if there is a workaround and get pagelines to work within these 64MB?

 

 

Share this post


Link to post
Share on other sites
thebastion    20
thebastion

I'm running it on only 40mb on one shared server and have no issues at all.

Share this post


Link to post
Share on other sites
opwolken    3
opwolken

thank you for the answer, but unfortunately, this does not help me a bit. Do you agree that the error states that I have a too low php memory? I checked this with the provider and it is indeed 64 mb.

 

I'm using wordpress 3.6 and pagelines DMS 0.9.7. Is this different than yours? 

Share this post


Link to post
Share on other sites
thebastion    20
thebastion

All I was saying was I'm running lower memory so essentially I was helping you work out that a system can run on lower memory than your system has, anyway yes I'm running the same set up as you, WP3.6 and DMS 0.97.

 

I'm no expert on servers or PHP but it does look like your server reached its allocated memory limit when trying to read line 282 in the less file.

 

Do you have a lot of plugins running?

Share this post


Link to post
Share on other sites
opwolken    3
opwolken

you're right, i'm a little frustrated by it :p.

 

I have deleted all of my plugins, I have none at the moment. I just can't figure out why it needs the 64mb at least.

Share this post


Link to post
Share on other sites
thebastion    20
thebastion

Are you using the github or pagelines version?

Share this post


Link to post
Share on other sites
pfaustino    0
pfaustino

I had the same problem. Fortunately, my hosting allows me to increase to 128Mb which got rid of the error.

Share this post


Link to post
Share on other sites
opwolken    3
opwolken

So there is probably no workaround?

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

opwolken

 

I have just visited your website and it appears to be working. Therefore, can you enable PL Debug mode please.

 

DMS Toolbar > Global Options > Advanced

 

Once enabled reply here and we can investigate the issue further. PageLines DMS shouldn't require 64Mb or more to run.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
opwolken    3
opwolken

Hi Danny,

 

Thank you for the help. 

 

the site i'm referring to is http://iteratie.nl/

 

my own site is based on a different hosting partner.

Share this post


Link to post
Share on other sites
Rob    547
Rob

opwolken"] when @[member="thebastion asked you which version you're using, he was trying to clarify what site was used for the source of your installation: whether it was the documentation or our homepage. 

 

Please go to http://www.pagelines.com and fill out the form when clicking the red button. This will give you a download file called dms.zip.  Please unzip the file and save the dms folder (it contains) to your desktop.

 

FTP into your site. Navigate to wp-content/themes and find either dms or DMS-DEV.  Delete either one (or both if you have the two).

 

Let the deletion process complete.

 

Then, upload the dms folder you saved to your desktop. Let the upload complete.

 

In Firefox, go to your website and login as admin.

 

Browse to Dashboard > Appearance > Themes and make sure DMS is the activated theme.

 

Then, view the site in Firefox.  It will look much better.  Your current installation is broken.

 

PS. If you do not have the ability to FTP, use the file management tools provided by your host.  That should be a very loud sign that you need a new hosting company.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
opwolken    3
opwolken

Hi Rob, thank you as well for the help. 

 

I have done this procedure of installment many times, and did so just the right way (installing the dms.zip via ftp). The problem is though that after installing, and when activating I get the error which I reported in my first post:

 

Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 64 bytes) in /public/sites/www.iteratie.nl/wp-content/themes/dms/includes/less.plugin.php on line 282

 

I believe because of this error my DMS installment is broken.

 

I am now wondering why I get this fatal error. Because as said a 64 php memory should be enough.

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Can you please enable PL Debug mode please. The issue is most likely related to your server configuration, providing these details may help us resolve your issue.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Rob    547
Rob

@opwolken  Is there a phpinfo.php file in your site? If so, please point us to it.  If your host is providing ONLY 64mb of memory, in total, then we don't know if there is actually 64Mb allocated to PHP.

 

When such errors occur, it's often a plugin conflict, or a server issue.  You could have 64Mb as your host says, but they could have your site on a machine with 650 other websites.

 

We just don't know. 


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
opwolken    3
opwolken

Hi Danny"] and @[member="Rob, 

 

I have enabled debug and below you find the phpinfo. 

 

http://iteratie.nl/phpinfodaan.php

 

thank you again for helping, you're doing a good job and keeping the forum life and healthy!

Share this post


Link to post
Share on other sites
Danny    1,327
Danny
Hi, Are you sure you have enabled PL Debug mode, as the URL isn't working.

Please search our forums, before posting!

Share this post


Link to post
Share on other sites
opwolken    3
opwolken

I have just checked and I'm sure. 

I have set WP_debug from false to true.

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Ah I apologise I mean PageLines debug mode.

 

Which you can find from DMS Toolbar > Global Options > Advanced


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

opwolken - slightly confused by your latest reply, you're the one who started the topic so we know you have an issue that is why we are responding. I have asked if you can enable PageLines debug mode, the instructions are above.

When you have it enabled, please reply here informing us.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
opwolken    3
opwolken

Danny

 

I will summarize my problem.

 

I have an hosting server on which I installed wordpress (working properly),

after that I uploaded DMS 0.9.7 from www.pagelines.com from within wordpress.

this installment has no problems.

Then I activate the DMS in wordpress, and when I do so I get the error below and the DMS is not properly activated or installed, I don't know.

 

Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 64 bytes) in /public/sites/www.iteratie.nl/wp-content/themes/dms/includes/less.plugin.php on line 282

 

the line number in the error differs, a bit random every time I refresh or try again.

Later on the error above didn't show up anymore, instead it just displays a broken site as you can see on www.iteratie.nl and in the image taken from the root logged in as admin. (http://postimg.org/image/btgp07g8j/)

 

As you requested I have added the php info file. (www.iteratie.nl/phpinfodaan.php)

 

I have tried installing DMS from ftp but it had the same result.

 

In the meantime I have created the website for the client on a local host and maybe on friday I will try to upload it via ftp and hopefully that will work, but I think it won't.

 

This is my problem, I hope you can help me out and give me a golden tip so I can get this site up and running on this terribly cheap hosting server. (30 euro per year)

 

edit: because I can't enter the root page properly, I can't enable the pagelines debug mode. Is there an other way?

Share this post


Link to post
Share on other sites
Simon    247
Simon

First thing you need to do is add a page or a post so the site isnt just a big 404 mess.

 

Go to wp-admin => pagelines and click on dms tools tab, click SAVE to regenerate css. Looks like you had the framework installed in the wrong folder initially as it is referencing pagelines folder for fonts etc.

Share this post


Link to post
Share on other sites
dandro    0
dandro

Hi Everyone,

 

I have the exact same issue on the same host,

Running WP 3.6 and the newest version of Pagelines DMS.

I also can't access PageLines debug mode like opwolken

Any help..?

Share this post


Link to post
Share on other sites
opwolken    3
opwolken
Hi dandro. I gave up and switched to yourhosting.nl best and most trustworthy hosting in the Netherlands, though a bit more expensive.

Share this post


Link to post
Share on other sites

  • Similar Content

    • oseehys
      By oseehys+
      Hello There,
      So i want to use platform 5 and DMS sections on a single page, i am using a child theme with pinspro as my main theme and i activated platform 5, the only problem am having so far is the fixed option, my navbars are not aligning to their default size, and it will be great if platform 5 header and footer section will function, has anyone used this option, how can i make the best use of platform 5 and DMS on a site
      Cheers
    • thirdstonemedia
      By thirdstonemedia+
      I've been fighting with a resolution issue ? Want to use Flick Slider, the site looks great on my monitor but client says she can't see bottom of homes. I believe she's on an old PC using outdated browser/s ... but, she's important to me and I'd like to make this work, on her system. Without asking her adjust her own set-up. 
      I put the Flick Slider inside a container, here ::
      http://becauze.xyz/home-five
      Set the Height of Flick Slider to 50 Base ... I don't know how this works exactly ... there is a Base then a Min ... but, haven't adjusted the Min ::
      http://becauze.xyz/home-four/
      Tried using Splash Up, which presents the same issue (she can only see top of home) and she wants several images to rotate on Home page, so not sure this would work anyway ::
      http://becauze.xyz/
      I have tried going into Layout and making the width narrower, and that does make the site narrower, but the homes still don't display in full, on her system. Help ?

      Here are her screen grabs, both desktop and iPad  (dumped the chalkboard background).

      FInally, she said these look great ::
      http://www.sinclairaia.com/
      http://www.kristihanson.com/
      What am I doing wrong ?? Is there a better way to accomplish making the site look great on any resolution at any size ?
      Joanne
      (Longtime Pagelines-lover.)


    • Suneel
      By Suneel+
      I updated my theme to framework and now can't get rid of this bright blue bar that appears across the top of every page. It says, "A fixed bar that makes it easy to promote important content.", and then a button that says, "Get PageLines".
      I am a novice and need help.
      Thank you!
      Natalie
    • kwaoru
      By kwaoru
      Hi,
       
      I have been using DMS and pagelines.
      I am facing to a huge trouble with the appearance of one of my page on mobile (smart phones) built with pagelines.
      However I haven’t come to any solutions to organise either edit the appearance of mobile view to look neat or deactivate the responsive function. 
      Now it looks totally messy on the phone...
       
      1. Is there any way to edit the appearance of the mobile version (responsive theme)?
      2. Is there any way to deactivate responsive function?
       
      If I could receive support from you to go thorough this process I would be happy to be a pro member. 
       
      Looking forward to hearing from you.
    • kwaoru
      By kwaoru
      Hi,
      I desperately need to deactivate the responsive function on mobile for reasons. It looks so messy with the responsive look on mobile and not navigating or informative at all as it is. 
      I searched for solutions online and tries some of those that I found but nothing worked out. Also I found a previous post on this forum says that this theme pagelines DMS is not meant to be build to deactivate the responsive function... 
      Also tried with widget such as WPtouch to edit the mobile look a little more informative but as I am using "single page" theme on pagelines, the frontpage(main page) never appears on those app.
      Seems like not compatible?
      If there is no way to deactivate responsive function or I'll have to recreate another page just dedicated for a mobile page? or change the theme completely and build a page from scratch?
      I have been searching for this for two days already...
      Could anyone wise and kind out there, please help me?
       
      Thanks,
×