Jump to content

Archived

This topic is now archived and is closed to further replies.

richardmichael78

Home Page Does Not Appear In Fixed NavBar

Recommended Posts

richardmichael78    0
richardmichael78

Thanks in advance everyone! I love the product and the support for it has been great! 

My "home" page does not show up in the fixed navbar at the top of the site. I have WP configured to display the "Home" page, and selected another page for the blog posts in WP's settings. Is that the reason why? And if so, is there a way to remedy this? Some of my clients are having a hard time making it back to the home page. The link for home shows up on the footer...but not on the fixed navbar. 

 

Any insight would be deeply appreciated. 

 

Again, thanks! You guys rock! 

 

Share this post


Link to post
Share on other sites
richardmichael78    0
richardmichael78

Oh! Forgot to mention that I'm running the latest version of DMS. I updated it today. ;)

Share this post


Link to post
Share on other sites
Rob    547
Rob

I believe they're aware of this, but I will remind them.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
richardmichael78    0
richardmichael78

Thanks, Rob! I deeply appreciate it!

Share this post


Link to post
Share on other sites
Rob    547
Rob

Just out of curiosity, the menu you selected for the fixed navigation... does it contain a custom link to the home page labeled home or are you just creating this menu on the fly from pages?


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
richardmichael78    0
richardmichael78

Hey, Rob! 

The fixed navbar does not have any custom links. I went with the "stock" navbar that comes with DMS and created the pages in Wordpress. 

 

Again, thanks, my friend! 

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi,

 

You need to create a custom Menu and assign it to the FIxed NavBar, which can be done in the Fixed NavBar options ~ DMS Toolbar > Global Options > NavBar > Configure Menu.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
richardmichael78    0
richardmichael78

Hey, Danny! 

I created another menu from scratch, and your fix worked like a charm! Many thanks, guys! The navbar at the top of the site works great now! 

However, for some reason, when I went to the config page, two "Home" pages were listed. This is before I created the new menu. I noticed this on the site, the navbar at the bottom of the page had two "Home" pages. One "Home" at the left, and one "Home" on the far right. So, I removed the second entry from the default layout--again, this is before I created the new menu--and it vanished from the site's bottom navbar, leaving only one "Home" link, as it should. 

I then created the new menu, and ensured there was only one "Home" page in the list, and updated the settings and refreshed. The top menu is fine, works great, however, now I have two "Home" page links on the bottom of the page's navbar again. And there is only one entry I made in my custom menu for "Home." Help! LOL

Any insight would be deeply appreciated, my friends. Thanks! 

The only other info I can think of is that the bottom navbar had two "home" entries since I installed DMS. IE: the default layout. And I'm currently running the latest version of DMS. I updated the site Friday. Thanks!

Share this post


Link to post
Share on other sites

  • Similar Content

    • Grant Turck
      By Grant Turck+
      Navbar Broken on All Devices When Not Logged Into Wordpress. See screenshots attached from mobile. What is causing this issue and how do I fix? Site is venicepride [dot] org.


    • PierreFF
      By PierreFF+
      Hello, 
      I have an issue with NavPro on mobile when the link of the menue is on the same page. 
      Here is my website: http://foundersofthefuture.co
      The isssue comes from the fact that in my menue most of the items send somewhere else on the same page using anchor link (eg. #container_u788888). 
      This works well on desktop but on mobile, nothing happens when clicking on the link. One of the link of the menue of the homepage "France" sends to another page of the website and this one works well even on mobile. 
      I am using the Pagelines framework theme and also used a wordpress plugin (jQuery Smooth Scroll) for smooth scrolling . 
      Thanks in advance for your help and let me know if I need to provide more information. 
      Best,
      Pierre
    • tristanrodgers
      By tristanrodgers+
      Hi there!
      I'd love to have some social media buttons in my navbar like my online-shop has!
      http://mc1r-magazine.com/
      Can someone explain me how to create them? I tried a lot but don't know how to realize them...
      Greetings from Germany,
      Tristan
    • jeomiland
      By jeomiland+
      Hi guys. Just now trying out Platform 5. I like the reletive simplcity of the new interface but there are things I'm used to in DMS that I'm not seeing yet in 5. Is there a good manual, documentation, video series about some of the basics?
      In particular, I've got a simple navigation menu, created the standard way in WP menus section with several top level parents, then 3-4 children menu items below a couple parent items. Have them moved to the right to create the standard parent-child relationship but all I see on the page is the parent level items - no dropdown!. So I changed themes from Platform5 to the standard 2015 default theme and now I see absolutely no menu at top, except for the mobile (hamburger?) icon.
      In DMS, one had Navi and Navbar, etc sections and each would work differently and give different results. How do you work the menu system in 5? And how get different results ?
      thanks
    • nizami
      By nizami+
      I have a problem at http://kambo.world. Using navbar for the main site navigation. It works fine in normal/desktop mode [first screenshot], using the WP Menu I have specified. But in hamburger mode it seems to do its own thing, picking a few pages at random [second screenshot] A fix for this greatly appreciated! 
       


×