Jump to content

Archived

This topic is now archived and is closed to further replies.

kulmetehan

Template trouble

Recommended Posts

kulmetehan    13
kulmetehan

Hi, it goes as following:

 
 
 
The template I want on my homepage = "A"
The template I want on my product page = "B"
 
Whenever I load A to my homepage, the template automatically also gets loaded  on "http://www.highpowereurope.net/producten/high-power-industrieel/". As mentioned the template for this page should be B. When I go to "http://www.highpowereurope.net/producten/high-power-industrieel/" and upload the B template on to it, it is back to how it was supposed to be. But now template A is loaded to my homepage.
 
I hope you understand my dilemma. It seems like these two pages are clones, whatever I do to one happens to the other. And this is a serious issue for me now. As one is my homepage and the other a product page. Please help.
 
I've tried to find a workaround by creating a new page and using that instead... Still not working, still having the same problem.
 
Please help :(

Share this post


Link to post
Share on other sites
thebastion    20
thebastion

metehankul have you read this?

 

http://forum.pagelines.com/topic/29028-pagelines-dms-documentation-feedback/

 

Note these sections:

  • Configure/Sections Overview: Mention the fact that anything placed within the Header section will show on every page.
  • Configure/Using Templates: Mention that even though these templates are selectable within the Wordpress edit page option "DMS Page Setup" you need to actually change them from the front end Visual Editor whilst you are on the page using the templates options.

The official documentation is here:

http://docs.pagelines.com/configure/using-templates

 

Also make sure you have not placed any of your section items inside the header section because of the "Configure/Sections Overview" note above.

 

Once you are happy with one of the page layouts I would save it as template A. Then move onto the next page and then adjust that page as you want and then save it as template B.

 

Do all of this in the front end Visual Editor.

 

Good luck.

Share this post


Link to post
Share on other sites
kulmetehan    13
kulmetehan

thebastion

 

Thank you for your help but unfortunately this isn't the solution. 

 

It really is a conflict between the two of these pages:

A - http://www.highpowereurope.net/

B - http://www.highpowereurope.net/producten/high-power-industrieel/

 

 

First of all, I always work in the front end visual editor. So unfortunately that also isn't the issue.

 

Whenever I adjust the template of B, A's entire templete gets mixed up with content from all of the pages on my website. I mean literaly all.

 

I just tried again and again the template got mixed up. You can see for yourself on my homepage:

http://www.highpowereurope.net/

 

It's carrying textual content of all my pages. Does it maybe have anything to do with the "Content post loop" section?

 

Page B is now how it should be. But whenever I load the right template to page A, page B gets mixed up. 

 

Please take a look in my account if you need to. I really need this to work. :(

Share this post


Link to post
Share on other sites
thebastion    20
thebastion

metehankul I do not work for Pagelines I'm just trying to help.

 

I did notice that template B is a parent of a page (pageid-28), look at the orange text:

 

A: http://www.highpowereurope.net/

<body class="home page page-id-2 page-template-default dms pl-basic-version responsive full_width editor_navbar_fixed pl-editor display-full">

 

B: http://www.highpowereurope.net/producten/high-power-industrieel/

<body class="page page-id-104 page-child parent-pageid-28 page-template-default dms pl-basic-version responsive full_width editor_navbar_fixed pl-editor display-full">

 

Try this.

Set up a new page in the Wordpress admin area and assign it the "default page" template. Redesign page A into that. Then save it as page A template.

Do the same again but this time redesign page B into it and then save it as page B template.

 

See how that goes.

Share this post


Link to post
Share on other sites
kulmetehan    13
kulmetehan

thebastion

 

Yess, that last bit of advice worked out perfectly. Thank you very much!

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi,

 

I don't actually understand what your issue was, if you create a template, name it and then save it, you can assign this template to whatever page you like. Then if you create another template, do the same thing and assign this template to another page, both pages will be using different templates. Making changes to one of these templates should have no effect on the other (I have done this myself no more than 10 minutes ago and didn't have any issue).

Therefore, are you saying that your issue was due to your page being a child of your homepage or have I misunderstood ?


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
kulmetehan    13
kulmetehan

Danny

 

I'm not exactly sure what the problem was.

 

But the thing is that whenever I adjusted one template, the other got messed up and all of a sudden contained data from all over the website.

 

However, it was probably a page related issue. Maybe because it ineed was a child.

 

I deleted both pages and set them up from 0 as advised above. When I did this all was ok again.

Share this post


Link to post
Share on other sites

  • Similar Content

    • JawDesigns
      By JawDesigns
      Hi everyone,
      Flywheel have reported errors on my clients site 'www.racewaredirect.co.uk' and it's not loading. Can someone please provide some information on how to fix this? The site has never experienced these issues before.
      Thanks,
      James Wilson
    • MissT
      By MissT+
      Hi there,
      I've got an issue with 3 websites built with DMS since I migrated them from http to https that I need help with please.
      When any changes are made - e.g. new posts added or existing posts amended - certain sections of the live site seem to break e.g. image headers hang and don't load (b/g on canvas section), sliders hang and don't load (Revslider), flipper section doesn't load.
      Logging in and then clicking 'Edit the site using DMS' seems to fix the problem. Often if I try to open up another browser window to edit the site / re publish I'm unable to as the page wont load / hangs while trying to load.
      Any ideas how to fix this? On a couple of the sites I've installed a caching plugin as I thought it might be a loading speed issue but it's still happening.
      Website URL's can be provided privately.
      Many thanks in advance.
    • jeomiland
      By jeomiland+
      Hi
      I found this topic
      which talks about a similar issue I am having, but a little different. Hope someone can help me out.
      Best way to see the problem is to view http://cassclayton.com/ on Safari (Mac) compared to Firefox or Chrome. You will see the banner just under the fixed menubar has a gap between the menubar and top of the banner. Looking at Inspector, I found:
      <div class="fixed-top-pusher" style="height: 62px;"></div>
      <script> jQuery('.fixed-top-pusher').height( jQuery('.pl-fixed-top').height() ) </script>
      and indeed it seems the jquery is not always working consistently. For instance, if you simply refresh the page in Safari, it will loose the gap and all looks fine, so is it a browser cache issue that is interacting with the jquery? I do have W3 Total Cache installed. There must be a way to tell the code to make sure jquery is up and running and available to do it's majic?
      And perhaps there is just a better way to do this banner? Originally I tried several DMS sections and used the banner image as background, etc... Kept running into problems with resizing and the left/right parts of the image were getting chopped off. It is important the whole image show, so currently I just use a NextBox section with this code:
      <img src="[pl_site_url]/wp-content/uploads/2015/12/CassClayton-blues-tribute-banner.jpg" width="100%" />
      and it looks the way it should. Is there a better way to place a banner graphic under a fixed navbar and make sure the whole banner graphic displays regardless of screensize?
       
    • oseehys
      By oseehys+
      Hello There,
      So i want to use platform 5 and DMS sections on a single page, i am using a child theme with pinspro as my main theme and i activated platform 5, the only problem am having so far is the fixed option, my navbars are not aligning to their default size, and it will be great if platform 5 header and footer section will function, has anyone used this option, how can i make the best use of platform 5 and DMS on a site
      Cheers
    • kwaoru
      By kwaoru
      Hi,
      I desperately need to deactivate the responsive function on mobile for reasons. It looks so messy with the responsive look on mobile and not navigating or informative at all as it is. 
      I searched for solutions online and tries some of those that I found but nothing worked out. Also I found a previous post on this forum says that this theme pagelines DMS is not meant to be build to deactivate the responsive function... 
      Also tried with widget such as WPtouch to edit the mobile look a little more informative but as I am using "single page" theme on pagelines, the frontpage(main page) never appears on those app.
      Seems like not compatible?
      If there is no way to deactivate responsive function or I'll have to recreate another page just dedicated for a mobile page? or change the theme completely and build a page from scratch?
      I have been searching for this for two days already...
      Could anyone wise and kind out there, please help me?
       
      Thanks,
×