Jump to content

Archived

This topic is now archived and is closed to further replies.

evscicats

NavBar Mobile and Category Links Issue

Recommended Posts

evscicats    14
evscicats

NavBar is working great for me when it displays my website in desktop and tablet resolutions.  Unfortunately, when it goes to mobile phone layout, the category links from my menubar no longer list in the black area that shows to the right when the menu button is engaged.

 

The menu that I have setup has a custom link for Home and the rest of the links are categories for my posts. 

 

Go to http://evscicats.com/evscnewsletter and check it out.

 

* One more thing I noticed, it resorted to using pages from the Wordpress Pages list.  I immediately recognized the page names and so I deleted them since we were not going to use them.  As soon as they were deleted, the links to the pages disappeared from the mobile menu and now the only thing that shows is the little buttons to the social media links I have setup.  The links to the pages never displayed part of the desktop version of the menu.

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

HI,

 

The NavBar mobile menu is controlled by going to DMS Toolbar > Global Options > Layout & Nav, the Primary Navigation Menu & Secondary Navigation Menu options.

 

Wordpress by default, creates a menu based on your pages, if you wish to stop this, you will need to create your own custom menu.

 

http://docs.pagelines.com/tutorials/adding-custom-menus


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
evscicats    14
evscicats

Thanks Danny!  That did the trick.  I guess what is confusing is when I go to the NavBar section itself on the front end and click the little edit button and look at the Section Options (global) settings, I already had the "Main Nav" menu selected there.  It worked fine when it was viewed from the Desktop but the mobile layout wasn't bringing in the menu I had configured with Wordpress.  

 

Is there a way to make the Section Options (global) for the NavBar section and the Layout & Nav settings of the Global Options for the site somehow link together since they are technically both global for the navbar?

 

Thanks - Jerrad

 

[URL=http://s1351.photobucket.com/user/jjgleim/media/navbar-section-options-global_zps641c7010.png.html]navbar-section-options-global_zps641c701[/URL]

 

[URL=http://s1351.photobucket.com/user/jjgleim/media/global-options-layout-and-nav_zpsbda0d9d3.png.html]global-options-layout-and-nav_zpsbda0d9d[/URL]

Share this post


Link to post
Share on other sites
Rob    547
Rob

@evscicats  Did you go to Dashboard > Appearance > Menus and make sure the Main Menu is selected in Two places?  One is Theme Options on the left side.  The other is Theme Options (a tab on the top of the Menu area

 

These will let you select your Main Menu and have it appear in the NavBar.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
evscicats    14
evscicats

I did after Danny helped me.  I just was wondering if it would be possible to make it where the two places for this setup would be linked so we wouldn't have to do that.  I was frustrated by it - didn't know if it was frustrating for any other users.  

 

I'm fine now though.  Thanks!

Share this post


Link to post
Share on other sites
Rob    547
Rob

Glad to hear it!


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

  • Similar Content

    • Grant Turck
      By Grant Turck+
      Navbar Broken on All Devices When Not Logged Into Wordpress. See screenshots attached from mobile. What is causing this issue and how do I fix? Site is venicepride [dot] org.


    • PierreFF
      By PierreFF+
      Hello, 
      I have an issue with NavPro on mobile when the link of the menue is on the same page. 
      Here is my website: http://foundersofthefuture.co
      The isssue comes from the fact that in my menue most of the items send somewhere else on the same page using anchor link (eg. #container_u788888). 
      This works well on desktop but on mobile, nothing happens when clicking on the link. One of the link of the menue of the homepage "France" sends to another page of the website and this one works well even on mobile. 
      I am using the Pagelines framework theme and also used a wordpress plugin (jQuery Smooth Scroll) for smooth scrolling . 
      Thanks in advance for your help and let me know if I need to provide more information. 
      Best,
      Pierre
    • tristanrodgers
      By tristanrodgers+
      Hi there!
      I'd love to have some social media buttons in my navbar like my online-shop has!
      http://mc1r-magazine.com/
      Can someone explain me how to create them? I tried a lot but don't know how to realize them...
      Greetings from Germany,
      Tristan
    • jeomiland
      By jeomiland+
      Hi guys. Just now trying out Platform 5. I like the reletive simplcity of the new interface but there are things I'm used to in DMS that I'm not seeing yet in 5. Is there a good manual, documentation, video series about some of the basics?
      In particular, I've got a simple navigation menu, created the standard way in WP menus section with several top level parents, then 3-4 children menu items below a couple parent items. Have them moved to the right to create the standard parent-child relationship but all I see on the page is the parent level items - no dropdown!. So I changed themes from Platform5 to the standard 2015 default theme and now I see absolutely no menu at top, except for the mobile (hamburger?) icon.
      In DMS, one had Navi and Navbar, etc sections and each would work differently and give different results. How do you work the menu system in 5? And how get different results ?
      thanks
    • nizami
      By nizami+
      I have a problem at http://kambo.world. Using navbar for the main site navigation. It works fine in normal/desktop mode [first screenshot], using the WP Menu I have specified. But in hamburger mode it seems to do its own thing, picking a few pages at random [second screenshot] A fix for this greatly appreciated! 
       


×