Jump to content

Archived

This topic is now archived and is closed to further replies.

nfp1900

DMS losing content and formatting

Recommended Posts

nfp1900

I've been working with DMS just after the launch so I've had some time to get used to the methods. But I'm finding that it's reformatting pages and losing content after editing without any warning. I can also be in the visual editor and publish a page but what's actually published isn't what I'm seeing - the page has defaulted to a 12/12 column and the sidebar has jumped to the bottom of the page.

 

I did ask if there were 'rules' about how to build the pages - e.g. what you can and can't do with columns to format the pages, if you could nest the columns, what doesn't work... Whilst the way of working is very flexible it seems very simple to bang out a site that has full width sections with different colours and backgrounds but less stable when it comes to using sidebars and columns to construct a page. 

 

Anyone else suffering?

 

PS I have just tried this again..and again and regardless of how the content is reformatted in the editor and then published the view in the browser is totally different. 

Share this post


Link to post
Share on other sites
Danny

Hi,

 

The thing I can think of is that you're not creating different templates and therefore, are just editing the same template, for different pages. To be on the safe side, create different templates that have different layouts.

 

If after trying this, you're still experiencing the same error, reply here and let us know and we can take a look.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
nfp1900

Hi

 

I'm just working on the homepage and have attached the issue[attachment=1329:site_format.jpg]

 

As I understand it, I have to first create the content I want then save it as a template. 

 

The fact that you can't tell which template is loaded against which page is being addressed from what I can see. 

Share this post


Link to post
Share on other sites
micstepl

Hi to all of you,

 

This seems to be connected to the confusion on how templates work and what they really do and maybe issues.

 

Look at the open questions I have posted at ... 

http://forum.pagelines.com/topic/28950-template-documentation-seem-incomplete/?hl=template

 

      .... maybe there will be answer soon.

 

br

,Michael

Share this post


Link to post
Share on other sites
nfp1900

Considering the template system is fundamental to the operation of DMS and building a site I think it's pretty crucial to know when this information is going to be available. 

 

Sure I can build a one page site with a few sections dropped in that scrolls forever. But nothing addresses building a site with sidebars and what the correct  approach should be with DMS. It's likely that certain approaches simply don't work and you can't actually drop in, for example,  three column sections where you want.

 

The concept of web templates isn't new but these seem more akin to stylesheets that are applied rather than templates which usually have restrictions on what can and can't be edited once they are created.  

 

In the meantime, any answers are good right now...

Share this post


Link to post
Share on other sites
nfp1900

I've  found that adding  CSS to a column class is causing the weird wraps and content to reflow - even a 1px border is causing this.  

Share this post


Link to post
Share on other sites
nfp1900

Not sure if this is classed as a bug but creating a class for a column and applying a background colour is fine. Adding a border causes the column to jump to the next row. Although you can't see this in the visual editor you can on live preview. 

Share this post


Link to post
Share on other sites
scientistsofmedia

I too am struggling with changes being saved within the visual editor.  I am finding simple global option changes as editing colors, selecting the nav bar types and fonts do not save.  I have to click the preview button numerous times before the changes stick and can publish.

 

I assume I am doing something wrong.  is anyone else experienceing this?

Share this post


Link to post
Share on other sites
nfp1900

After you enter your text, code or whatever to the section click outside of the box. You'll see the save icon spin next to the publish button. Then refresh to see the changes and then publish. Things like drop menus are saved on the fly, other entry fields seem to need that click...

 

The publish tick should ideally be red when there are unpublished changes and blue when it's ok. Or have a * like photoshop or some other indicator. 

Share this post


Link to post
Share on other sites
Rob

@nfp1900  That indicator idea is a very good one. Did you add it to the Ideas and Feedback section separately?


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
nfp1900

nope, where can I do that?

 

And Rob can you pls try this out, shouldn't take 2 secs, I posted it above as the reason for the reflow:

 

Not sure if this is classed as a bug but creating a class for a column and applying a background colour is fine. Adding a border causes the column to jump to the next row. Although you can't see this in the visual editor you can on live preview. 

Share this post


Link to post
Share on other sites
Rob

Nick, where are you adding the actual CSS? In Custom Code or in the class field? 

 

What CSS did you add, so I can test it.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
scientistsofmedia

I've tried this: "After you enter your text, code or whatever to the section click outside of the box." and I see the auto save spin happening, but then hit refresh and changes disappear.

Share this post


Link to post
Share on other sites
nfp1900

I create the class for the column element, say 'column-home'  in the edit options then in custom code use .column-home to define the CSS

Share this post


Link to post
Share on other sites
Rob

That's correct. As long as the .column-home css instructions are in Custom Code, all should work properly.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
nfp1900

If I add the following custom classes to my my code (they are column classes 6/12 - 6/12 layout)

 

.diamond, .events-column {
background-color: orange;
  border-radius: 3px;
}
 
It's fine, I get a nice orange box with a radius. But if I want to add border to my box and include:
 
.diamond, .events-column {
background-color: orange;
  border-radius: 3px;
  border-style:solid;
border-width:2px;
}

 

The boxes look ok in the visual editor but when you preview the site the columns reflow and jump all over the place. 

Share this post


Link to post
Share on other sites
nfp1900

Did anyone try the code above to see if it's a bug? 

Share this post


Link to post
Share on other sites

×