Jump to content


This topic is now archived and is closed to further replies.


Sections bug/corrupt when page reloads

Recommended Posts


Hi, I was editing earlier today and when i refreshed the home page (in editor mode) all 'sections' on all pages disappeared, when i tried to add them again they either kept disappearing (did not save after refresh) or when they did save, they seem to be corrupt/buggy.

See image below, which displays two different sections that seem corrupt after i refresh the browser window.







I have not added any new plugins recently.





EDIT: So I think it is to do with the editor, because it shows fine on the front end.

Share this post

Link to post
Share on other sites

I've had something similar recently and was trying to pin down the cause - in this case the header/footer was fine but any sections in the content area first reformatted on the page (one of the columns jumped from 8/12 to 12/12 pushing content underneath)  then went altogether when I published. I did activate/deactivate a plugin but something's up...

Share this post

Link to post
Share on other sites

Yes, everything in the header and footer sections are fine, but when I add sections to the 'template' area and refresh the editor they scramble and if I refresh the editor again they disappear/delete and I have to start again.


The only solution I can find is to add all the content in one hit, then hit publish, (but not refresh in the editor mode) then view the page out of the editor (logged out like a normal user/viewer of the site.)



It is a major bug, I hope it get fixed soon.

Share this post

Link to post
Share on other sites

I'm having the same issue with sections re-sizing and disappearing

Share this post

Link to post
Share on other sites

This isn't a bug.  However, respectfully, it's the result of failure to read the docs and understand the product.


"(did not save after refresh)"  --- You're supposed to save (Publish) first, and then refresh.  If you refresh first, the work you've done is overwritten.   This is no different in a WordPress post or page edit screen, so why are so many people having issues with this in DMS?


If you're in any edit screen and you've written something and refresh your screen, those changes will be gone, forcing you to do it again.  Doesn't it make sense that the same fundamental computing praecept will be the norm in DMS?  Every word processor, graphics editor, CAD program, I've used in computing since 1975 (yes, before the PC and Apple IIe), had the same basic rule of thumb.  Don't refresh till you save.

Former PageLines Moderator, Food Expert and Raconteur

Share this post

Link to post
Share on other sites

  • Similar Content

    • Valentina
      By Valentina+
      When putting a background color in some section and go to save, pageline like that it stays locked and does not allow you to save the changes made and sends an error to the console.
      (Uncaught Error: cannot call methods on iris prior to initialization; attempted to call
      method ''toggle).

    • Moti
      By Moti+
      How do I hide the dates from the post thumbs in the Onepage template BlogModule?

    • Kedark
      By Kedark+
      Hello. I have a big problem, platform 5, the save changes button does not work. All the time, "spins" and can not save modifications. There was information about the account refresh or re-login (due to the token), everything has been done, still saving does not work properly. Help.
      I got an answer on facebook that you have to put the site from scratch, I have a dozen or so - it's some tragedy. So ask for help !!!
      Regards, Kedark
    • MiraAdmin
      By MiraAdmin+
      Looking for some help on a recently developed issue. Editor will not load. 
      Theme:  DMS2
      Error from:  Chrome - Inspector - console view
      Error message: Refused to execute script from 'http://xxxx.xxx/wp-content/themes/dms/dms/editor/js/gettext.js/?ver=4.9.7' because its MIME type ('text/html') is not executable, and strict MIME type checking is enabled.
      Occurs on all sites on same server. 
      WP versions to 4.9.5, 4.9.6, 4.9.7 = same behavior. Worked properly on these same versions until 07/04/2018.
      No new plugins. Isolating plugins offers same behavior. 
      Server vendor reports no changes, patches, etc. 
      Server re-starts no impact.  

      Thank you. 
    • sakkthi subramaniyam
      By sakkthi subramaniyam
      Working on a very old site which has  pagelines framework theme. I need section plugin. so i can install postpins section. I have lost backup copy.
      Thank you.