Jump to content

Archived

This topic is now archived and is closed to further replies.

rambman

DMS stylesheet missing

Recommended Posts

rambman    0
rambman

Hello, I just installed the latest version of Wordpress 3.6. and version 2.4.4. of the Pagelines framework just before I tried to install the free DMS to have a look on before purchase. My problem is that either way I tried to install DMS I get an error saying something like "broken theme. stylesheet is missing. themes need to have a stylesheet and a template installed". On my screen it looks this way:

 

Beschädigte Themes

Die folgenden Themes sind installiert, aber nicht vollständig. Themes müssen ein Stylesheet und ein Template haben.

Name Beschreibung dms Es fehlt ein Stylesheet.

 

Waht is the problem and how can I solve it? couldn't find a similar post.

 

Thanks in advance for your replies.

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Hi,

 

Where did you download DMS from and how are you installing it ?

 

Can you also provide a screenshot of your issue, if you have your Dashboard set to German, can you disable this and put back to English if possible please, just to make it easier for us.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
rambman    0
rambman

Hi Danny and thanks for your reply.

 

I downloaded DMS directly from pagelines.com (Get DMS now. It´s free!) and extracted the .zip-file. I then uploaded the DMS folder to my server and got this message in themes of my Wordpress dashboard:

 

http://screencast.com/t/Sop74u6f8

 

Same happened when I was installing it through Wordpress using the .zip-file.

Share this post


Link to post
Share on other sites
Rob    547
Rob

Okay,  unzipped, the DMS.zip file will let you save a dms folder to your desktop.

 

FTP into the site, then navigate to wp-content/themes and if you find a dms folder there, delete it

 

Once its finished, upload the dms folder from your desktop to wp-content/themes.  When it's finished, you should have wp-content/themes/dms

 

Browse to Dashboard > Appearance > Themes.  Activate DMS.  It should be there awaiting activation.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
rambman    0
rambman

Hi Rob,

 

All that´s what I´ve done. I uploaded the DMS folder that I got from the zip file via FTP and got the information in my screenshot. Then deleted the folder and tried installation using the zip flie via dashboard > appearance > themes. Same happened. I tried it several times.

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

Can you take a screenshot of your FTP client, showing us your dms folder please.

As I am unable to recreate your issue.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

The style.css file is there? Not sure what the issue is, maybe an issue with your installation. I would recommend installing DMS again. If the issue persists, download a free copy from PageLines.com and try again.

 

Also can you take a screenshot of your themes directory please.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
danieldynasty    2
danieldynasty

Hello,

 

I had the same problem. I solved it on my own. It's a temporary fix since I don't know what will happen if I were to update DMS etc..

Here was my email to DMS Support:
 

I did some troubleshooting on my own. It seems the problem is solved by adding the line below to Custom Scripts (header html):

<link rel='stylesheet' id='pagelines-draft-css'  href='http://example.com/hello-world?pagedraft=1' type='text/css' media='all' />
 
But that does not work for some reason, Chrome displays the CSS code but Firefox displays the Hello World page. So I copied the CSS code from Chrome and created a new .css file called "hello-world.css" and uploaded that to my webserver. Then I linked to it instead of /hello-world?pagedraft=1, resulting in the code below that solves the problem.
<link rel='stylesheet' id='pagelines-draft-css'  href='http://example.com/hello-world.css' type='text/css' media='all' />

I still don't know why the problem exists, but I found a workaround temporary solution. Please advise on how to solve this problem correctly.

 

 

Hope this works for you as it did for me. DMS was useless until I found this fix..

Share this post


Link to post
Share on other sites
rambman    0
rambman

Hello everybody,

 

taking the screenshot of my themes folder I stepped on the problem. I uploaded the DMS folder as root not as the user of the website. So now I deleted the folder as root and logged in as user to upload the DMS file again. Now the "DMS theme" appears in my dashboard. Issue solved. Thanks a lot guys.

Share this post


Link to post
Share on other sites

  • Similar Content

    • JawDesigns
      By JawDesigns
      Hi everyone,
      Flywheel have reported errors on my clients site 'www.racewaredirect.co.uk' and it's not loading. Can someone please provide some information on how to fix this? The site has never experienced these issues before.
      Thanks,
      James Wilson
    • MissT
      By MissT+
      Hi there,
      I've got an issue with 3 websites built with DMS since I migrated them from http to https that I need help with please.
      When any changes are made - e.g. new posts added or existing posts amended - certain sections of the live site seem to break e.g. image headers hang and don't load (b/g on canvas section), sliders hang and don't load (Revslider), flipper section doesn't load.
      Logging in and then clicking 'Edit the site using DMS' seems to fix the problem. Often if I try to open up another browser window to edit the site / re publish I'm unable to as the page wont load / hangs while trying to load.
      Any ideas how to fix this? On a couple of the sites I've installed a caching plugin as I thought it might be a loading speed issue but it's still happening.
      Website URL's can be provided privately.
      Many thanks in advance.
    • jeomiland
      By jeomiland+
      Hi
      I found this topic
      which talks about a similar issue I am having, but a little different. Hope someone can help me out.
      Best way to see the problem is to view http://cassclayton.com/ on Safari (Mac) compared to Firefox or Chrome. You will see the banner just under the fixed menubar has a gap between the menubar and top of the banner. Looking at Inspector, I found:
      <div class="fixed-top-pusher" style="height: 62px;"></div>
      <script> jQuery('.fixed-top-pusher').height( jQuery('.pl-fixed-top').height() ) </script>
      and indeed it seems the jquery is not always working consistently. For instance, if you simply refresh the page in Safari, it will loose the gap and all looks fine, so is it a browser cache issue that is interacting with the jquery? I do have W3 Total Cache installed. There must be a way to tell the code to make sure jquery is up and running and available to do it's majic?
      And perhaps there is just a better way to do this banner? Originally I tried several DMS sections and used the banner image as background, etc... Kept running into problems with resizing and the left/right parts of the image were getting chopped off. It is important the whole image show, so currently I just use a NextBox section with this code:
      <img src="[pl_site_url]/wp-content/uploads/2015/12/CassClayton-blues-tribute-banner.jpg" width="100%" />
      and it looks the way it should. Is there a better way to place a banner graphic under a fixed navbar and make sure the whole banner graphic displays regardless of screensize?
       
    • oseehys
      By oseehys+
      Hello There,
      So i want to use platform 5 and DMS sections on a single page, i am using a child theme with pinspro as my main theme and i activated platform 5, the only problem am having so far is the fixed option, my navbars are not aligning to their default size, and it will be great if platform 5 header and footer section will function, has anyone used this option, how can i make the best use of platform 5 and DMS on a site
      Cheers
    • kwaoru
      By kwaoru
      Hi,
      I desperately need to deactivate the responsive function on mobile for reasons. It looks so messy with the responsive look on mobile and not navigating or informative at all as it is. 
      I searched for solutions online and tries some of those that I found but nothing worked out. Also I found a previous post on this forum says that this theme pagelines DMS is not meant to be build to deactivate the responsive function... 
      Also tried with widget such as WPtouch to edit the mobile look a little more informative but as I am using "single page" theme on pagelines, the frontpage(main page) never appears on those app.
      Seems like not compatible?
      If there is no way to deactivate responsive function or I'll have to recreate another page just dedicated for a mobile page? or change the theme completely and build a page from scratch?
      I have been searching for this for two days already...
      Could anyone wise and kind out there, please help me?
       
      Thanks,
×