Jump to content
Sign in to follow this  
JawDesigns

NavBar Classic Drop Down Menu on Mobile Phones

Recommended Posts

JawDesigns

Hi,

 

I was looking at my website today on my Galaxy S2 Andriod phone and I am unable to select pages from the drop down menus using NavBar Classic. I'm not sure how I'll get this to work (though I am sure there is obviously a way). Does anyone have a method of achieving this?

 

I am also using Woocommerce so I am able to select the 'Shop' tab but I am unable to select catergories below (Parts, Wheels etc).

 

Any advice would certainly be appreciated.

 

I'm using the following:

 

WP 3.6

Theme: Base Theme Version 1.0.2

 

Cheers, James


James Wilson

Designer & Photographer

 

Share this post


Link to post
Share on other sites
Danny

Hi,

 

I don't have access to a Droid phone but I can you provide a link to your site and I will speak to one of my colleagues who has.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
JawDesigns

Thanks Danny,

 

Not sure if it's an Android thing as I've not checked my website on another touch screen device yet. I'll provide a link but I will need to take it off-line soon as it's currently work in progress.

 

The multiple pages is under the menu item called 'Shop'

 

Cheers, James

 

Link: http://www.racewaredirect.com/


James Wilson

Designer & Photographer

 

Share this post


Link to post
Share on other sites
Danny

Ive tried on iPhone, no issue there and I have also tried Android on Screenfly and it also worked there, can you record your issue and then provide us with a link please.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
JawDesigns

That's weird but good I guess. Just to double check are you able to select the category 'GARMIN MOUNTS' under 'Shop' using a Phones touch screen. This is the page that I am unable to select.

 

Thanks aagain Danny!


James Wilson

Designer & Photographer

 

Share this post


Link to post
Share on other sites
Danny

Hi,

 

Not sure what is going on now, Im getting a splash screen saying to visit .co.uk instead and this site isn't using PageLines.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
JawDesigns

Sorry Danny, I disabled the site as I was leaving the computer for a while. If you could please take another look now to see if you can select STORE > GARMIN MOUNTS easily through using a touch screen interface that would be great. Everything is live now.

 

Cheers, James


James Wilson

Designer & Photographer

 

Share this post


Link to post
Share on other sites
Danny

OK, I have check on iPhone again and no issues whatsoever. My colleague has check on FF on his Android device and he has no issues either. Can you tell us what browser you're using on your device and also what version of droid please.

 

As, I have come to the conclusion that your issue may be related to your styling of your menu. To check, disable your custom CSS for your navigation and so that you're back to the default styling. Now try your navigation again on your device.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites
JawDesigns

Thanks for checking for me!

 

I'm using an app that was pre-installed on the phone called: web'n'walk (version 4.0.4-BVLPH). I just downloaded a Firefox browser and it seems better but I have been doing all of my CSS in Firefox sofar. However, even in Firefox I have the same problem because clicking on 'SHOP' selects the 'SHOP' page and I have to immediately try and click 'GARMIN MOUNTS' to select another page before the 'SHOP' page loads if that makes any sence?

 

Maybe a single press could open up the children pages and then a second press could confirm which page you want to select (maybe...) as this would give me more time to select a page before the 'SHOP' page loads. I will need to add many more pages soon (for product catergories) so I'll be able to spend more time looking into how this all works.

 

I also disabled all CSS and it's still the same behaviour and therefore difficult to quickly select a child page.

 

Thanks, James


James Wilson

Designer & Photographer

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×