Jump to content

Archived

This topic is now archived and is closed to further replies.

klouis

Classic Navi, right justified navigation, inactive background color

Recommended Posts

klouis    0
klouis

Hello,

1. How do I get the my side navigation to be right justified,  currently it is centered?  I'm using classic navi.   http://www.sclouis.com/about-us/

2. Also, I would like for the active grey background color to be inactive and font to be active instead.

I'm using PageLines Framework.

Thanks,
SC Louis

Share this post


Link to post
Share on other sites
Rob    547
Rob

Hi,

 

When you created the menu, did you name it in Appearance > Menus? If you did, that's perfect.

 

Go to Appearance > Menus and click "Screen Options" on the top right. You'll see a panel open and one of the options is Custom Classes.  Check that option, then click Screen Options again to close the panel.

 

Add or edit a menu item.  You'll see a new field for Custom Class.  Add the name of your new class.  For demo purposes, we'll call it sidemenu1.

 

Now, you'll craft some CSS.

 

.sidemenu1 {background: none;

text-align: left;

color: red;

}

 

You can customize the CSS as desired as the example above is only for demonstration. If you need guidance with the CSS options, check http://www.w3schools.com/css/

 

It's possible to also do it with an a (for a href) so that when someone clicks, the font can change. Examples of this kind of code are available at the link above.

 

I hope this helps. 


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
klouis    0
klouis

It works perfectly. 

 

How do I make "About Us" the ACTIVE/ON button on the page?  I need the consumer to know what page they are on.  Each button needs to ACTIVE/ON  for each page that is related to the page?  

 

Ex.:  http://www.celine.com/en/collection/winter/ready-to-wear/look-book/  

Please notice that "WINTER 2013 READY TO WEAR" button is ACTIVE/ON.

Share this post


Link to post
Share on other sites

  • Similar Content

    • decmech
      By decmech+
      Hey Guys,
      Having some issues with the dropdowns for the Navi in DMS. For some reason I can't have any more than 2 levels in the dropdown. The cursor is hovering over RPAS Training (and the arrow to indicate more is visible) but no matter what browsers, it never shows up. Also inspecting the HTML shows that the additional fields are not there.
      I have inspected the PHP and cannot see anything that is limiting the number of levels. Any assistance to get the additional levels showing would be great.

    • jeomiland
      By jeomiland+
      Hi guys. Just now trying out Platform 5. I like the reletive simplcity of the new interface but there are things I'm used to in DMS that I'm not seeing yet in 5. Is there a good manual, documentation, video series about some of the basics?
      In particular, I've got a simple navigation menu, created the standard way in WP menus section with several top level parents, then 3-4 children menu items below a couple parent items. Have them moved to the right to create the standard parent-child relationship but all I see on the page is the parent level items - no dropdown!. So I changed themes from Platform5 to the standard 2015 default theme and now I see absolutely no menu at top, except for the mobile (hamburger?) icon.
      In DMS, one had Navi and Navbar, etc sections and each would work differently and give different results. How do you work the menu system in 5? And how get different results ?
      thanks
    • Kedark
      By Kedark+
      Hi,
      how to set the menu navi:
      - The background color when you expand a submenu,
      - Background color on mouseover,
      - The color of the text,
      - Width of submenu
      Please help, nowhere in the forum I have not found the answers to these questions ..
      Regards
      RKA
       
    • triggerfish
      By triggerfish+
       I have setup the Navi (content width) to show the burger icon for my menu system (desk and mobile).
      It works great..displays only the Burger..BUT ONLY when on the Default Menu (which is not a real menu, but some random selection of pages).
      As soon as I select the MAIN Menu in the Navi settings it suddenly displays all of the menu items...which I don't want.
      The domain is not pointed yet..it is at 162.219.161.131
      If you know how to trick your computer the website is here... http://phw-homes.com/home-dms-2


    • balfred1345
      By balfred1345
      null When I tested Search using the search field in Navi, it throws the error as shown in pastebin: http://pastebin.com/DJ079bmy
      Is there a fix for this? If there is no fix, can you please tell me how to disable search in Navi?
      Thanks,
      Bruce
×