Jump to content
Sign in to follow this  
asialove

Invalid argument supplied for foreach() admin_functions.php error

Recommended Posts

asialove

Dear all, i just bought the latest IblogPro wordpress theme, Ver. Version 4.0.0, when i try to congig the theme option, post and page option, it comes to error message like this:

Warning: Invalid argument supplied for foreach() in /home/lgephone/public_html/lg-cosmos.com/wp-content/themes/iblogpro/core/admin/admin_functions.php on line 312
someone here suggest to turn off the php.ini "magic_quotes_gpc" i tried and re-start the server, it still not solve the problems I am hosting on godaddy vps, and here i paste the php.ini for your reference thanks:

Share this post


Link to post
Share on other sites
cmunns

I removed the file to un clutter the thread. You should start by resetting everything to default in you theme options. (blue button on the bottom) Usually this fixes any errors that may appear in the admin after install.

Share this post


Link to post
Share on other sites
asialove

The theme works fine on other server. reset the default in theme option does not solve the problems I change the php "iblogpro/core/admin/admin_functions.php on line 312 foreach( foreach((array) now no error message appears..

Share this post


Link to post
Share on other sites
bryan-hadaway

Okay, you'll need to hold tight for continued support tomorrow. Bump your topic please. Thanks, Bryan

Share this post


Link to post
Share on other sites
asialove

Thanks Bryan, I still need someone to help me Your themes works on hostmonster.com server fine, local server fine, Can any one help to check my godaddy server settings?

Share this post


Link to post
Share on other sites
cmunns

You need to get them to upgrade your php to PHP5, otherwise you may have to switch hosting providers.

Share this post


Link to post
Share on other sites
asialove

yes, it is php5??‚??‚dear cmunns

Share this post


Link to post
Share on other sites
Andrew

Hi Zhang, We've seen this issue before and yes it was related to server side issues. Are you on version 4.2.4? Andrew

Share this post


Link to post
Share on other sites
asialove

dear arpowers, yes, it is iblogpro 4.2.4, it is server side errors, I need to check again my php.ini settings..thanks anyway

Share this post


Link to post
Share on other sites
asialove

hello, is there anyone has similiar errors, , i know someone tunr on the magic_quote in php.ini, that works, but mine does not..

Share this post


Link to post
Share on other sites
cmunns

Did the host with this server give you any errors. It's really hard for us to know where the problem is coming from when it works somewhere but not elsewhere. An error log or more info would help. I know you posted something in the beginning but something concise is preferrable. Do they have anything to say?

Share this post


Link to post
Share on other sites
asialove

hello cmunns, thanks for your reply! I notice error "Warning: Invalid argument supplied for foreach()" means "empty array"? only the radio check box option part gets errors. like Post Thumbnail Placement Post Excerpt Placement Full Post Content Placement and etc my server is apach + mysql 5.1.XX + php5.1

Share this post


Link to post
Share on other sites
Andrew

Actually Zhang, it says you are version 4.0.0 of iBlogPro? I believe we've since updated to fix this specific problem.. Have you checked your launchpad account?

Share this post


Link to post
Share on other sites
asialove

Hello arpowers, i am hosting on godady vps. checking the server settings, anyway,, now i am just update the database table page-Line_option manually. only options that need to check with radio box have problems, so i guess something error with that ,when trying to config the option, radio data from database can not be read, so it is emty array,

Share this post


Link to post
Share on other sites
asialove

launch pad account? I just bought the iblogpro , the latest ver

Share this post


Link to post
Share on other sites
asialove

iBlogPro 4.2.4 by PageLines iBlogPro is a professional WordPress theme built on the PageLines CMS framework. Designed and developed by PageLines. Activate | Preview | Delete

Share this post


Link to post
Share on other sites
bryan-hadaway

Your Launchpad account login is here: http://www.pagelines.com/launchpad/member.php You can always check to see if you have the latest and greatest theme version. That's funny you mention GoDaddy and Hostmonster. I've actually written an article about how Hostmonster is the best and GoDaddy is the worst of popular hosts. As a designer in the past 5 years I have had many problems with GoDaddy. If you are running Hostmonster for another site and you're having so many problems with GoDaddy... at this point my recommendation would be to move everything over to Hostmonster and start fresh. Thanks, Bryan

Share this post


Link to post
Share on other sites
asialove

Thanks Bryan, The problems solved, The godaddy vps server default php.ini set the arg_separator.input as ",& ", it is this "," problems, now it is ok. forgive me for the silly questions as above, thanks anyway, wish this may helps those who are using godaddy server, thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×