Jump to content
Sign in to follow this  
andulka

Carousel photos from posts not showing

Recommended Posts

andulka

I'm apparently having a bad computer day/week/month... Now the problem is the carousel page, which isn't working for me. The theme is Station Pro and I'm trying to add a carousel page using the 'links from posts' option. When I try this on a test blog with similar settings, it's working, but not on the actual blog. As far as I can see, I'm not doing anything differently. Created a few test posts with some content and a feature photo, then a new carousel page and selected the posts setting. All I get is a blank black field on top of the page with the scroll buttons at both ends, but there isn't even the empty image spaces that would normally appear in place of photos that doesn't exist. Any ideas? (Can't provide a sample page as obviously I'm not having a page like that online and I was mainly testing anyway). The site itself is here.

Share this post


Link to post
Share on other sites
bryan-hadaway

I could be wrong, but links from posts might just make it so that the carousel links to the different posts you have. You may actually still need to set the photos in the carousel. Thanks, Bryan

Share this post


Link to post
Share on other sites
andulka

It does work in a test blog with the same settings though. Posts without any feature photo show as empty boxes in the carousel, but in the actual blog all I get is just the blank bar. Would adding the photos need to be done using Flickr then?

Share this post


Link to post
Share on other sites
cmunns

Make sure you have a minimum of 8 images for the carousel so in this case 8 posts. Also, have you changed code? Because the carousel page template wouldn't be used with the blog page unless you've modified something, or you'd need to to get it working. in template_posts.php you would need this ` if(is_page_template('page-carousel.php') || is_page_template('page-carousel-full.php')) $carousel_page = true; else $carousel_page = false; ` to be this ` if(is_page_template('page-carousel.php') || is_page_template('page-carousel-full.php') || is_home()) $carousel_page = true; else $carousel_page = false; `

Share this post


Link to post
Share on other sites
andulka

OK, thanks, I'll see how it goes. I was actually testing on a normal page with the carousel template, but to be able to use it on a blog page might be requested as well. Although I have several, the news is the default blog page and then there are three others, which are categories I've added to the dropdown under Blog menu. If I were to use it on a blog page, it would be one of those.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×