Jump to content

Archived

This topic is now archived and is closed to further replies.

jweinberger

Dropdown menus don't function per HTML standards - can't click on top item

Recommended Posts

jweinberger    0
jweinberger

According to one pagelines person, this is resolved, but I believe this is not. The topic to which I refer is here: http://forum.pagelines.com/topic/22239-top-menu-links-to-pages-dont-function/

 

The ability to click on the top (anchor) item in the dropdown menu is a requirement (not optional for any theme). Many many sites do it this way (nearly every site I visit, and that includes many pagelines sites).

 

I require this, so I am posting in the hope that someone has a way to make pagelines perform like this.

 

I do not code, and do not add any custom code to my site, so a solution that does not rely on custom code would be much appreciated.

 

Any advice, direction, examples or solutions are very much appreciated.

Share this post


Link to post
Share on other sites
batman    389
batman

Hi

You can use the "Nav Classic"

Please go to

Pagelines > Drag & Drop > Template Setup 

Click in Header

And you can see it in

Available / Disabled Sections


Life is too short to remove USB safely ...

Share this post


Link to post
Share on other sites
jweinberger    0
jweinberger

First - thank you! THat helped, and got me halfway there.

 

It did make the top/anchor item in the navbar clickable. Which actually answered my question.

 

But it caused a problem - the style choice (also critically important) no longer seems to apply. I had a black navbar. now the background is white. I need the black back.

 

Again, I don't used custom coding, only settings, so if there is a way to do this, please let me know.

 

Thank you!!

Share this post


Link to post
Share on other sites
batman    389
batman

Hi Jweinberg

 

You can try add in

PageLines > Site Options > Custom Code > CSS Rules

 

Please, take a look to this

http://forum.pagelines.com/topic/22532-changing-color-of-navbar/?hl=drop+down

 

If you need more CSS help, make sure you've downloaded Firebug for Firefox

and check out W3 Schools for more info. 

http://www.w3schools.com/


Life is too short to remove USB safely ...

Share this post


Link to post
Share on other sites
jweinberger    0
jweinberger

Thanks again!

 

This didn't work. I think that specific style is for the NavBar, not the "Nav Classic".

 

I tried looking for the style in Firebug (and a few other tools, but despite finding what I think it is, changing it doesn't seem to work. My best guess is that the style that need amending is ".navigation_wrap" but adding the code in that post fails to change anything and even adding

.navigation_wrap {
background: #000;
}

doesn't change it at all.

 

I am at a loss, so I'd appreciate any help. But Thank you very much for your help so far!

Share this post


Link to post
Share on other sites
batman    389
batman

Hi again

 

Please, you can post your site's url so if I can try properly troubleshoot the issue for you.

;)


Life is too short to remove USB safely ...

Share this post


Link to post
Share on other sites
jweinberger    0
jweinberger

Wow - sorry! I thought I did: http://stage.dsthree.com

 

I did some playing around with the CSS as firebug and its Chrome equivalent reported it. I got the menu to color as I wanted (I had to force the first menu item, and I'm pretty sure I did something dangerous....). So it's now my color green.

 

I **think** it's fine now, but I'd like to find a simpler solution and make sure that I haven't done anything really dangerous or bad....

 

Here's the custom CSS I have right now:


 .navbar.pl-color-black-trans {
  background-color: #658d1b;
  background-image: none;
  background-repeat: repeat-x;
  border-top: none;
}
.navbar .searchform .searchfield {
  background-color: #658d1b;
  border: none;
  box-shadow: 0px 1px 2px rgba(0,0,0,0.1) inset, 0px 1px 0px #658d1b;
}
.dropdown-menu li > a:hover,
.dropdown-menu li > a:focus,
.dropdown-submenu:hover > a,
.dropdown-menu li.current-menu-item > a {
  background-color: #658d1b;
  background-image: none;
  background-repeat: repeat-x;
} 
.main_nav_container,
.main_nav_container > a,
.main_nav_container > a:hover,
.main_nav_container > a:focus,
.main_nav_container > ul {
width: 100%;
float: left;
margin-right: -230px;
background-color: #658d1b;
}

.main-nav li a:hover, .main-nav li.current_page_item > a, .main-nav li.current-page-ancestor > a {
background-color: #658d1b;
}

.main-nav.sf-menu li li a {
background-color: #658d1b;
text-align: left;
}

Thank you for any help or advice you can offer!

Share this post


Link to post
Share on other sites
Banga    0
Banga

Hi

You can use the "Nav Classic"

Please go to

Pagelines > Drag & Drop > Template Setup 

Click in Header

And you can see it in

Available / Disabled Sections

Hi Batman,

Turns out I'm a real dummy.  I can't figure out how to get to "Template Setup".  I have only just started using wordpress and pagelines (yesterday) so everything is new to me.  Also have no coding background to speak of so excuse my blindness.

 

I've got the same problem.  I want to be able to click through my top item in the drop down menu.  Doesn't seem to want to let me.

Share this post


Link to post
Share on other sites
Rob    547
Rob

Banga, the best place to start is never in the middle, but always at the beginning.  In this case, reading the docs at http://docs.pagelines.com

That will give you some basics.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

  • Similar Content

    • dwpoyner
      By dwpoyner+
      Not sure exactly what is causing the issue. For some reason, why you view my site on mobile, the menu does not show up. It will pop up, but it is black. You can check it out here: http://dev.caryfbc.org. I'm also attaching a screenshot where I shrunk my browser down. Any suggestions?

    • khat
      By khat+
      I think I may have installed pagelines pro incorrectly, and then used features incorrectly. I installed first platforms framework theme and then the child, thinking I could do setup for child later. I tried to set up a background image, and tried custom css feature in pagelines dashboard. I had mistakes in my css, and just thought that if I deleted the info in the css custom feature in pagelines dashboard that the new information would overwrite the old info. The background image didn't respond at all, probably because I didn't have the child directory renamed. I then tried to use the LSS plugin to create css and added more css, possibly, somewhere -sigh-. I never did change the background image and get it placed properly. I used a workaround and in nested containers I placed a background image which worked well enough, so I moved on to try to create my nav bar/ menu bar. When I go to the Menus panel, there is NO area where I can place a menu on a page. I have read and reread and re- re- reread the instructions for placing a menu. I've used the pagelines editor to place a menu, however only HOME shows up. I've been at this for many hours. I've since uninstalled all of my pagelines items and reinstalled, thinking that it would restore all my changes to default, but no, it is still all there, with all my unresolved issues. I am completely at a loss as to what to do next.
    • Jarek
      By Jarek+
      How to make the Impulse menu sticky?
      Here is a site that seems like it is doing just that: http://www.manhattanperiodontist.com/
      Here is the site I am working on: http://boeriu.digitalvector.com/ 
      I have no problem showing the menu at the bottom, but when scrolling up it does not stick.  I tried to add Nav Pro menu but when I do that, it just shows on top and no matter what I try is not working as I want it to.
      Any suggestions?
    • Dave
      By Dave+
      1) Toggle menu on mobile devices does not work properly, combination Chrome 56.0.2924.87 with Android 6.0.1

      2) Mobile / Default Menu > Set the primary/default navigation for your site. This will be used in the pop out mobile menu and as the default in navigation sections. Does not work.
    • David
      By David+
      We are building a long-page scrolling site with Pagelines 5. Our menu is made with # links that go to a container's unique ID, e.g. container_ux7al6g
      This works, but it doesn't look great in the menu. Is it possible to assign a 'nice' # link, e.g. /#solutions ? 
      We used to do this in the DMS2 platform through a workaround, but that doesn't seem to be possible now. 
      Any suggestions? 
×