Jump to content
peter88

Hero nav mobile, tablet device arrows

Recommended Posts

peter88    0
peter88

Hi,

 

i have another question. How can i change the hero nav for mobile, tablet devices because the nav shows all levels at once and i can't use the arrows...

 

Thanks for help

 

Greetings

 

Peter

Share this post


Link to post
Share on other sites
evan    0
evan

Hi peter88,

 

I'm not quite sure what you mean.  Yes in the mobile view, if you have chosen 'hover' for your dropdown trigger, the menu will show all levels fully expanded, so the menu items with arrows will be fully functioning links.

 

If you wish to be able to expand collapse menu levels in the mobile view, you will want to use the 'click' dropdown trigger instead.   A different behavior, but it sounds like that's what you want.

 

 

Let me know if that works for you,

 

 

Evan

Share this post


Link to post
Share on other sites
peter88    0
peter88

Hi peter88,

 

I'm not quite sure what you mean.  Yes in the mobile view, if you have chosen 'hover' for your dropdown trigger, the menu will show all levels fully expanded, so the menu items with arrows will be fully functioning links.

 

If you wish to be able to expand collapse menu levels in the mobile view, you will want to use the 'click' dropdown trigger instead.   A different behavior, but it sounds like that's what you want.

 

 

Let me know if that works for you,

 

 

Evan

 

Hi Evan,

 

sry it was my mistake I have set the option to "click" and it works fine.

 

thx for your quick help

 

Peter

Share this post


Link to post
Share on other sites
peter88    0
peter88

Hi Evan,

 

i have another question about the hero nav. If choose the "click" option how can i set the normal subnav to display on hover and not listing the parent element in the dropdown again (on desktop resolution)?

Could add a new behaviour or setting for this?

 

thank you so much

 

Peter

 

 

Share this post


Link to post
Share on other sites
evan    0
evan

Hi peter88,

 

By normal subnav do you mean the dropdown menus?  

 

The behavior you're describing is the hover dropdown trigger.  It is not currently possible to use different modes for mobile/desktop views.

 

It's possible I may add an option in the future for the dropdown trigger for mobile, but that would only apply when viewed on a real mobile device, not just a responsive viewport change.

Share this post


Link to post
Share on other sites
peter88    0
peter88

Hi Evan,

 

yes by normal subnav i mean the dropdown menus?

The problem is that in mobile resolution all menu items are open so i have a long list of menu items which are shown :(

Is there anything I can do to show on dropdowns on desktop resolution and to show click navigation on mobile resolution?

 

thx

 

Peter

Share this post


Link to post
Share on other sites
evan    0
evan

Currently your best option is to use the click dropdown trigger.  This is currently the only way to get what you want for the mobile resolution.

It sounds like you want your dropdown menus to pop out on hover though in the normal desktop resolution?  This is the compromise you would have to choose.

 

As an alternative, you could use Hero Nav for your top-level navigation, and Sidekick for your secondary/sub levels.  Sidekick specializes in using space efficiently with it's different behaviors and the two are designed to work together!

Share this post


Link to post
Share on other sites
peter88    0
peter88

Ok and is there another way that I could customize it for example? The problem is that we want our dropdown menus to pop out on hover :) in normal desktop resolution.

 

Is it for example possible to override the section in the child theme?

 

thx for help

Share this post


Link to post
Share on other sites
evan    0
evan

The problem is that you want hover drop functionality on desktop resolution, and click-open sub-menus in mobile.

 

Your top level menu items with dropdowns will not be usable links if clicking them toggles a dropdown.  That's the reason that the two modes differ in the mobile view, primarily because they can't work the same way.

 

The only possible solution I can think of would be to add an option that allows you to choose the trigger mode you want to use when viewed on a mobile device, where you would then be able to set that to click.  That would force mobile viewers to get the click navigation you want, regardless of resolution.

 

I will most likely add an option like this to a future release.  When that will come is hard to say.

 

About customizing the section, that is always possible, but you're on your own there.  The only thing you could do in a child theme is create a template.hero-nav.php which would override the section_template only.  That wouldn't be enough for what you want though.  You could move the section from it's store-installed location into your child theme's sections folder where it would then be safe from updates.  You could then modify it to do whatever you want!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • vikzee
      By vikzee+
      Hero Nav 1.3
      DMS 2.1.9.3
      Wordpress 4.2.2
      I just downloaded the latest version of Hero Nav from my Pagelines account but when I try to upload it to the plugins page it gives me this error:
      The package could not be installed. No valid plugins were found.
      Plugin install failed.
      So I unzipped the package and find that all it contains is a README file.
      Can you send me the latest version (vikzee (@AT@) yahoo.co.uk) in it's entirety or re-load it to the Pagelines site so people who've paid for it can get the latest version?
      Thanks! 
    • AppLEaDaY
      By AppLEaDaY
      Hello.
       
      I did not personally install what I'm trying to fix. I'm working on a preexisting installation of WordPress and Pagelines.
      But when I arrived the problem was already there: just upon posts displaying in the hero nav main menu I get a "Home" link not working,
      due to a anchor completely missing the href attribute.
       
      I made some tests and I noticed what follows.
      The same problem occurs with every plain link I add that hero menu (not with pages), I mean with links showed as CUSTOM Curiously enough I found in a sublevel a link of that kind, it has somehow back in the past inserted by someone else, no me: it works just like it is supposed to do No problem of that kind in a fixed navigation bar (I tried to enable it) I underscore the mentioned problem occurs only when displaying posts, not with pages.
       
      Any clues? Since I'm afraid it may take a too long time to fix this specific problem, I also ask: could you possibly point to what I am supposed to read in order to do without the hero nav bar and use some other navigation bar in the same place of the template?
       
      Thanks in advance
       
       
      Andrea
    • limelight
      By limelight+
      Hello, I'm having a strange issue with the background of my Hero Nav drop-down being "see through". Can anyone direct me on how to make this solid black instead??  Thank you! 
       
      Site URL: http://multicolores.org/ And there is a drop-down menu when you hover over 'About'.
       
       
    • ScribbleGD
      By ScribbleGD+
      Hi there,
       
      Whenever I make changes to the formatting options in the Hero Nav section of Site Settings such as font base colour it doesn't appear to change the look of my nav bar,
       
      Any reason as to why this is happening? Screenshot attached.
       
      Thanks.
       
      URL - staging.scribblegraphicdesign.com.au
       
      Tim
       
    • webmktco
      By webmktco+
      Evan,
       
      I've had issues with making edits to the Hero Nav settings for a while now.  I've been able to work around the issue, but I thought I'd bring this to your attention.
       
      Do you know why this is happening and how to fix it?
       
      Here's the debug info: http://josephfoxdds.myddsdev.com/?pldebug=1

      WP: 4.0
      DMS: 2.1.1
×