Sign in to follow this  
Followers 0

Masthead Video

2 posts in this topic

I cannot find a way to get this video:


To autoplay at 100% in the Masthead.


Please assist.


Thank you.



Edited by lookrad

Share this post

Link to post
Share on other sites



While the Masthead is full-width, videos added to it are not necessarily full-width. The size of the video usually depends on proporional sizing, scaling, and other criteria.  I should point out that if it did fill the width, likely you'd find the height would be greater than the visible window of your browser.


You may simply need to do some CSS here, but I'm not sure. 


What code are you adding?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Similar Content

    • Popovers cut off screen edge.
      By respectgb+
      I'm having problems with bootstrap popovers being cut off the edge of the browser. I'm using the latest version of dms (2.2) and this problem occurs on all browsers tested. Please can you let me know how we can fix this?


    • Can I remove the play button that appears on canvas area background images on mobile?
      By crose+
      I am using the Canvas Area section at the top of my site. I have a video playing in the background, which works really well on desktop. But on mobile video doesn't play without user interaction, so I have a static image in place as an alternate image. However when viewed on a mobile device there is now a play button over the static image that does nothing. This didn't use to happen so I imaging it is due to an upgrade. But this is really bad UX. Is there a way to remove it?
      Here is the site:
      Thanks in advance.
    • Is (or will there be) support for responsive tables
      By dawsonbarber+
      I added a table but it was not responsive so I'm wondering if there's a class for this or if there are plans for responsive tables.
    • Video Background
      By Matt C.+
      So I used to use the Video Background extension that was offered here on pagelines, but until recently it continued to function.  Yesterday however it ceased to work and since it has been removed and no longer supported I've been forced to find a new way to show the youtube video that used to be on my background.
      I know that there is the option to upload videos for background, needing both an mp4 and ogv version.  However, since this is a youtube video I don't have any source files to upload.
      I have since turned to using the mb.YTPlayer wordpress plugin.  It seems to be working just fine on its part, as you can see a sliver of it playing just below my footer.  My issue though it that it doesn't show up behind my main body content.  Now it was my understanding that the backgrounds were defaulted to transparent in DMS2 and that this shouldn't be happening.  I've tried several CSS transparency codes to no avail, so my question is how am I able to get the video that is showing up right beneath the footer in other areas?  Either on a section by section basis or for the entire body?
    • Powerloop layout w/ video
      By clj182+
      I'm having trouble getting my Powerloop layout the way that I want...
      I'd like to have the same layout as the question below but instead of an image I'm using video.
      I have my media shortcode above everything but the title is still above it in my page and when I inspect it.
      My settings:
      [powerloop_title class="plHtxt" align="center"] 
      [powerloop_content class="plHContent" align="left"]
      [powerloop_author class="plHauthor" align="left"] | [powerloop_date format="F j, Y"]
      Another problem I am having is that I cant create space between the video and the content..If i add padding or an margin to my content class it adds that spacing to the video as well.
      Any ideas on how I can fix this?