Jump to content

Archived

This topic is now archived and is closed to further replies.

andersen3

Bring RevSlider navigation to the front

Recommended Posts

andersen3    0
andersen3

Hi,
 
I am trying to figure out the new DMS before I activate it on my real website, but have run into a small problem.

I am in other words currently running DMS on a local server.
 
Anyhow, I have made some small changes to my local site using custom CSS-coding. One of the things I have done is that I have placed my branding section, navigation and a text box on top of the revslider to give that part of my site a nice transparent effect. Please see this photo for reference: 

Screen-Shot-2013-07-29-at-2.48.08-PM.png

Now, I had to use custom CSS-coding to place the revslider underneath all the other elements in the header section, which worked. However, the slider controls/navigation still seem to be placed behind or underneath the actual slider, making it impossible to actually use the controls since they are invisible.
 
I suspect my custom CSS coding to be the problem:

.revslider-container {
width: 100% !important;
position: relative;
padding: 0;
max-height: 724px !important;
min-height: 724px !important;
overflow: visible;
margin-top: -161px;
z-index: -2;
}

Any idea how I get the slider controls to appear on top of the revslider again, yet the revslider is layered underneath the rest of my header elements?

 

Thanks!

- Christian

Share this post


Link to post
Share on other sites
Rob    547
Rob

Hi Christian,

 

As you doubtlessly know, each element has its own CSS code.  If you're using tools like Chrome Inspection or Firebug for Firefox, you should be able to find the right element, and likely will need to set a different z-index for the controls.

 

I hope this helps.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
andersen3    0
andersen3

Thanks a lot Rob. I tried setting a different z-index for the controls on the slider, but with no success. I can't seem to place the revslider underneath my textbox, branding and navigation without the slider controls disappearing. 

 

Any idea how I should proceed to get this issue fixed?

 

Thanks!

Share this post


Link to post
Share on other sites
Rob    547
Rob

When you say "underneath" do you mean as a background?  It is not a background slider. It is a full-width slider.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
andersen3    0
andersen3

No, not as a background. The slider is functioning the way I want it - as a fullwidth slider. I can however not get the controls/slider arrows to appear on top of the actual slider images. It seems like they are layered below the Revslider images. For better understanding, please have a look at my website here: www.creativefuturemag.com

 

Thanks

Share this post


Link to post
Share on other sites
Danny    1,327
Danny

HI,

 

z-index only works on positioned elements.

 

http://www.w3schools.com/cssref/pr_pos_z-index.asp

Therefore, if you have't used this, then using z-index is pointless.

Please bear in mind that we do not provide support to user created custom code. I would do as Rob suggested and use Chromes web dev tools.


Please search our forums, before posting!

Share this post


Link to post
Share on other sites

  • Similar Content

    • JawDesigns
      By JawDesigns
      Hi everyone,
      Flywheel have reported errors on my clients site 'www.racewaredirect.co.uk' and it's not loading. Can someone please provide some information on how to fix this? The site has never experienced these issues before.
      Thanks,
      James Wilson
    • MissT
      By MissT+
      Hi there,
      I've got an issue with 3 websites built with DMS since I migrated them from http to https that I need help with please.
      When any changes are made - e.g. new posts added or existing posts amended - certain sections of the live site seem to break e.g. image headers hang and don't load (b/g on canvas section), sliders hang and don't load (Revslider), flipper section doesn't load.
      Logging in and then clicking 'Edit the site using DMS' seems to fix the problem. Often if I try to open up another browser window to edit the site / re publish I'm unable to as the page wont load / hangs while trying to load.
      Any ideas how to fix this? On a couple of the sites I've installed a caching plugin as I thought it might be a loading speed issue but it's still happening.
      Website URL's can be provided privately.
      Many thanks in advance.
    • jeomiland
      By jeomiland+
      Hi
      I found this topic
      which talks about a similar issue I am having, but a little different. Hope someone can help me out.
      Best way to see the problem is to view http://cassclayton.com/ on Safari (Mac) compared to Firefox or Chrome. You will see the banner just under the fixed menubar has a gap between the menubar and top of the banner. Looking at Inspector, I found:
      <div class="fixed-top-pusher" style="height: 62px;"></div>
      <script> jQuery('.fixed-top-pusher').height( jQuery('.pl-fixed-top').height() ) </script>
      and indeed it seems the jquery is not always working consistently. For instance, if you simply refresh the page in Safari, it will loose the gap and all looks fine, so is it a browser cache issue that is interacting with the jquery? I do have W3 Total Cache installed. There must be a way to tell the code to make sure jquery is up and running and available to do it's majic?
      And perhaps there is just a better way to do this banner? Originally I tried several DMS sections and used the banner image as background, etc... Kept running into problems with resizing and the left/right parts of the image were getting chopped off. It is important the whole image show, so currently I just use a NextBox section with this code:
      <img src="[pl_site_url]/wp-content/uploads/2015/12/CassClayton-blues-tribute-banner.jpg" width="100%" />
      and it looks the way it should. Is there a better way to place a banner graphic under a fixed navbar and make sure the whole banner graphic displays regardless of screensize?
       
    • oseehys
      By oseehys+
      Hello There,
      So i want to use platform 5 and DMS sections on a single page, i am using a child theme with pinspro as my main theme and i activated platform 5, the only problem am having so far is the fixed option, my navbars are not aligning to their default size, and it will be great if platform 5 header and footer section will function, has anyone used this option, how can i make the best use of platform 5 and DMS on a site
      Cheers
    • kwaoru
      By kwaoru
      Hi,
      I desperately need to deactivate the responsive function on mobile for reasons. It looks so messy with the responsive look on mobile and not navigating or informative at all as it is. 
      I searched for solutions online and tries some of those that I found but nothing worked out. Also I found a previous post on this forum says that this theme pagelines DMS is not meant to be build to deactivate the responsive function... 
      Also tried with widget such as WPtouch to edit the mobile look a little more informative but as I am using "single page" theme on pagelines, the frontpage(main page) never appears on those app.
      Seems like not compatible?
      If there is no way to deactivate responsive function or I'll have to recreate another page just dedicated for a mobile page? or change the theme completely and build a page from scratch?
      I have been searching for this for two days already...
      Could anyone wise and kind out there, please help me?
       
      Thanks,
×