Jump to content

Archived

This topic is now archived and is closed to further replies.

bobbekaer

WooCommerce not showing grid

Recommended Posts

bobbekaer

Hi :-)

 

I am working on a site trying to show WooCommerce products in a grid - not as a list. I have tried using the WooCommerce shortcode and the Pageline plugin for WooCommerce but they show up the same way. i guess somehow pagelines is overruling the grid-setting. 

 

Anyone with ideas or experience on how to solve it? It is quite ruining the page :-(

 

The address is http://leanspil.dk - login: arbejder

 

;-)

 

Bolette

 

 
 

Share this post


Link to post
Share on other sites
Rob

Hi Bolette,

 

I presume you're still in Framework and have not migrated to DMS.

 

With all that's been going on, I'm not sure what is happening, so it could be related to our recent crashes or to the updates we've made due to DMS. 


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
bobbekaer

Hi Rob,

 

Yes, this project is still in Framework - I was actually hesitant to migrate to DMS - I thought it was two very different platforms? I am very close to finishing this project, so I would like to make as few changes as possible. 

 

I have experienced the same problem on another project 2 month ago. 

 

 

 

 

Share this post


Link to post
Share on other sites
Rob

You're still using the WooCommerce/PageLines Integration then, right?


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Rob

I'll get someone on this.  Thanks for your patience. 


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
ellenmva

Hi Bolette,

 

Yes, the WooCommerce for Pagelines plugin fixes the single row issue on the Shop page but not when you use the shortcode.  To fix the issue on the home page put this code in Pagelines --> Site Options --> Custom Code --> CSS/LESS.

.home .hentry {
	clear: none; /* Fix for columns not rendering */
	}

Let me know if that fixes the issue.

 

Ellen


Ellen Moore

Pagelines Developer

www.elsue.com www.betterdms.com

Share this post


Link to post
Share on other sites
bobbekaer

Hi Ellen,

 

Thank you. I tried it and it makes no difference. Have I understood it right:

  • I should have the WooCommerce Plugin activated
  • I insert the code
  • and should be able to use the WooCommerce short code?

I would like to use the shortcode for showing the featured products. I do hope there is a solution...

 

Bolette

Share this post


Link to post
Share on other sites
ellenmva

Hi Bolette,

 

I tried looking at your site but the WooCommerce for Pagelines plugin is throwing an error and can't access your site. I'm not quite sure why it is doing that but to get rid of the error, remove the plugin from your wp-content/plugins folder.

 

Are you upgrading the site to DMS? That could be the reason for the error, you don't need the WooCommerce for Pagelines plugin for DMS, WooCommerce works natively with DMS.

 

Ellen


Ellen Moore

Pagelines Developer

www.elsue.com www.betterdms.com

Share this post


Link to post
Share on other sites
bobbekaer

Hi Ellen

 

Something is all wrong on this site  :-) So just to calm myself I made a local install with DMS and WooCommerce and it seems to work - I can use the shortcode for showing featured products and it works fine.

 

I think this is the way to go...

 

But thank you for your help :-D

 

Bolette

Share this post


Link to post
Share on other sites
hugo2808

Hi all,

I'm facing the same issue!

With framework and pagelines plugin for woocommerce activated I get always a product for row.

I've tryed to put the css referenced by ellenmva but no sucess.

 

If I desactivate the plugind and change theme for Twenty Thirteen I get all products displayed in a grid correctly.

 

Who can this be fixed in pagelines framework??

 

Thanks

Share this post


Link to post
Share on other sites
Rob

@hugo2808  please open a new topic.  This one is already closed and we want to give you the best possible answers.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

  • Similar Content

    • Jessica McCabe Lawson
      By Jessica McCabe Lawson+
      I'm building a product catalog site. The featured image is set correctly, but the woocommerce placeholder image is displaying instead. If I click on the placeholder image, the featured image appears, and the featured image works fine as a thumbnail.
      Please view the site here: http://www.directmat.net/product/power-lock-logo-mat/
      Note: I deleted the placeholder image via FTP to see if that would inspire Quick Shop to look for the featured image. No such luck. Please help!
    • mtaus
      By mtaus+
      I'm using Woocommerce in a Pagelines framework. When I build out a product, I'm able to add images in the admin panel and the
      Product Image will display on Shop page, but neither the Product Image nor the Product Gallery will display on the product's dedicated page.
      Shop: https://bendbotanics.com/shop/
      Product Example: https://bendbotanics.com/product/500mg-full-spectrum-hemp-oil-fsho/
      Any help would be greatly appreciated!
    • cdracos
      By cdracos+
      Hello everyone,
      I face a common problem as I can see on relevant topics with quickshop plugin. 
      On Product Single page of woocommerce, i use quickshop as layout. The primary photo of my product doesn't appear on the thumb slider, but the first image is the default placeholder. 
      Need some help not with custom script in the product description for each product. 
      Have a look on my website: http://lillyandsid.gr/shop/camp-things-top/
    • bnapoli
      By bnapoli+
      I have Quickshop installed on my WooCommerce section of this website: http://a04.125.myftpupload.com/
      Main Shop: http://a04.125.myftpupload.com/?page_id=1198
      I've having what appears to be CSS issues on the individual product pages. After cleaning up any code accessible from the wp-admin, the page still appears broken. I never tried to customize it, it just came broken like this right out of the box.
      You can see examples of it broken on every single product page, see here:
      http://a04.125.myftpupload.com/?product=futaba-14sg-14-channel-2-4-ghz-radio-system
      http://a04.125.myftpupload.com/?product=gremsy-gstabi-h7-brushless-3-axis-gimbal
      http://a04.125.myftpupload.com/?product=dji-inspire-1-zenmuse-x5-gimbal-and-camera-unit
      http://a04.125.myftpupload.com/?product=dji-wookong-m-flight-controller
      Can somebody help?
    • King Creative Design
      By King Creative Design+
      I am setting up a Woocommerce site using PL Framework and Platform 5. I added a hook so the category description appears under the category page titles (on archive pages). However, it also appears under the title on the main "shop" page (which I have renamed "Catelog" page). There is a default description here and I can't figure out for the life of me where it is being generated from so I can change it. Any ideas how to change it or delete it on the main shop page ONLY? The staging site is here - http://16e.117.myftpupload.com/ and the page in question is http://16e.117.myftpupload.com/catalog/
      I have hit up Woocommerce support and they weren't familiar with Platform 5 and recommended I contact you.
      Your help would be appreciated, thanks!
      Michele

×