Jump to content
suburbanite

NavBar Issues

Recommended Posts

suburbanite    0
suburbanite

Again, total newb so forgive me if I'm asking about something obvious. I placed the NavBar section on my site, but I do not see anything in the customization area about getting rid of the colored line that goes underneath the menu items when you hover over them. Also, the menu bar has a shadow under it that I'd like to get rid of. Any help you can provide would be great. Thank you! 

Share this post


Link to post
Share on other sites
batman    389
batman

Hi subrurbanite

 

You have the option to change the color from
Global Option> Nav bar> Fixed NavBar Theme
see the image
 
You can also change the color or change from
Custom Code
see this
 
You can see more information here
 
For example you get rid it add in your customize code
.navbar.pl-color-base .navline > li:hover > a, .navbar.pl-color-base .navline > li.current-menu-item > a, .navbar.pl-color-base .navline > li.dropdown.open > a { box-shadow: none;}
 

My exemplary code is not necessarily applicable as written, to your site, so please adjust accordingly.


Life is too short to remove USB safely ...

Share this post


Link to post
Share on other sites
ppotent    5
ppotent

Hey Batman,

 

I'm in same situation. I followed your suggestions, but when I click on the custom code, as per your screenshot (https://lh5.googleus...55.44%20PM.jpeg), it's just empty. How do I access the css for the navbar so that I can change it?

 

Thanks in advance.

Share this post


Link to post
Share on other sites
batman    389
batman

Hi ppotent

Yes, your custom code are empty.

You need write your own CSS code.

 

You can see more information here

 

If you need more CSS help, make sure you've downloaded Firebug for Firefox

http://getfirebug.com/css

 

and check out W3 Schools for more info. 

http://www.w3schools.com/


Life is too short to remove USB safely ...

Share this post


Link to post
Share on other sites
ppotent    5
ppotent

Hi Batman,

 

Thanks for your reply. I appreciate it. The only problem is, even with the css tutorial and the w3 schools, I don't know the tags of the pagelines fixed navbar, so can't really do anything.

 

thanks anyway.

Share this post


Link to post
Share on other sites
suburbanite    0
suburbanite

@Batman:

Thanks for your help, I used the code you provided and it worked to get rid of the color bar underneath the menu. As far as i can tell the code should also work to get rid of the shadow, but it doesn't seem to be working for some reason.

Share this post


Link to post
Share on other sites
batman    389
batman

Hi suburbanite

 

I don't understand the shadow you get rid.
You can add a image and you can provide a link to your website please, if this is possible.
Sorry for I don't understand.
:)

Life is too short to remove USB safely ...

Share this post


Link to post
Share on other sites
suburbanite    0
suburbanite

@batman 

I'm using DMS through a MAMP server, so it's not online anywhere. I don't know how helpful it is, but here's an image of what I'm talking about. This is after implementing the exact CSS code you mentioned earlier.

 

[URL=http://s29.photobucket.com/user/suburbanite/media/pl_zps0a234326.jpg.html]pl_zps0a234326.jpg[/URL]

Share this post


Link to post
Share on other sites
Rob    547
Rob

Even with Mamp, with Chrome, you should be able to use the inspection tools, or Firebug for Firefox to view the CSS/code for that shadow. Once you see it, you can copy, edit and paste it to the Custom Code section.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • oseehys
      By oseehys+
      Hello There,
      So i want to use platform 5 and DMS sections on a single page, i am using a child theme with pinspro as my main theme and i activated platform 5, the only problem am having so far is the fixed option, my navbars are not aligning to their default size, and it will be great if platform 5 header and footer section will function, has anyone used this option, how can i make the best use of platform 5 and DMS on a site
      Cheers
    • Grant Turck
      By Grant Turck+
      Navbar Broken on All Devices When Not Logged Into Wordpress. See screenshots attached from mobile. What is causing this issue and how do I fix? Site is venicepride [dot] org.


    • yemoonyah
      By yemoonyah+
      Hi,
      I tried to make a simple change on my opt-in page today by reordering two sections.
      Now they won't save and whatever I do, the same 2 section will be stuck to the top.
      This is a huge problem since it is my opt-in page!
      http://yemoonyah.com/quiz
      (I'm on the latest WP & PL version)
      Thanks.
       
    • Anthony King
      By Anthony King+
      I have to say that I like the Layout and the Template based sections. Some of them are really impressive.
      One of the things that I would like to request though is the possibility of being able to dynamically rearrange the layout.
      An example of what I am talking about is take the Agency Section. It's current layout starts with the
      Splash Module then the Portfolio Module then the Service Module and so on and so forth.
      What would be great is if we were able to move these modules around. I.e have the Service Module first
      then maybe the Splash, and then the portfolio.
       
    • PierreFF
      By PierreFF+
      Hello, 
      I have an issue with NavPro on mobile when the link of the menue is on the same page. 
      Here is my website: http://foundersofthefuture.co
      The isssue comes from the fact that in my menue most of the items send somewhere else on the same page using anchor link (eg. #container_u788888). 
      This works well on desktop but on mobile, nothing happens when clicking on the link. One of the link of the menue of the homepage "France" sends to another page of the website and this one works well even on mobile. 
      I am using the Pagelines framework theme and also used a wordpress plugin (jQuery Smooth Scroll) for smooth scrolling . 
      Thanks in advance for your help and let me know if I need to provide more information. 
      Best,
      Pierre
×