Jump to content
Sign in to follow this  
andulka

Slideshow header

Recommended Posts

andulka

I'm wondering if it's possible to get a fading slideshow, something like this working on the Station Pro theme? I've tried a couple of plugins, such as Flashfader, but can't figure out where to place the code in the header.php for it to show, or should it go somewhere else altogether? Or maybe there's a plugin you know that would do the job? The site where I'd like to add this is here.

Share this post


Link to post
Share on other sites
catrina

Hi, It's possible to put it in header.php if you would like it above the navigation link menu. Do you still have Flashfader installed?


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
andulka

Yes, I do, or rather, I have a test blog where I carry out these experiments so that I don't mess up anything too badly, an once and if I get something working, I just carry the same thing out on the actual site. :-) The flashfader is installed there at the moment. Yes, I would like to have it in place of the header photo, above the menu tabs. There are several similar banner type photos of the band on that same hill top in slightly different poses, and I think they would make a nice effect and add to the visual interest of the front page while waiting for them to decide what they _really_ want there, and for more media material to become available. :-)

Share this post


Link to post
Share on other sites
andulka

It doesn't have any permanent theme as such, but I can activate it temporarily for testing purposes, if I need something Station Pro specific. It's a restricted access blog visible only to myself and with no actual content, so I can change it according to whatever is currently needed. The actual blog in question was hacked just this week (quite a few blogs on the same server were, apparently) and after that I'm even less willing to risk messing things up so that I would need to re-install everything once again, especially as it looks like a transfer to a better maintained and more secure server is due sooner rather than later...

Share this post


Link to post
Share on other sites
catrina

Hi, If you activate StationPro on your test blog and install the Flashfader plugin, you can test how the slideshow works and see how you like it. I can direct you to where the slideshow can go in the header.php file.


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
andulka

I've already done that, but haven't yet been able to figure out where to put the code, so would be great if you could help with that. :-)

Share this post


Link to post
Share on other sites
catrina

In the Flashfader control panel (under "Posts" on the left side of your Dashboard) upload the images you want (if you haven't done so already). At the bottom, you'll find this code:

<?php include (ABSPATH.'wp-content/flashfader/flashfaderhtml.txt'); ?>
This is the code that you paste into the header.php file. Copy and paste it directly below this code in the file:
<div id="header" class="fix">


Please read the docs before posting. Please do not private message me unless I ask you to.

Designer | Catrina Dulay

Founder | Catrina and Mouse

Share this post


Link to post
Share on other sites
andulka

No, that doesn't seem to work. All I get is an empty white box (or whatever colour is chosen as the background colour), if the 'XHTML-valid flash embed' is set to 0, if it's set to 1, there isn't even any box visible. I've tried several different dimension and it should be the right size (and the box in fact is), it's just that no photos are showing.

Share this post


Link to post
Share on other sites
cmunns

Why don't you use the built-in feature slider to get this effect? Are there considerations that are stopping you from using it?

Share this post


Link to post
Share on other sites
andulka

Do you mean the feature page? (could also be I've missed something, haven't had that much time to familiarise myself with the theme with the hack attack last week and stuff... If you mean the feature page, that's not quite what I'm after as it's the header that i would like to replace on all pages, not affecting the actual page content itself. If I've missed something, then please could you point me to the right direction! :-) Also I've been experimenting with the festure slider with some videos and the effect is somewhat twitchy, have to check if there's a thread about that...

Share this post


Link to post
Share on other sites
bryan-hadaway

In the Feature Setup page, you can indeed change the transition effect, there are many different effects to choose from, including what you're trying to do I believe. Thanks, Bryan

Share this post


Link to post
Share on other sites
andulka

But as I've just explained, I don't want a feature page but a header, and if I can turn the Feature Setup into a header slider, then I don't have a clue as to how and would appreciate some pointers. Please see the link in my first post for the type of thing I'm after (maybe 3 photos and a bit faster transition effect, but that's the idea - a changing header to replace the static one).

Share this post


Link to post
Share on other sites
cmunns

My mistake. We could modify the theme to put the slider in the header but to be honest it would seem easier to just continue with troubleshooting the plugin you have. so going back to :

No, that doesn't seem to work. All I get is an empty white box (or whatever colour is chosen as the background colour), if the 'XHTML-valid flash embed' is set to 0, if it's set to 1, there isn't even any box visible. I've tried several different dimension and it should be the right size (and the box in fact is), it's just that no photos are showing.
Is there a link I can see. Perhaps the image paths are not correct despite there being an image uploader?

Share this post


Link to post
Share on other sites
andulka

There's no link at the moment, as obviously I couldn't leave a blank white bar or an empty space there, but I'll take a look and get back to you. Another thing I noticed was that as I have to remove the custom header in order for it to be replaced by the slider-wana-be (rather than it showing on top of the header), the site name becomes visible and that is not a desired effect either, as they want their name to appear on the header and possibly one of the slideshow photos would be a banner with just the band's name in the same font as on the current header here.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×