Jump to content
Sign in to follow this  
robinonholiday

Website home page is live but all other pages still on temporary address

Recommended Posts

robinonholiday    1
robinonholiday

Hello Pagelines gang

 

Website URL: http://www.dancebiodanza.co.uk
Framework Version: 2.4.3
WordPress Version: 3.5.1
Plugins in Use: NextGen, Poppy, Better Carousel
Server/Host: www.ecowebhosting.co.uk

 

I have been building the site at a 'temporary address' on the above hosting service  http://176.32.230.24/dancebiodanza.co.uk/

 

For some reason when I changed the nameservers for the site, only the homepage address changed. I emailed the problem to my server/host (see below). I tried to act on his suggestion (I won't give you the details as didn't resolve it).

 

I hope you can point me in the right direction. I am very new to the 'back office' side of websites.

 

This site is suppose to go live tomorrow!

 

On 22 July 2013 18:30, Robin Shaw <robinonholidayyahoo.co.uk> wrote:

Hiya Rob
 
I just (finally!!) changed the nameservers for dancebiodanza.co.uk.
 
I typed in the live address: www.dancebiodanza.co.uk and was pleased to see the site was already showing!
 
But.

When I clicked some of the pages I saw that they were still linking to the TEMP address: 'http://176.32.230.24/dancebiodanza.co.uk/about-biodanza/welcome-to-biodanza/'
 
I thought they would all update - relationally? Is that what they are suppose to do?

All the best
Robin
 

From: Rob Percival <enquiries@ecowebhosting.co.uk>
To: Robin Shaw <robinonholidayyahoo.co.uk>
Sent: Monday, 22 July 2013, 19:07
Subject: Re: Website home page live but all other pages still on temp address?
 

Dear Robin,
 
I suspect that's because in your CMS (Wordpress, Joomla etc) you have set the URL to include the IP address. If you change that in the settings that should fix it. If you've written in the URLs yourself you will need to update them manually.

Kind regards,

Rob

www.ecowebhosting.co.uk
 

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

It could take a few hours (maybe 24+) for the DNS changes to take effect. 

 

Rob Percival from Eco Hosting suggests changing the permalink settings. Go to Wordpress > Permalinks and click save, (make no changes) and let us know if this fixes the problem. 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
robinonholiday    1
robinonholiday

Hi Martin

 

Thanks for replying. I checked out the permalinks already. I really don't think that is the solution. They don't deal with the DNS/IP issue. I'm not having a problem with the page names themselves - it's the IP/DNS address that isn't changing. I have had a good go at trying the various fixes I found in the forums etc - what to do when you move your site etc - but nothing has completely addressed the problem.

 

So unless some miracle or info appears before tomorrow am, I will delete the site and start afresh.... :-P At least I have all the content already!

 

Thanks again.

Robin

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

Did you move the site or just repoint the URL at you other install? 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
Rob    547
Rob

Robin,

 

When migrating a site, the migrated files include dynamic links that point to the source site. This is how WordPress works.  When you complete the migration, a standard practice is to go to Dashboard > Settings > Permalinks, where you do not change the permalink structure (no changes at all), and just save.  This updates all dynamic links that WordPress has created to the current location of your site.

 

It has nothing to do with IP addresses, as things in WP are not based on IP addresses.  Though you are seeing an IP address in the URL, that is because it's the URL from the source, and thus it is the dynamic address WP picked up.  You'll be pleased to know that when you simply save the Permalink settings without any changes, those addresses will update and all links will reflect the new IP unless you manually added them.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
robinonholiday    1
robinonholiday

Hello Martin and Rob

 

Thank you very much for thinking about my problem!

 

Yes I want to migrate the whole site - not just point the domain at the existing site.

 

When I can get access to my WP admin area I will give the permalinks another go!

 

Given the situation with Pagelines servers, I am very grateful that my client was happy for me to focus on other promo activities this week (taking photos of the event he was hosting etc) rather than on getting the new site launched..!!

 

I will mark this question as solved. If I get joy with the permalinks I will let you know!

 

Thanks again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Similar Content

    • David
      By David+
      We are building a long-page scrolling site with Pagelines 5. Our menu is made with # links that go to a container's unique ID, e.g. container_ux7al6g
      This works, but it doesn't look great in the menu. Is it possible to assign a 'nice' # link, e.g. /#solutions ? 
      We used to do this in the DMS2 platform through a workaround, but that doesn't seem to be possible now. 
      Any suggestions? 
    • ipitts
      By ipitts+
      Greetings! 
      We are using Pagelines >> DMS2 theme. We are using the DMS2 Media Box module on several pages throughout our site. The media box includes an image thumbnail with hyperlinked text (below the thumbnail - located in the embedded HTML text editor).  We would like for users to be able to click on the image in addition to the accompanying text. Is there a way to add a hyperlink on the image itself?
      Please see the attached screenshot. You'll see we have "Compatibility Matrix" thumbnail image & text within the "Text & Embedded HTML" section that provides an <a href="...."></a> to direct visitors to another page. 
      We tried to follow this post (http://slickmedia.co.uk/blog/glenns-blog/pagelines-dms-mediabox-add-link/), but it did not help us solve our challenge. 
      Thank you very much for your help,
      Marie Thiele
      Marketing Coordinator, Syn-Apps LLC
      480-355-6822
      mthiele@syn-apps.com
      media box.tiff
    • mnagillum
      By mnagillum+
      As noted elsewhere on the Forum, the Media Box section doesn't have an option to enter a hyperlink to link to another page on my site, ndtest.mamulligan.com. Can someone please advise me on the exact code to use in my child theme (or Jetpack Appearance file) to make the five media boxes (Program Design, etc.) clickable links to the five corresponding areas shown in the menubar? Thanks in advance for any/all help.
       
       
    • saur0
      By saur0
      Hi, 
       
      I have set up a website asolve.it and have another domain name which I wish to use with it asolveit.co.uk, I have set up a domain alias with my hosting provider, but when I visit the site the pagelines images are not visible. Is there anything I can do to resolve this situation.
       
      Thanks,  
    • jharri74
      By jharri74+
      Hello,
       
      Like a lot of people, I have built my wordpress (version 4) website in it's own folder. Not the top level of the hosting server.
       
      The domain was still pointing to the old website also in it's own folder. While i was building the the new website, the IP address/folder(http://s446863904.onlinehome.us/WP) was pointing to the website i was building. I eventually pointed the domain (http://envymeremy.com) here.
       
      Thats when things got a little screwed up. Especially when I made the change in wordpress general settings.
       
      WordPress Address (URL): http://s446863904.onlinehome.us/WP
      Site Address (URL): http://envymeremy.com(formerly the same as above)
       
      So after fixing the 505 and 404 issues (editing the .htaccess file in top level of this website) that now follow changing the url, the first thing i noticed was that the fonts weren't embedding.
       
      In my child theme's css file, i had to change:
       
      @import url("../dms/style.css");
      @import url("fonts/stylesheet.css");
       
      TO:
       
      @import url("../dms/style.css");
      @import url('http://envymeremy.com/wp-content/themes/jayharry_theme-child/fonts/stylesheet.css');
       
      The pagelines font/symbols  for dropdown and slider arrows aren't loading.

       
      So now whats happening is, when I launch the dms editor, it goes to a page that "does not exist". I'm thinking thats because the homepage was http://s446863904.onlinehome.us/WPand is now http://envymeremy.com/.
       
      When i click on the links in the navigation (Home, about us, etc), it takes me to the page, but I don't get the dms editor with options to add anything, edit the sections or anything. Just the page as i would see it if i were not logged into wordpress.
       
      I'm using:
      wordpress 4
      DMS 2 with a child theme
      hosting: 1and1.com plan: 1&1 Unlimited
       
       
       
       
       
       
×