Jump to content
Sign in to follow this  
Michael Paul Henderson

Using Multiple Buttons On A Page | Button Shortcodes

Recommended Posts

Michael Paul Henderson    0
Michael Paul Henderson

I ran in to a problem with button shortcodes several months ago while working on a site for a client. At that time, time was of the essence so I worked around the issue.
 
Same problem has reared it's head again.
 
When using multiple button shortcodes on a page is where I run into problems. The url, button type, color...any attribute actually, is corrupted. Is it not possible to have multiple buttons on the same page that have differing button text, link, color, etc. attributes?
 
A link is worth a thousand words, here are two. You may need to look at the page source for more.

 

My attempts to remedy:

  • PL version is up to date
  • Plugins active/inactive no change
  • Multiple browsers - i.e., ff, chrome, opera, etc.
  • Multiple button types

I"m toast - Any help is appreciated.

-Paul

Share this post


Link to post
Share on other sites
Rob    547
Rob

Hi Paul,

 

You're toast? It was 114 degrees F here about an hour ago. Cooled now to a balmy 110 in the Northeast.  Phew!

 

You should be able to include multiple shortcodes for buttons in every page or post.  Your attached image is so small I can't read anything in it.  Could you simply snapshot the edit field, that we may read the shortcodes you're adding?

 

Thanks.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Michael Paul Henderson    0
Michael Paul Henderson

Rob,

 

114 degs - glad you made it through! Thanks for getting back at me. I think if you simply click on the image you can zoom in on it. Here's a link to a better image.

 

http://patrickfarber.com/screenshot.png

 

Here ya go.

Share this post


Link to post
Share on other sites
Rob    547
Rob

Michael,

 

I tested it on my site and think you've found a bug.

 

Oddly, the [pl_raw] and [/pl_raw] tags are the culprits here.

 

Initially, I added the shortcodes directly from our Tools page.  Well, not really directly. I copied them to a Notepad and stripped out the prefixed empty spaces, then pasted the cleaned up code to a page in the site.  I did this with all the button types.  It was fine.

 

Then, in my second go, I added the pl_raw codes and each button was identical.

 

Lastly, I stripped out the pl_raw code and voila!  Everything was perfect.

 

I'm going to report this ASAP!!!!

 

Thanks for your patience.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Michael Paul Henderson    0
Michael Paul Henderson

The Tools Page "copy-paste-notepad-strip-copy-paste" is the preferred method on my end too. Wish I could say I am happy to help on the bug thing - not so much. Ha.

Thanks for your diligence! And by all means - please advise.

Share this post


Link to post
Share on other sites
Rob    547
Rob

Michael,

 

You don't need to worry about the bug testing.  All you need to do is remove the [pl_raw] and [/pl_raw] and you'll see positive results on your page.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Similar Content

    • bnapoli
      By bnapoli+
      On my site www.anewbeginning.com the "toggle" function mysteriously stopped working.  I have tried all browsers, tried disabling plugins, removing all the relevant CSS but still cant understand why it isn't working.
      The toggle is placed on this page: http://anewbeginning.com/?page_id=15965 and http://anewbeginning.com/?page_id=10779 but it does not display.
      On my other Platform5 websites, that exact code works fine: see here http://4aa.d11.myftpupload.com/?page_id=123
      Code is the same. Please help, thank you!
    • micstepl
      By micstepl+
      Pagelines seems to "disallow" the (a) usage and/or (display) of shortcodes.
      Specifically I need shortcodes in "description" of "tag/catagory" in order to display images/fontawsome, before a category.
      Please can you provide a fix for me to allow. 
    • mrhinsh
      By mrhinsh
      Guys,
       The ProPricing plugin does not seam to render shortcodes.

       
      I am using WP-Types, and as you can see the shortcode is rendered in the "Elements" but not in the "ProPricing".
      Can we get a fix?
    • micstepl
      By micstepl+
      @Simon I do have an urgent request for a client Projekt. After migrating (before it worked) my site to anpother Server I get problems will all ShortCode Sections.
      See this Problem here: http://www.baumeister-scheidl.at/map-try
      thanks in advance!
      Maybe ist a User (MY) fault.
    • globalnative
      By globalnative+
      Hi everyone
      I used to love the Pagelines DMS shortcodes for creating tabs and accordians. 
      It doesn't seem to work in this version of pagelines 5?
      Is there another way to get that functional?
      Thank you kindly
      Nate
×