Jump to content
ghostdancer

Admin CSS Issue, PageLines 2.4.4 w/ WordPress 3.5.2

Recommended Posts

ghostdancer    0
ghostdancer
PageLines admin.css overrides WordPress CSS; background CSS shorthand property assigns explicit given values and sets missing properties to their initial values.
 
Due to the added <body> class 'toplevel_page_PageLines-Admin'...
 
<body class="wp-admin wp-core-ui js pagelines_ui toplevel_page_PageLines-Admin folded auto-fold admin-bar branch-3-5 version-3-5-2 admin-color-fresh locale-en-us no-customize-support">
 
...the PageLines CSS...
 
./wp-content/themes/pagelines/admin/css/admin.css?ver=2.4.4 (line 127)
 
.toplevel_page_PageLines-Admin .wp-menu-image{
background: transparent url('../images/favicon-pagelines.png') no-repeat 50% 50%;
background-size: 20px 20px;
}
 
...is overriding WordPress CSS, changing the background style for ALL elements with the wp-menu-image class on the admin page (not just PageLines elements), and resulting in corrupted admin menu backgrounds.
 
Given the PageLines HTML...
 
<li id="toplevel_page_PageLines-Admin" class="wp-has-submenu wp-has-current-submenu wp-menu-open menu-top toplevel_page_PageLines-Admin menu-top-first menu-top-last">
<a class="wp-has-submenu wp-has-current-submenu wp-menu-open menu-top toplevel_page_PageLines-Admin menu-top-first menu-top-last" href="admin.php?page=PageLines-Admin">
<div class="wp-menu-arrow"><div></div></div>
<div class="wp-menu-image"><br></div>
<div class="wp-menu-name">PageLines</div>
</a>
...
...changing the PageLines CSS by adding the anchor element, or using the id attribute of the li element instead of the class attribute, resolves the issue...
 
./wp-content/themes/pagelines/admin/css/admin.css?ver=2.4.4 (line 127)
 
a.toplevel_page_PageLines-Admin .wp-menu-image{
background: transparent url('../images/favicon-pagelines.png') no-repeat 50% 50%;
background-size: 20px 20px;
}
 
Is this a PageLines bug or am I missing something?
 

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there,

 

I'll ask one of our developers to take a look at the code you've provided, if you could send a screenshot of how it's displaying as well we'll forward this over to them as well.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
ghostdancer    0
ghostdancer

Images attached. As per code in earlier post, the PageLines admin.css replaces the WordPress styles for WordPress items when the PageLines menu page is selected.

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

Thanks for the update 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      every since Chrome introduce scroll anchoring (see chrome://flags) blog posts on my page start scroll automatically as soon as the user scrolls down a bit. It is super annoying and I don't know exactly what triggers the incompatibility with Chrome's latest feature that is supposed to improve usability.
      Since I don't know what causes it (Pagelines, or a Plugin), I would like to disable the feature using a CSS override that Google describes as follow:
      "Scroll anchoring aims to be the default mode of behavior when launched, so that users benefit from it even on legacy content. A CSS property overflow-anchor can disable scroll anchoring in part or all of a webpage (opt out), or exclude portions of the DOM from the anchor node selection algorithm. This property supports the following values when applied to an element E:
      overflow-anchor: auto (the default value) declares that the DOM subtree rooted at E is eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E. overflow-anchor: none declares that the DOM subtree rooted at E is not eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E." Do you guys happen to know how to use that property with the ROOT element so it applies to the whole page?
      Thanks
      Michael 
    • wyo22ski
      By wyo22ski+
      Hello,
       
      I'm basically a designer and understand a little on how to change CSS, etc., so please excuse my ignorance...  I recently upgraded to the newest platform from the DMS and my old DMS theme no longer functions.  I'm trying to replace the image slider that my Horizon Photography Theme (Nick Haskins) had created.  The Impulse image slider seemed the closest to what I need, but there are problems.
      It seems the the Impulse section for sliding images defaults to the image width, no the height.  I can change the Impulse stage height and width, but this does nothing to the internal content.  For instance, if I change the height to 200 pixels, the image remains the full width and only shows a cropped section.  I would like the ability to change the Impulse height, and have the image height fit space. 
      I've put this custom CSS in, but again, this only controls the stage height of Impulse:
      .pl-sn-impulse .pl-impulse-cell .cell-wrap, .pl-impulse-container, .owl-stage-outer {
        width: 100%;
      }
       
      Any suggestions welcome.  Thanks 
    • Objectif-Mariage
      By Objectif-Mariage+
      Hello. 
      I have just realized that CSS (Less plugin) , is not working..... I have disable all plugins (except PL CUSTOM LESS and PL5) , and ... it's not working ... 
      It's not the first time. Usually I had trouble with a plugin name Autoptimize , but it's Desactivate now , all memory have been purge, and it's still not working! :-/ So it's not from this plugin. 
      NB : When I am logged on my website, if i go on the black wordpress dashboard bar, go on the PL icon, clic on </> LESS/CSS => then the page suddenly apply the CSS .... But As soon that i reload the page, nothing. I think the problem is that the plugin LESS/CSS does not load properly (if I can say that with my simples words).
      I order to keep the site "good looking" I have temporally copy/paste all my LESS code in a plugin : Script n Styles that apply the LESS/CSS code... but it's not a solution for long time.
      Can someone help me ? Did I do something wrong ? Is it an update ? 
       
      my website : https://www.wedding-photography-minneapolis.com
    • Jason
      By Jason+
      Feel free to delete this post if its not helpful or its just plain wrong.
       
      I though it might be useful to share how I customize the size of the builder. (reduce my eyestrain )
      1 - install stylerbot extension in chrome (stylerbot keeps this css every time you access the url)
       
      2- add this css to stylerbot for the site you are working on
      .CodeMirror {
          font-size: 14px;
          height: 600px;
      }
      .pl-workarea.pl-has-sidebar .pl-workarea-sidebar-container {
          right: 0px;
          width: 500px;
      }
      .pl-workarea.pl-has-sidebar .iframe-container {
          right: 500px ;
      }
       
      change sizes to suit.
       
      Cheers.
    • Jason
      By Jason+
      Hi.
      I can't seem to get the Teamwork section to accept custom css. I am trying to change the padding from 7em to 1em on the splash part
      I have tried
        .pl-sn-teamwork .pl-tw-splash {
          padding-top: 1em;
          padding-bottom: 1em;
        }
       
      This works in chrome inspect but when added to custom css nothing happens.
      I have also tried most of the classes I can see accoiated with this section but again nothng seems to happen.
      Any ideas?
×