Jump to content

Archived

This topic is now archived and is closed to further replies.

bscherr

Hero Nav broken in Internet Explorer

Recommended Posts

bscherr+    7
bscherr

My hero nav is broken in IE. Attached is a screenshot.  Unfortunately my site is on a development server, so I have copied my hero nav css here as well.  I am not a CSS expert, so I can't really see what I'm doing wrong.[attachment=1236:IE_HeroNav_Problem.PNG][attachment=1237:CSS_HeroNav.txt] 

 

Can someone help me with this? Thanks!

Share this post


Link to post
Share on other sites
evan    0
evan

Greetings bscherr,

 

Are you using the latest version of the section?  It looks like the css is not taking effect at all.  Have you customized it at all or you're working within the available options?

 

 

Evan

Share this post


Link to post
Share on other sites
bscherr+    7
bscherr

Hi Evan, Thanks for the reply.  Yes I just checked that i have the latest version of Hero Nav and everything is up to date.  And I am only working with the available options.  If it helps, I could ask that my site be moved over to a production (public facing) server so you could see how it looks in Firefox, Safari, and Chrome and also see any of the code.  The good news is that we are a University site, so the vast majority of users are either Safari, Firefox, or Chrome... but there are still plenty of stubborn IE users out there.

 

I am poking around in the CSS for elements near it that could possibly effect it, but somewhat futilely.

 

Blythe

Share this post


Link to post
Share on other sites
bscherr+    7
bscherr

Hi,

Hero Nav still does not appear to be displaying correctly in IE.  I really need to fix this, because right now I am using a plugin to block and redirect IE users, but I can't do that long term because we are a University, and as such my environment is rife with faculty (who are technology dinosaurs insistent on using IE).  Unfortunately, my reality is that their opinion matters.  Our site is now public.  Could you please take a look and see if there's anything I can do?  Again, i am running the most current version of the section).

 

My site is here: http://honors.syr.edu

 

Thanks for any help you can provide,

Blythe Scherrer

Share this post


Link to post
Share on other sites
evan    0
evan

I hear ya.  As far as I know, Hero Nav displays properly in IE 9 and above.

 

I'm aware there is a problem with older versions, and I'm looking into a possible solution.

The reality is that Hero Nav is designed for modern browsers.  If you require full compatibility with every version of IE, I don't think Hero Nav can meet that need.

 

PageLines support for IE is IE8 and above, so that is the version I am trying to extend functionality to.  Officially, there is no PageLines requirement for for legacy browser compatibility.

 

I'll let you know what I find!

Share this post


Link to post
Share on other sites
bscherr+    7
bscherr

Hi, Sorry I should have clarified.  SU runs IE 8.0 (that is the browser I am running) and that is where the program is, so it should work right? 

Share this post


Link to post
Share on other sites
evan    0
evan

There IS currently a problem with IE 8, I'm looking into it :)

Share this post


Link to post
Share on other sites
bscherr+    7
bscherr

Ok thanks very much! I love Hero Nav, it's gorgeous on our site and works really well too!

Share this post


Link to post
Share on other sites
evan    0
evan

Hey there bscherr, 

 

I see your site is using Framework 2.4.4.  To get enable compatibility with IE 8, go to Site Options and enable the Google IE Compatibility script.

 

lzXVvmA.png

 

That should do it!

Share this post


Link to post
Share on other sites

  • Similar Content

    • dloos
      By dloos+
      ONEPAGE has visual errors in IE, objects do not stay separated, and image elongated on next section.  Any Suggestions?  It is coming up with this error from Pagelines on site. 
       
    • arno
      By arno+
      Site that looks great on other browser, are is rendered wrong on IE: http://foodfunded.us/
      We got multiple complaints.
      The height of sections is way too high. Not sure which section is causing the problem, as they are in containers.
      Or is the size of the images?

      While most of us probably don't use IE, it might prevent professionals from getting client engagements with the PL5 tool, if the browsers don't have coverage.

    • MissT
      By MissT+
      On more than one website I'm building there is a massive blank space after the content and pagination within the loops section when viewed on Internet Explorer 11. It looks like the loops-wrap section is about twice the depth it needs to be. Screenshot attached.
      Can provide url via private message.
      WP version 4.4.2
      Platform5 Version 5.0.132
      Loops version 5.0.18
      Many thanks.

    • Audun MB
      By Audun MB+
      This is a boxes section with media at left in IE11
      :
      Boxes with media on top works without issues. 
       
    • Audun MB
      By Audun MB+
      Heroes section acts crazy sometimes. Here's how it looks in IE 11.

      This looks OK, even though it has the same setup as the one above. Only difference is the hero image:

      On the same page, there's another hero section where things act up again, this time with 3 sections. Looks crazy:

       
       
×