Jump to content
Sign in to follow this  
kimishima

The secondary sidebar is in the bottom of the page.

Recommended Posts

kimishima    0
kimishima

Hello.

 

The secondary sidebar is placed in the bottom of the page.

Please look at the screenshot. It's the screenshot of the bottom of the page.

It's not fixed by any settings in PageLines.

 

Please let me know what should I do to fix it.

Share this post


Link to post
Share on other sites
Rob    547
Rob

Hi Kimishima,

 

When this happens, there are two possible causes.

 

1.  HTML in some part of your content (in the post or in a sidebar) is broken or incomplete.

2.  An image in an area is set wider than the container, causing the container to bleed into the other area, and pushing one down.

 

Check the HTML in your post or in any widget you've added using an HTML validator.  Even a missing </a> can cause a break.

 

If there is an image,  if the image is 500px wide, and the container (like the sidebar or content area) is 450px wide, then the image will force the extra 50px to push the sidebar below the content area, making sure it has room to expand.  Check any set widths you have for images, or anything else within the content areas or text widgets, or the width of other widgets if they have settings for width.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
kimishima    0
kimishima

Thank you for your reply, Rob.

 

But, there's no 1 or 2 you said.

The widget is empty as in the screenshot.

And there's no html error for posts.

 

Is there other reason that causes the error?

Share this post


Link to post
Share on other sites
Rob    547
Rob

Could you provide a link to the page where this happens? I'll take a look. 


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Rob    547
Rob

Hi,

 

It looks fine in Firefox, IE10 and Chrome on my Windows machine. I do not see anything in the right sidebar.  But, I do see the calendar on the left sidebar and that appears to be pushing to the right edge of the left sidebar.   That might be the problem.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
kimishima    0
kimishima

Thank you for your reply, Rob.

 

I edited the widget. Please look at the bottom, again.

Share this post


Link to post
Share on other sites
Rob    547
Rob

I see it.

 

Please go to Dashboard > PageLines > Store.

 

You will probably see that the screen is asking you to install the PageLines Sections plugin. Please install it.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
kimishima    0
kimishima

Thank you for your reply, Rob.

 

I've done it, but the problem is not resolved.

What should I do next?

Share this post


Link to post
Share on other sites
greenfly    230
greenfly

Please can you remove the maintenance mode plugin and we can advise further. 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites
kimishima    0
kimishima

Thank you for your reply, Martin.

 

I'm sorry for that. I deactivated the maintenance mode.

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there,

 

Looking in the source code, your site is set to full width in the layout - http://screencast.com/t/zZ5DPrWMt4Bz

 

What items/sections do you have in the sidebar container, it looks like there's a primary and secondary sidebar and the item which is falling under the page is in the secondary sidebar container.

 

I would say your best bet is to try hiding/un-publishing some of your posts to see if any code inside them is causing the sidebar to fall below, sometimes html can effect the layout of the page. Try creating a new static blog page and assigning that as the new posts page in settings>reading, does the same happen?


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
kimishima    0
kimishima

Thank you for your reply, James.

 

I've done as you said, but there's no change...

http://ossblog.jp/

 

Is there any other way to fix?

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there, if you could take some screen shots of your drag and drop on that template so we can see what's present in the sidebar section and enable the debug option in Pagelines>site options>advanced and drop us the debug url. Its not clear that there is anything wrong in the source code from what i can see.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

×