Jump to content
Sign in to follow this  
jenske

Pageless cause slow loading speed of sites

Recommended Posts

jenske    0
jenske

I have 5 sites that is setup the same. Recently I have noticed two of them load between 4-5sec longer than the others.

 

Host: IPage. (Everything is updated) Sites: memyselfandpeke.com and innerpeke.com

 

I have WT3 Cache installed and MaxCDN. I have also read all your topic forums on this and docs.

 

According to tools.pingdom.com the slow speed is due to the Pageless, which with the WT3 now off load 4-6sec on its own- with it on still 3-4sec.

 

I do not understand why I get this problem on only these two sites and have no idea what to look for or how to fix this (I am not a developer).

 

Can you give me any suggestions on what to do to fix this.

Share this post


Link to post
Share on other sites
Rob    547
Rob

Hi,

 

Both sites loaded instantly for me.  Did you clear your browser cache?

 

Please snapshot the pingdom.com report, so we can see what exactly is causing the issue. Thanks.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
Rob    547
Rob

Nevermind, I got the report.

 

Pageless is sitting there, waiting 2.01 seconds for a javascript to load from this plugin forms.aweber.com/form/17/. The plugin is evidently taking so long to load that Pageless cannot complete its compilation, waiting for the CSS from the form plugin.  It sounds like that form may be your problem.  Deactivate it temporarily.  Run the pingdom test again and see if you have improvement.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites
jenske    0
jenske

Hi. I deactivated the aweber plugin. It seems that it is not the cause of the pageless problem.

 

I have been comparing it to my two "working" pageless sites (which are basically the same as these two) to see if I can find the error.

 

The two "working" sites do test 520ms and 718ms respecitively and do not even bring up the pageless file.

 

Any other options for me?

Share this post


Link to post
Share on other sites
jenske    0
jenske

It does seem to have a correlation with the html also loading longer. But once again, if you look at the sites,

they are extremely similar. I have no idea why these two html docs would be different. They are the same size

as the others.

Share this post


Link to post
Share on other sites
jenske    0
jenske

I have to rectify my previous post - I re-enabled my cache plugin and it sorted out the html size.

 

So it is not related to the pageless css problem.

 

Can you tell me what file this is and where I should look for it. This is slowing my sites down.

 

Or can I disable it somewhere - restart it?

Share this post


Link to post
Share on other sites
James B    436
James B

Hi there, Pageless is a store product, so I've moved your thread in to the store product forum so the developer can advise further for you.


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites
jenske    0
jenske

It has been 3 days now. And I haven't heard a word. Pageless still causing 2 sites to be slow. I had loading times of 16sec and 20sec.

Can anyone help me with this?

Share this post


Link to post
Share on other sites
Jenny    33
Jenny

This is not related to a Store product. Pageless is the LESS/CSS processed by PageLines.

 

Looking at your site, you do have a few obvious issues.

 

First, when I load your home page, the URL changes to http://memyselfandpeke.com/#sthash.WErgBsYc.dpbs.  Obviously not pretty and extra stuff being added from somewhere. Culprit here is a plugin.

 

Also, you're showing a shortcode in your post excerpt. Should correct that as well.

 

You have ultimate tinymce installed but I don't even think it works with PageLines. I recommend disabling all plugins so we can check your site then.

 

Moving this back to the right forum and closing your other topic.


Jenny :: Web designer at Simple Mama (follow me at @simplemamacom)

Check out Share Me, a social sharing add-on for DMS that is super simple to set up.

Share this post


Link to post
Share on other sites
jenske    0
jenske

Ok I started with my site "innerpeke.com" - I disabled all plugins, removed the shortcodes, my css styling and the load in the url.

 

The sit still load 4secs - all that is left is pagelines theme, modern them (child theme) and a few picture that I uploaded.

Share this post


Link to post
Share on other sites
jenske    0
jenske

Ok I now removed my modern child theme and replaced it with the base child theme - so not the childtheme either

Share this post


Link to post
Share on other sites
Rob    547
Rob

Hi,

 

I understand your frustration, but you must understand that not everything wrong with your site is PageLines' fault. 

 

Please see a current Pingdom test just done minutes ago (below)

[attachment=1220:7-9-2013 2-26-24 PM.jpg]

 

This shows clearly that nearly 2 seconds of your load time comes directly from the domain, which means it precedes the actual loading of PageLines. As you can see, pageless doesn't even begin to load until after the domain is loaded.  That's clearly indicative of a server issue, not a software issue on our side.

 

Your host has probably assigned insufficient memory resources to your PHP allocation.  It should be a minimum of 64Mb, but I'd recommend at least 128Mb.  The max is 256Mb.

 

In the image below, you will see that 77% of your load time is dedicated to waiting.  While there is about 1 second wait for pageless,  that could be due to memory resources as well, or, it could be due to erroneous CSS.  As Jenny pointed out, you did have some mistakes in your site.  They can cause a problem.   Please consider that before PageLines loads, WordPress must load too.  If there are plugins in WordPress, they will, in many cases, load even before PageLines, as they may be part of the operating system, like a cache plugin.

[attachment=1221:7-9-2013 2-26-50 PM.jpg]

 

When I replied to you several days ago, and recommended a solution, you didn't mention you had a cache plugin activated.  When a change is implemented you absolutely must clear the plugin cache afterwards or the change will not be seen.  This is critical, as it makes the support we give you useless until your cache clears.  If that's set to 24 hours, you wouldn't see the changes for a day.  Most cache plugins operate on 30 minutes, but still, that's half hour you'd not see what we've guided you to do.

 

I must point out that while James did not post anything further, our developers have been rather busy and didn't reply to him.  He said he'd respond when he knew and I assure you that he's excellent at following up.  Support in a forum is not instantaneous.  It can take days to get replies from busy developers. I apologize for the inconvenience, but that's the honest truth.   I might point out that our forums are responded to very quickly, compared to those in other companies where even an initial reply can take days or even weeks.

 

In conclusion, I recommend contacting the host, and showing them that first attachment I've provided. Ask them to upgrade the amount of RAM allocated to PHP resources.  Again, Pageless is not the problem here.

  • Like 1

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Similar Content

    • Michael Kummer
      By Michael Kummer+
      Hi guys,
      every since Chrome introduce scroll anchoring (see chrome://flags) blog posts on my page start scroll automatically as soon as the user scrolls down a bit. It is super annoying and I don't know exactly what triggers the incompatibility with Chrome's latest feature that is supposed to improve usability.
      Since I don't know what causes it (Pagelines, or a Plugin), I would like to disable the feature using a CSS override that Google describes as follow:
      "Scroll anchoring aims to be the default mode of behavior when launched, so that users benefit from it even on legacy content. A CSS property overflow-anchor can disable scroll anchoring in part or all of a webpage (opt out), or exclude portions of the DOM from the anchor node selection algorithm. This property supports the following values when applied to an element E:
      overflow-anchor: auto (the default value) declares that the DOM subtree rooted at E is eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E. overflow-anchor: none declares that the DOM subtree rooted at E is not eligible to participate in the anchor node selection algorithm for any scrolling box created by E or an ancestor of E." Do you guys happen to know how to use that property with the ROOT element so it applies to the whole page?
      Thanks
      Michael 
    • wyo22ski
      By wyo22ski+
      Hello,
       
      I'm basically a designer and understand a little on how to change CSS, etc., so please excuse my ignorance...  I recently upgraded to the newest platform from the DMS and my old DMS theme no longer functions.  I'm trying to replace the image slider that my Horizon Photography Theme (Nick Haskins) had created.  The Impulse image slider seemed the closest to what I need, but there are problems.
      It seems the the Impulse section for sliding images defaults to the image width, no the height.  I can change the Impulse stage height and width, but this does nothing to the internal content.  For instance, if I change the height to 200 pixels, the image remains the full width and only shows a cropped section.  I would like the ability to change the Impulse height, and have the image height fit space. 
      I've put this custom CSS in, but again, this only controls the stage height of Impulse:
      .pl-sn-impulse .pl-impulse-cell .cell-wrap, .pl-impulse-container, .owl-stage-outer {
        width: 100%;
      }
       
      Any suggestions welcome.  Thanks 
    • Objectif-Mariage
      By Objectif-Mariage+
      Hello. 
      I have just realized that CSS (Less plugin) , is not working..... I have disable all plugins (except PL CUSTOM LESS and PL5) , and ... it's not working ... 
      It's not the first time. Usually I had trouble with a plugin name Autoptimize , but it's Desactivate now , all memory have been purge, and it's still not working! :-/ So it's not from this plugin. 
      NB : When I am logged on my website, if i go on the black wordpress dashboard bar, go on the PL icon, clic on </> LESS/CSS => then the page suddenly apply the CSS .... But As soon that i reload the page, nothing. I think the problem is that the plugin LESS/CSS does not load properly (if I can say that with my simples words).
      I order to keep the site "good looking" I have temporally copy/paste all my LESS code in a plugin : Script n Styles that apply the LESS/CSS code... but it's not a solution for long time.
      Can someone help me ? Did I do something wrong ? Is it an update ? 
       
      my website : https://www.wedding-photography-minneapolis.com
    • Jason
      By Jason+
      Feel free to delete this post if its not helpful or its just plain wrong.
       
      I though it might be useful to share how I customize the size of the builder. (reduce my eyestrain )
      1 - install stylerbot extension in chrome (stylerbot keeps this css every time you access the url)
       
      2- add this css to stylerbot for the site you are working on
      .CodeMirror {
          font-size: 14px;
          height: 600px;
      }
      .pl-workarea.pl-has-sidebar .pl-workarea-sidebar-container {
          right: 0px;
          width: 500px;
      }
      .pl-workarea.pl-has-sidebar .iframe-container {
          right: 500px ;
      }
       
      change sizes to suit.
       
      Cheers.
    • Jason
      By Jason+
      Hi.
      I can't seem to get the Teamwork section to accept custom css. I am trying to change the padding from 7em to 1em on the splash part
      I have tried
        .pl-sn-teamwork .pl-tw-splash {
          padding-top: 1em;
          padding-bottom: 1em;
        }
       
      This works in chrome inspect but when added to custom css nothing happens.
      I have also tried most of the classes I can see accoiated with this section but again nothng seems to happen.
      Any ideas?
×