kimishima

I can't save any settings of PageLines

24 posts in this topic

Framework Version:V2.4.4
WordPress Version:3.5.2
Plugins in Use:Only Akismet, Hello Dolly, and WP Multibyte Patch
Server/Host:heteml (Japanese hosting service)
Details:
Hello.
I want to do setting in PageLines' site option.
But, if I click "Save Options", there's "Saving..." message, but it
doesn't finish.
I challenged again and again. But I can't save any settings.
Please let me know what should I do to fix this error.
 

Share this post


Link to post
Share on other sites

Hello kimishima,

 

If you can, please go to Dashboard > Plugins > Installed Plugins.   Deactivate all the plugins (except the ones by PageLines).  Then, go to Dashboard > PageLines > Site Options and test a setting change, and save.  See if it saves right away.  If it does, then you have a plugin conflict.

 

You could then re-activate the plugins, one at a time, checking the process of saving settings after each re-activation.  If you cannot save again, then the last plugin you re-activated is the one causing the problem.  You'll have to replace that plugin. You can continue re-activating after that, leaving the bad plugin deactivated or deleted.

 

If you do not see any change after deactivating, please let us know.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

Hello, Rob.

 

Thank you for your reply.

 

But, all plugins are already deactivated.

Can I do something else?


Share this post


Link to post
Share on other sites

You can try a reinstallation of PageLines.  Do you have FTP access?


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

Thank you for your reply, Rob.

 

Yes, I have FTP access.

I installed PageLines in Appearance > Themes > Install Themes > Upload > Install now.

Is it wrong?


Share this post


Link to post
Share on other sites

It is not wrong, but it may not have been a perfect installation.

 

I recommend:

1. Go to your Launchpad account by logging into: http://pagelines.com/launchpad/member.php

 

2. From your account, download the latest version of PageLines Framework. Close your browser (to clear the cache).

 

3. Unzip the file to your desktop.  You will see a new folder there called pagelines.

 

4. FTP to your site and navigate to wp-content/themes/ and find the pagelines folder there.  Delete the entire folder.  Your settings will not be affected. This can take a few minutes.

 

5. When the deletion is completed, transfer the pagelines folder from your desktop to wp-content/themes/.  This too, can take a few minutes.

 

6. As soon as the file transfer is completed, open your browser and go to Dashboard > PageLines > Site Options.  Change a setting and save. See if the issue is resolved. It should be.

 

Please let us know how this procedure goes.

1 person likes this

Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

Thank you for your reply, Rob.

 

I reinstalled PageLines on that way, but the error is not fixed, I can't save any settings.

Is there other way to fix it?


Share this post


Link to post
Share on other sites

Try going to Pagelines > Site options > Advanced and clicking 'enable debug'

 

once you have done this let us know 


The answer to many issues can be found by searching in the forum before posting as someone else  may very well have had the same problem before you have.  Also, reading the documentation can help you gain a good understanding of how everything works. 

 

Please do not send me private messages. Occam's razor - The principle states "Keep things simple!"

Share this post


Link to post
Share on other sites

Thank you for your reply, Martin.

 

I checked the "Enable debug", and click "Save options", but it's not saved.

Is there other way to make it "Enable debug"?


Share this post


Link to post
Share on other sites

FTP into your site, and go to wp-config.php.  Open it in a text editor,

 

Find this line:

define('WP_DEBUG', false);

Change it to:

define('WP_DEBUG', true);

Save the file and re-upload it.

 

View your site.  Any bugs or errors will then show.  Copy the errors (in full) and paste them here.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

Thank you for your reply, Rob.

 

I edited wp-config.php as you said.

But, there's no error or bugs is shown in my site.

This is my site.

http://ecommercesuccess.biz/


Share this post


Link to post
Share on other sites

Is your Dashboard in English or Japanese?

 

Do any errors show on the Dashboard or in the PageLines Dashboard?


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

Thank you for your reply, Rob.

 

No errors are shown on the Dashboard or in the PageLines Dashboard.

 

What should I do next?


Share this post


Link to post
Share on other sites

If your site's Dashboard is in English, create a new administrator level user in Dashboard > Users > Add New.

 

Send it to robert@pagelines.com and I'll take a look to see what I can find.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

Thank you for your reply, Rob.

 

I created your administrator user account and the email is sent to robert@pagelines.com.

Please check it.


Share this post


Link to post
Share on other sites

Hi,

 

I've checked everything, installed the Sections plugin, which worked.  Tested installing a section and child theme, which both worked. But I can't get your Site Options working either.  I have asked our developer to look into this.  He won't be in until tomorrow, as far as I know. 

 

As soon as I hear back from him, I will update.  Thanks for your kind patience with this.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

Thank you for your reply, Rob.

 

OK. I wait for it.

I appreciate your such effort. Thank you very much.


Share this post


Link to post
Share on other sites

Your server configuration is blocking ajax requests via POST

http://screencast.com/t/8YBpUDJuk

 

You need to contact your host.

1 person likes this

Share this post


Link to post
Share on other sites

Thank you for your reply, Simon.

 

OK. I got it.

I asked it to the host. They doesn't allow AJAX.

I will move the data to another server.

 

Thank you very much for all your suport.

This problem is resolved.


Share this post


Link to post
Share on other sites

Great.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

Hello.

 

I'm sorry, but there's another problem.

 

I checked "Disable AJAX Saving?" on the server that allows AJAX.

And I exported the settings and imported on the server that doesn't allow AJAX.

 

I think I can save options in this way because AJAX is already disabled.

But, if I click the "Save Options" there's "403 error Forbidden" page.

The page's URL is "http://ecommercesuccess.biz/wp-admin/options.php"

So, I can't save any settings even in this way.

 

What should I do to fix this error?


Share this post


Link to post
Share on other sites

Hi there,

 

Otherwise it could be mod-security. I've found another post on the forum which relates to this and provides a solution, take a look at - http://www.pagelines.com/forum/topic/27162-getting-404-on-pagelines-page-options/


Kindly search the forum and read the documentation before posting. It will help you resolve many issues.

For CSS help be sure to check out W3Schools first and be sure to download FireBug for FireFox for troubleshooting.

James B

Share this post


Link to post
Share on other sites

Thank you for your reply, James.

 

This problem is resolved by editing WAF settings on the hosting service.

Anyway, thank you for your support.


Share this post


Link to post
Share on other sites

On James' behalf, you're very welcome.  I'm glad this has been resolved.


Former PageLines Moderator, Food Expert and Raconteur

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now